synergy: update to 1.10.3

Bug fixes:
6546 Filtered out self assigned ip addresses from being displayed
6541 Fixed connected info text to include without TLS encryption
6527 Config app renders incorrectly on high DPI screens
6526 New TLS/SSL socket handled when no socket
6525 Race condition on disconnecting TLS/SSL socket
6521 Access violation in TLS/SSL socket close
6409 Server freezes when clipboard contains an image
3705 Hotkeys not working on Mac server
Enhancements:
6535 Version URL and added stage check to version check
6529 Cleaner redistributable use in Windows installer
6528 More verbose message for Linux display errors
6524 Minimize config app to system tray
6523 Restore auto hide on startup for config app
6522 Double click Windows tray icon to show and hide
6520 Support for 32-bit Linux for legacy users
6519 Support for Ubuntu 14.04 LTS for legacy users
6390 Support for OpenSSL 1.1.1 for better security
This commit is contained in:
tnn 2019-09-04 11:58:54 +00:00
parent 803579ce86
commit 853c09e348
3 changed files with 19 additions and 16 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.56 2019/08/22 12:23:41 ryoon Exp $
# $NetBSD: Makefile,v 1.57 2019/09/04 11:58:54 tnn Exp $
DISTNAME= synergy-core-1.10.2
DISTNAME= synergy-core-1.10.3
PKGNAME= ${DISTNAME:S/-core//}
PKGREVISION= 3
CATEGORIES= net x11
MASTER_SITES= ${MASTER_SITE_GITHUB:=symless/}
GITHUB_PROJECT= synergy-core

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.29 2019/07/18 16:04:43 nia Exp $
$NetBSD: distinfo,v 1.30 2019/09/04 11:58:54 tnn Exp $
SHA1 (synergy-core-1.10.2.tar.gz) = ad236af38aa2b24f21ebab19abcf67a95e602bcf
RMD160 (synergy-core-1.10.2.tar.gz) = 06216e1e22be7427e041017e3d08ae26243d2708
SHA512 (synergy-core-1.10.2.tar.gz) = adf2f0fd3319d81d16384a0b44a23b03b5f118aa4ada6acfd16149d8dba0a79f2685bd25bc0a9b571564e0cf1abde9997cfc94aadb4da5592040e242268dbffc
Size (synergy-core-1.10.2.tar.gz) = 6700286 bytes
SHA1 (patch-CMakeLists.txt) = 69a702eb389c92104e1cdbe6be8a059dcc7d8765
SHA1 (synergy-core-1.10.3.tar.gz) = fc406fb77e0b89d156b2d8cd5e978a3e90be7ddb
RMD160 (synergy-core-1.10.3.tar.gz) = f6d588c7b6d780dac7f0ccb2612b4e2100a1a161
SHA512 (synergy-core-1.10.3.tar.gz) = 01497fe362395dd9d26d44f7468ca5c01ee7cd2f590b6c28a67e094f969fdca3b8f78570cca4f188c16fc2575ca895daf8d6ffd07378964ed01da1540db05c8e
Size (synergy-core-1.10.3.tar.gz) = 7596446 bytes
SHA1 (patch-CMakeLists.txt) = 09d8e49897c99fba3e7f9b58da72b6d3f6e3c4f1
SHA1 (patch-src_lib_server_CConfig.cpp) = 94c5e9a57f9880ab8fcb75320bd2dbb306540966
SHA1 (patch-tools_gmock-1.6.0_configure) = 0a3a23076b15858b79a8b3c2a9144ddaaad7ebe3
SHA1 (patch-tools_gmock-1.6.0_include_gmock_internal_gmock-port.h) = 70d0f775e952a67b2680c480f757e60eb183e5be

View file

@ -1,10 +1,10 @@
$NetBSD: patch-CMakeLists.txt,v 1.2 2019/07/18 16:04:43 nia Exp $
$NetBSD: patch-CMakeLists.txt,v 1.3 2019/09/04 11:58:54 tnn Exp $
Don't use hardcoded paths for finding libcrypto and libssl.
--- CMakeLists.txt.orig 2019-05-09 16:52:59.000000000 +0000
--- CMakeLists.txt.orig 2019-09-03 08:41:49.000000000 +0000
+++ CMakeLists.txt
@@ -279,32 +279,7 @@ endif()
@@ -279,36 +279,7 @@ endif()
#
# OpenSSL
#
@ -18,12 +18,16 @@ Don't use hardcoded paths for finding libcrypto and libssl.
-
- include_directories (BEFORE SYSTEM ${OPENSSL_ROOT}/include)
- set (OPENSSL_LIBS
- ${OPENSSL_ROOT}/lib/libeay32.lib
- ${OPENSSL_ROOT}/lib/ssleay32.lib
- ${OPENSSL_ROOT}/lib/libssl.lib
- ${OPENSSL_ROOT}/lib/libcrypto.lib
- )
-elseif (${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
- set (OPENSSL_ROOT /usr/local/opt/openssl)
-
- #Try use 1.1 for the latest features. otherwise use the default
- IF(EXISTS /usr/local/opt/openssl@1.1)
- set (OPENSSL_ROOT /usr/local/opt/openssl@1.1)
- else()
- set (OPENSSL_ROOT /usr/local/opt/openssl)
- endif()
- include_directories (BEFORE SYSTEM ${OPENSSL_ROOT}/include)
- set (OPENSSL_LIBS
- ${OPENSSL_ROOT}/lib/libssl.a