g95: preliminary support for FreeBSD-12, minor rototilling.
Don't fail in configure.
This commit is contained in:
parent
837faef49e
commit
853c7bc96e
3 changed files with 16 additions and 12 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.25 2015/12/29 23:34:46 dholland Exp $
|
||||
$NetBSD: distinfo,v 1.26 2016/09/27 20:51:11 maya Exp $
|
||||
|
||||
SHA1 (g95_source.tgz) = b5e503fd6459b65cbda73190685f9490230d9cff
|
||||
RMD160 (g95_source.tgz) = 98d03e9a1835f4b3553a72a798bdf1d90a757176
|
||||
|
@ -12,10 +12,10 @@ SHA1 (patch-ab) = 7429a4da26aa573dcdd94bf417da1e009f95d273
|
|||
SHA1 (patch-configure) = 48450808201d4ea5ddb993627c4efeaf43d53bd2
|
||||
SHA1 (patch-g95spec.c) = d6f434e715835cd39511c45ed18632c8401b78a2
|
||||
SHA1 (patch-gcc_Makefile.in) = cc5cc142a85612ebf2d38513e4b05db0ae795268
|
||||
SHA1 (patch-gcc_config.gcc) = 36d6af33ee7997d67179090114dfd8fc3e403a74
|
||||
SHA1 (patch-gcc_config.gcc) = ed135c425730d231182e36af840278d307396c6e
|
||||
SHA1 (patch-gcc_config_dragonfly-spec.h) = bf0c97caa314714542cf8cc63fdf0c73bda80511
|
||||
SHA1 (patch-gcc_config_dragonfly.h) = 6d46b7b4637a20b36e19a15e1eaffdfff6638de9
|
||||
SHA1 (patch-gcc_config_freebsd-spec.h) = 58eb1a97c243da253f7be070521ed4b6ea6c2c76
|
||||
SHA1 (patch-gcc_config_freebsd-spec.h) = 508304b26b592518c3d3f43f466ac0a6542b2704
|
||||
SHA1 (patch-gcc_config_i386_dragonfly.h) = 7d60d29b5ae636d69650e8c412a94f7a6045f6d9
|
||||
SHA1 (patch-gcc_config_i386_dragonfly64.h) = 9d2d8512a913e58055fa5c1b7d85a109117dcfba
|
||||
SHA1 (patch-gcc_config_t-dragonfly) = dd8d5919af737dfb9e3c18be9a41b4e2c6f31155
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
$NetBSD: patch-gcc_config.gcc,v 1.3 2015/10/07 10:36:54 sevan Exp $
|
||||
$NetBSD: patch-gcc_config.gcc,v 1.4 2016/09/27 20:51:11 maya Exp $
|
||||
|
||||
Darwin 64-bit support.
|
||||
DragonFly BSD support.
|
||||
FreeBSD 10 & 11 support.
|
||||
FreeBSD 10 to 12 support.
|
||||
|
||||
--- ../gcc-4.1.2/gcc/config.gcc.orig 2006-10-15 23:12:23.000000000 +0000
|
||||
+++ ../gcc-4.1.2/gcc/config.gcc
|
||||
@@ -412,6 +412,10 @@ case ${target} in
|
||||
@@ -412,6 +412,12 @@ case ${target} in
|
||||
tm_defines="${tm_defines} FBSD_MAJOR=8" ;;
|
||||
*-*-freebsd9 | *-*-freebsd[9].*)
|
||||
tm_defines="${tm_defines} FBSD_MAJOR=9" ;;
|
||||
|
@ -14,10 +14,12 @@ FreeBSD 10 & 11 support.
|
|||
+ tm_defines="${tm_defines} FBSD_MAJOR=10" ;;
|
||||
+ *-*-freebsd11 | *-*-freebsd11.*)
|
||||
+ tm_defines="${tm_defines} FBSD_MAJOR=11" ;;
|
||||
+ *-*-freebsd12 | *-*-freebsd12.*)
|
||||
+ tm_defines="${tm_defines} FBSD_MAJOR=12" ;;
|
||||
*)
|
||||
echo 'Please update *-*-freebsd* in gcc/config.gcc'
|
||||
exit 1
|
||||
@@ -440,6 +444,23 @@ case ${target} in
|
||||
@@ -440,6 +446,23 @@ case ${target} in
|
||||
esac
|
||||
fbsd_tm_file="${fbsd_tm_file} freebsd-spec.h freebsd.h"
|
||||
;;
|
||||
|
@ -41,7 +43,7 @@ FreeBSD 10 & 11 support.
|
|||
*-*-linux*libc1* | *-*-linux*aout*)
|
||||
# Avoid the generic linux case.
|
||||
;;
|
||||
@@ -981,6 +1002,8 @@ hppa[12]*-*-hpux11*)
|
||||
@@ -981,6 +1004,8 @@ hppa[12]*-*-hpux11*)
|
||||
i[34567]86-*-darwin*)
|
||||
# All the configuration is presently done generically.
|
||||
;;
|
||||
|
@ -50,7 +52,7 @@ FreeBSD 10 & 11 support.
|
|||
i[34567]86-*-elf*)
|
||||
tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h i386/i386elf.h"
|
||||
tmake_file="i386/t-i386elf t-svr4"
|
||||
@@ -1012,6 +1035,12 @@ i[34567]86-*-freebsd*)
|
||||
@@ -1012,6 +1037,12 @@ i[34567]86-*-freebsd*)
|
||||
x86_64-*-freebsd*)
|
||||
tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h ${fbsd_tm_file} i386/x86-64.h i386/freebsd.h i386/freebsd64.h"
|
||||
;;
|
||||
|
|
|
@ -1,16 +1,18 @@
|
|||
$NetBSD: patch-gcc_config_freebsd-spec.h,v 1.2 2015/10/07 10:36:54 sevan Exp $
|
||||
$NetBSD: patch-gcc_config_freebsd-spec.h,v 1.3 2016/09/27 20:51:11 maya Exp $
|
||||
|
||||
Do not create duplicate definitions.
|
||||
Add support for FreeBSD 9 to 11
|
||||
Add support for FreeBSD 9 to 12
|
||||
From FreeBSD ports.
|
||||
|
||||
--- ../gcc-4.1.2/gcc/config/freebsd-spec.h.orig 2005-07-19 13:42:12.000000000 +0000
|
||||
+++ ../gcc-4.1.2/gcc/config/freebsd-spec.h
|
||||
@@ -51,11 +51,15 @@ Boston, MA 02110-1301, USA. */
|
||||
@@ -51,11 +51,17 @@ Boston, MA 02110-1301, USA. */
|
||||
#define FBSD_TARGET_OS_CPP_BUILTINS() \
|
||||
do \
|
||||
{ \
|
||||
- if (FBSD_MAJOR == 9) \
|
||||
+ if (FBSD_MAJOR == 12) \
|
||||
+ builtin_define ("__FreeBSD__=12"); \
|
||||
+ if (FBSD_MAJOR == 11) \
|
||||
+ builtin_define ("__FreeBSD__=11"); \
|
||||
+ else if (FBSD_MAJOR == 10) \
|
||||
|
|
Loading…
Reference in a new issue