DragonFly support.
This commit is contained in:
parent
a31cd3b54d
commit
8552f27422
5 changed files with 59 additions and 8 deletions
|
@ -1,9 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.5 2005/09/06 08:10:59 abs Exp $
|
||||
$NetBSD: distinfo,v 1.6 2005/12/18 20:14:03 joerg Exp $
|
||||
|
||||
SHA1 (Sharity-Light.1.2.tar.gz) = 4a8e93695b1772005e401c2aafbd3f5f70a3b30e
|
||||
RMD160 (Sharity-Light.1.2.tar.gz) = 35fba8ab2ebd98cf32f2b20ac0fc8325a6c69325
|
||||
Size (Sharity-Light.1.2.tar.gz) = 76481 bytes
|
||||
SHA1 (patch-aa) = 349384306807e8d0e16334a2d9a7e7e0002ef8d1
|
||||
SHA1 (patch-ab) = b973fde2f268408289774a4dd37521a1671ef12d
|
||||
SHA1 (patch-ab) = 43a90b43d5ef7260eb7293e32e182c3c28426be4
|
||||
SHA1 (patch-ac) = 2087a294f04ff2cc4fc4edd1814807e6f01cd949
|
||||
SHA1 (patch-ad) = a93762c2130349856c02f965743f424335bc7726
|
||||
SHA1 (patch-ad) = 9d884d65a3f12de391a190a43104c97073dcc785
|
||||
SHA1 (patch-ae) = a9f49fd4322f92f53e217b1fe9c5b3d54eb00515
|
||||
SHA1 (patch-af) = 74551def230d03eb5c28fa6ad37f2639514018f8
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ab,v 1.3 2005/09/06 08:10:59 abs Exp $
|
||||
$NetBSD: patch-ab,v 1.4 2005/12/18 20:14:03 joerg Exp $
|
||||
|
||||
--- nfs/syscalls.c.orig 1998-06-30 07:24:56.000000000 -0500
|
||||
--- nfs/syscalls.c.orig 1998-06-30 12:24:56.000000000 +0000
|
||||
+++ nfs/syscalls.c
|
||||
@@ -19,6 +19,13 @@
|
||||
#include <arpa/inet.h>
|
||||
|
@ -16,3 +16,21 @@ $NetBSD: patch-ab,v 1.3 2005/09/06 08:10:59 abs Exp $
|
|||
/* --------------------------- general constants --------------------------- */
|
||||
|
||||
#define NFS_TIMEOUT_SECONDS 10 /* nfs timeout in seconds */
|
||||
@@ -62,7 +69,7 @@ int syscall_mount(char *dir, void *root_
|
||||
struct sockaddr_in *socket, char *mntfrom)
|
||||
{
|
||||
struct nfs_args nfs_args;
|
||||
-#ifdef __FreeBSD__
|
||||
+#if defined(__FreeBSD__) || defined(__DragonFly__)
|
||||
# ifdef _NEW_VFSCONF
|
||||
struct vfsconf vfc;
|
||||
int error;
|
||||
@@ -93,7 +100,7 @@ struct nfs_args nfs_args;
|
||||
#else
|
||||
# define NFSNAME MOUNT_NFS
|
||||
#endif
|
||||
-#ifdef __FreeBSD__
|
||||
+#if defined(__FreeBSD__) || defined(__DragonFly__)
|
||||
# ifdef _NEW_VFSCONF
|
||||
# define GETVFSBYNAME error = getvfsbyname("nfs", &vfc)
|
||||
# define VFCERROR error
|
||||
|
|
|
@ -1,14 +1,18 @@
|
|||
$NetBSD: patch-ad,v 1.2 2005/09/06 08:10:59 abs Exp $
|
||||
$NetBSD: patch-ad,v 1.3 2005/12/18 20:14:03 joerg Exp $
|
||||
|
||||
--- ../unshlight/unshlight.c.orig 2001-03-09 10:09:36.000000000 -0600
|
||||
--- ../unshlight/unshlight.c.orig 2001-03-09 16:09:36.000000000 +0000
|
||||
+++ ../unshlight/unshlight.c
|
||||
@@ -8,6 +8,10 @@
|
||||
@@ -8,6 +8,14 @@
|
||||
#include <stdlib.h>
|
||||
#include <signal.h>
|
||||
|
||||
+#if defined(__NetBSD__) && __NetBSD_Version__ >= 299000900
|
||||
+#define statfs statvfs
|
||||
+#endif
|
||||
+
|
||||
+#if defined(__DragonFly__)
|
||||
+#define MOUNT_NFS "nfs"
|
||||
+#endif
|
||||
+
|
||||
static void usage(void);
|
||||
|
||||
|
|
13
net/sharity-light/patches/patch-ae
Normal file
13
net/sharity-light/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1 2005/12/18 20:14:03 joerg Exp $
|
||||
|
||||
--- sock.c.orig 2005-12-18 19:54:04.000000000 +0000
|
||||
+++ sock.c
|
||||
@@ -13,8 +13,6 @@
|
||||
#include <smb/smbno.h>
|
||||
#include "my_defines.h"
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
int close_fp(struct file *filp)
|
||||
{
|
||||
return close((int)filp);
|
14
net/sharity-light/patches/patch-af
Normal file
14
net/sharity-light/patches/patch-af
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-af,v 1.1 2005/12/18 20:14:03 joerg Exp $
|
||||
|
||||
--- syshdr.h.orig 2005-12-18 20:00:48.000000000 +0000
|
||||
+++ syshdr.h
|
||||
@@ -47,6 +47,9 @@
|
||||
# define BSD4_4_LITE2
|
||||
# endif
|
||||
#endif
|
||||
+#if defined(__DragonFly__)
|
||||
+#define BSD4_4_LITE2
|
||||
+#endif
|
||||
#if defined(BSD4_4) && !defined(BSD4_4_LITE2)
|
||||
# define BSD4_4_LITE
|
||||
#endif
|
Loading…
Reference in a new issue