Update to 0.1.8.

Packaging changes:
 - adapt to non-standardly-named github WRKSRC
 - bootstrap automake (this is a git snapshot, not "make distribution"
   output)

Upstream changes:

New in 0.1.8; 2010-01-07; Andreas Jellinghaus
* Fix problem causing slot_n parsing returning not certs or keys
  by Camille Moncelier
* Fix missing declaration of set_init_args symbol
  by Arfrever Frehtes Taifersar Arahesis

New in 0.1.7; 2009-10-20; Andreas Jellinghaus
* Buffer overrun fixed by David Smith

New in 0.1.6; 2009-06-15; Andreas Jellinghaus
* Fixed set_pin (strdup causes segfault in OPENSSL_CLEANSE later)
* Require new libp11 0.2.5 with new function to get the slot id.
* Revert changes to slot parsing code - seems partial bogus and
  orginal author doesn't respond to questions.
* print slot id in verbose mode (Douglas E. Engert).
This commit is contained in:
gdt 2014-04-02 19:23:06 +00:00
parent 167a0e7f0c
commit 858f96ac14
4 changed files with 41 additions and 28 deletions

View file

@ -1,24 +1,30 @@
# $NetBSD: Makefile,v 1.8 2014/02/12 23:18:31 tron Exp $
# $NetBSD: Makefile,v 1.9 2014/04/02 19:23:06 gdt Exp $
#
DISTNAME= engine_pkcs11-0.1.5
VERSION= 0.1.8
DISTNAME= engine_pkcs11-${VERSION}
PKGNAME= ${DISTNAME:S/_/-/}
PKGREVISION= 4
CATEGORIES= security
MASTER_SITES= http://www.opensc-project.org/files/engine_pkcs11/
MASTER_SITES= https://github.com/OpenSC/engine_pkcs11/archive/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.opensc-project.org/engine_pkcs11/
HOMEPAGE= https://github.com/OpenSC/OpenSC/wiki/OpenSSL-engine-for-PKCS%2311-modules
COMMENT= PKCS\#11 engine for OpenSSL
LICENSE= original-bsd
WRKSRC= ${WRKDIR}/engine_pkcs11-engine_pkcs11-${VERSION}
BUILDLINK_API_DEPENDS.openssl+= openssl>=0.9.7
USE_PKGLOCALEDIR= yes
USE_LIBTOOL= yes
USE_TOOLS+= autoconf automake gmake pkg-config
GNU_CONFIGURE= yes
USE_TOOLS+= gmake pkg-config
USE_LIBTOOL= yes
CONFIGURE_ARGS+= --with-openssl=${SSLBASE:Q}
USE_PKGLOCALEDIR= yes
pre-configure:
cd ${WRKSRC} && ./bootstrap
.include "../../security/libp11/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2009/03/05 20:30:52 hasso Exp $
$NetBSD: distinfo,v 1.2 2014/04/02 19:23:06 gdt Exp $
SHA1 (engine_pkcs11-0.1.5.tar.gz) = 189da9a9156c86df99d16567acbf141869f87729
RMD160 (engine_pkcs11-0.1.5.tar.gz) = e1edcab5008cc0d524c904808de3344b9520700e
Size (engine_pkcs11-0.1.5.tar.gz) = 355324 bytes
SHA1 (patch-aa) = 996cdb0f077c923a2c2552ad03443e449b7c70fe
SHA1 (engine_pkcs11-0.1.8.tar.gz) = 7a84469ff9ab59373fc345ceb7888eedf45c78eb
RMD160 (engine_pkcs11-0.1.8.tar.gz) = 66ab0417b6d62c4f0f639c45965805b21107d723
Size (engine_pkcs11-0.1.8.tar.gz) = 18866 bytes
SHA1 (patch-Makefile.am) = f240bc8ab9f28e4b20c766e49473e4b21ec0850d

View file

@ -0,0 +1,23 @@
$NetBSD: patch-Makefile.am,v 1.1 2014/04/02 19:23:06 gdt Exp $
Don't install NEWS, as usually it is not.
Don't install a README about a wiki copy that isn't there.
These changes have not yet been submitted upstream.
--- Makefile.am.orig 2010-01-07 10:09:32.000000000 +0000
+++ Makefile.am
@@ -15,10 +15,11 @@ MAINTAINERCLEANFILES = \
$(srcdir)/packaged
EXTRA_DIST = svnignore
-SUBDIRS = src doc
+SUBDIRS = src
+#doc
dist_noinst_SCRIPTS = bootstrap
-dist_doc_DATA = NEWS
+#dist_doc_DATA = NEWS
# Allow detection of packaged tarball
dist-hook:

View file

@ -1,16 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2009/03/05 20:30:52 hasso Exp $
--- Makefile.in.orig 2009-03-05 16:05:48 +0200
+++ Makefile.in 2009-03-05 16:24:01 +0200
@@ -227,9 +227,9 @@ MAINTAINERCLEANFILES = \
$(srcdir)/packaged
EXTRA_DIST = svnignore
-SUBDIRS = src doc
+SUBDIRS = src
dist_noinst_SCRIPTS = bootstrap
-dist_doc_DATA = NEWS
+dist_doc_DATA =
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive