Use the pkg version of libtool instead of kdesupport's private copy.
Use GNU_CONFIGURE, not HAS_CONFIGURE.
This commit is contained in:
parent
c1f3bd4d47
commit
859876ad98
3 changed files with 29 additions and 11 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.10 1998/07/19 21:09:22 tv Exp $
|
||||
# $NetBSD: Makefile,v 1.11 1998/07/19 21:22:34 tv Exp $
|
||||
# FreeBSD Id: Makefile,v 1.2 1997/11/05 04:19:46 asami Exp
|
||||
#
|
||||
|
||||
|
@ -9,14 +9,14 @@ MASTER_SITES= ftp://ftp.us.kde.org/pub/kde/stable/1.0/distribution/tar/generic/s
|
|||
|
||||
MAINTAINER= tron@netbsd.org
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/libtool:../../devel/libtool
|
||||
DEPENDS+= qt-1.40:../../x11/qt
|
||||
|
||||
CONFLICTS= kdesupport-2.1b kdesupport-3.1b kdesupport-4.1b
|
||||
|
||||
USE_X11= yes
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= "--prefix=${PREFIX}" \
|
||||
"--datadir=${PREFIX}/share/kde" \
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= "--datadir=${PREFIX}/share/kde" \
|
||||
"--with-qt-includes=${PREFIX}/include/qt" \
|
||||
"--with-qt-libraries=${PREFIX}/lib" \
|
||||
"--without-gnu-ld" \
|
||||
|
@ -24,5 +24,6 @@ CONFIGURE_ARGS= "--prefix=${PREFIX}" \
|
|||
"--without-libgif" \
|
||||
"--without-libgdbm" \
|
||||
"--without-libuulib"
|
||||
CONFIGURE_ENV= LIBTOOL=${LOCALBASE}/bin/libtool
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
19
converters/kdesupport/patches/patch-aa
Normal file
19
converters/kdesupport/patches/patch-aa
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- configure.orig Sun Jul 19 17:15:00 1998
|
||||
+++ configure Sun Jul 19 17:15:22 1998
|
||||
@@ -1632,6 +1632,8 @@
|
||||
ac_save_cflags="$CFLAGS"
|
||||
CC=$CXX
|
||||
CFLAGS="$CXXFLAGS"
|
||||
+
|
||||
+if false; then
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
|
||||
@@ -1679,6 +1681,7 @@
|
||||
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
|
||||
CC=$ac_save_cc
|
||||
CFLAGS="$ac_save_cflags"
|
||||
+fi
|
||||
|
||||
echo $ac_n "checking for AIX""... $ac_c" 1>&6
|
||||
echo "configure:1685: checking for AIX" >&5
|
|
@ -1,10 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 1998/07/15 12:51:36 agc Exp $
|
||||
lib/libQwSpriteField.so.5.2
|
||||
lib/libQwSpriteField.la
|
||||
lib/libQwSpriteField.a
|
||||
lib/libmimelib.a
|
||||
lib/libmimelib.so.1.0
|
||||
lib/libmimelib.la
|
||||
@comment $NetBSD: PLIST,v 1.8 1998/07/19 21:22:34 tv Exp $
|
||||
include/Pix.h
|
||||
include/QwCluster.h
|
||||
include/QwPublicList.h
|
||||
|
@ -43,4 +37,8 @@ include/mimelib/token.h
|
|||
include/mimelib/utility.h
|
||||
include/mimelib/uuencode.h
|
||||
include/mimelib/binhex.h
|
||||
lib/libQwSpriteField.so.5.2
|
||||
lib/libQwSpriteField.a
|
||||
lib/libmimelib.a
|
||||
lib/libmimelib.so.1.0
|
||||
@dirrm include/mimelib
|
||||
|
|
Loading…
Reference in a new issue