Update to xcircuit-3.4.26. Provided by Shaun Amott in PR pkg/34443.
There have been many updates and minor versions between the last packaged version and this one. These updates have included many bug fixes including several bugs which would cause a crash, bugs in the generated netlists, and others.
This commit is contained in:
parent
d997a0a7b7
commit
8637b76bce
6 changed files with 303 additions and 162 deletions
|
@ -1,35 +1,45 @@
|
|||
# $NetBSD: Makefile,v 1.27 2006/03/04 21:29:02 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.28 2006/11/12 14:25:50 dmcmahill Exp $
|
||||
|
||||
DISTNAME= xcircuit-3.3.0
|
||||
PKGREVISION= 1
|
||||
DISTNAME= xcircuit-3.4.26
|
||||
CATEGORIES= cad graphics
|
||||
MASTER_SITES= http://bach.ece.jhu.edu/~tim/programs/xcircuit/archive/
|
||||
MASTER_SITES= http://opencircuitdesign.com/xcircuit/archive/ \
|
||||
http://bach.ece.jhu.edu/~tim/programs/xcircuit/archive/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://xcircuit.ece.jhu.edu/
|
||||
MAINTAINER= shaun@inerd.com
|
||||
HOMEPAGE= http://opencircuitdesign.com/xcircuit/
|
||||
COMMENT= Drawing program for X11 (especially for circuits)
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
USE_TOOLS+= gs:run
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--with-tcl
|
||||
|
||||
.include "../../lang/tcl/Makefile.version"
|
||||
.include "../../x11/tk/Makefile.version"
|
||||
|
||||
CONFIGURE_ARGS+=--prefix=${PREFIX}
|
||||
CONFIGURE_ARGS+=--with-tcl=${BUILDLINK_PREFIX.tcl}/lib
|
||||
CONFIGURE_ARGS+=--with-tk=${BUILDLINK_PREFIX.tk}/lib
|
||||
CONFIGURE_ARGS+=--with-tclincls=${BUILDLINK_PREFIX.tcl}/include
|
||||
CONFIGURE_ARGS+=--with-tcllibs=${BUILDLINK_PREFIX.tcl}/lib
|
||||
CONFIGURE_ARGS+=--with-tkincls=${BUILDLINK_PREFIX.tk}/include
|
||||
CONFIGURE_ARGS+=--with-tklibs=${BUILDLINK_PREFIX.tk}/lib
|
||||
#CFLAGS+= -DBUILTINS_DIR=${PREFIX}/lib/${DISTNAME:C/\.[^\.]*$//}
|
||||
LDFLAGS+= -ltcl${TCL_VERSION:C/\.[^\.]*$//:C/\.//g}
|
||||
LDFLAGS+= -ltk${TK_VERSION:C/\.[^\.]*$//:C/\.//g}
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
BUILD_TARGET= tcl
|
||||
INSTALL_TARGET= install-tcl
|
||||
INSTALL_TARGET= install-tcl
|
||||
|
||||
post-extract:
|
||||
${RM} -fr ${WRKSRC}/examples/CVS
|
||||
${MV} -f ${WRKSRC}/examples/.xcircuitrc ${WRKSRC}/examples/xcircuitrc
|
||||
${TOUCH} ${WRKSRC}/menudep.h
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/xcircuit/
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/* ${PREFIX}/share/examples/xcircuit/
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/xcircuit
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/*.* ${PREFIX}/share/examples/xcircuit/
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/xcircuitrc ${PREFIX}/share/examples/xcircuit/
|
||||
|
||||
.include "../../graphics/xpm/buildlink3.mk"
|
||||
.include "../../lang/tcl/buildlink3.mk"
|
||||
|
|
|
@ -1,97 +1,141 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2004/11/19 13:24:11 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 2006/11/12 14:25:50 dmcmahill Exp $
|
||||
bin/xcircuit
|
||||
lib/xcircuit-3.3/analog.lps
|
||||
lib/xcircuit-3.3/analoglib2.lps
|
||||
lib/xcircuit-3.3/app-defaults/XCircuit
|
||||
lib/xcircuit-3.3/asg_spice.lps
|
||||
lib/xcircuit-3.3/avlsi.lps
|
||||
lib/xcircuit-3.3/bparams.tcl
|
||||
lib/xcircuit-3.3/console.tcl
|
||||
lib/xcircuit-3.3/digital.lps
|
||||
lib/xcircuit-3.3/fonts/courier.lps
|
||||
lib/xcircuit-3.3/fonts/courier.xfe
|
||||
lib/xcircuit-3.3/fonts/courieriso.xfe
|
||||
lib/xcircuit-3.3/fonts/courieriso2.lps
|
||||
lib/xcircuit-3.3/fonts/courieriso2.xfe
|
||||
lib/xcircuit-3.3/fonts/courieriso5.lps
|
||||
lib/xcircuit-3.3/fonts/courieriso5.xfe
|
||||
lib/xcircuit-3.3/fonts/helvetica.lps
|
||||
lib/xcircuit-3.3/fonts/helvetica.xfe
|
||||
lib/xcircuit-3.3/fonts/helveticaiso.xfe
|
||||
lib/xcircuit-3.3/fonts/helveticaiso2.lps
|
||||
lib/xcircuit-3.3/fonts/helveticaiso2.xfe
|
||||
lib/xcircuit-3.3/fonts/helveticaiso5.lps
|
||||
lib/xcircuit-3.3/fonts/helveticaiso5.xfe
|
||||
lib/xcircuit-3.3/fonts/myfont.lps
|
||||
lib/xcircuit-3.3/fonts/myfont.xfe
|
||||
lib/xcircuit-3.3/fonts/symbol.lps
|
||||
lib/xcircuit-3.3/fonts/symbol.xfe
|
||||
lib/xcircuit-3.3/fonts/times_roman.lps
|
||||
lib/xcircuit-3.3/fonts/times_roman.xfe
|
||||
lib/xcircuit-3.3/fonts/times_romaniso.xfe
|
||||
lib/xcircuit-3.3/fonts/times_romaniso2.lps
|
||||
lib/xcircuit-3.3/fonts/times_romaniso2.xfe
|
||||
lib/xcircuit-3.3/fonts/times_romaniso5.lps
|
||||
lib/xcircuit-3.3/fonts/times_romaniso5.xfe
|
||||
lib/xcircuit-3.3/generic.lps
|
||||
lib/xcircuit-3.3/ic_templates.lps
|
||||
lib/xcircuit-3.3/lgf.lps
|
||||
lib/xcircuit-3.3/library.tcl
|
||||
lib/xcircuit-3.3/musiclib.lps
|
||||
lib/xcircuit-3.3/ngspice.tcl
|
||||
lib/xcircuit-3.3/panzoom.tcl
|
||||
lib/xcircuit-3.3/pcb.lps
|
||||
lib/xcircuit-3.3/pcb_layout.lps
|
||||
lib/xcircuit-3.3/pcbout.tcl
|
||||
lib/xcircuit-3.3/pixmaps/a.xpm
|
||||
lib/xcircuit-3.3/pixmaps/b.xpm
|
||||
lib/xcircuit-3.3/pixmaps/bd.xpm
|
||||
lib/xcircuit-3.3/pixmaps/ccw.xpm
|
||||
lib/xcircuit-3.3/pixmaps/co.xpm
|
||||
lib/xcircuit-3.3/pixmaps/cp.xpm
|
||||
lib/xcircuit-3.3/pixmaps/cw.xpm
|
||||
lib/xcircuit-3.3/pixmaps/d2.xpm
|
||||
lib/xcircuit-3.3/pixmaps/e.xpm
|
||||
lib/xcircuit-3.3/pixmaps/fi.xpm
|
||||
lib/xcircuit-3.3/pixmaps/fx.xpm
|
||||
lib/xcircuit-3.3/pixmaps/fy.xpm
|
||||
lib/xcircuit-3.3/pixmaps/i.xpm
|
||||
lib/xcircuit-3.3/pixmaps/li.xpm
|
||||
lib/xcircuit-3.3/pixmaps/mk.xpm
|
||||
lib/xcircuit-3.3/pixmaps/pa.xpm
|
||||
lib/xcircuit-3.3/pixmaps/pl.xpm
|
||||
lib/xcircuit-3.3/pixmaps/pm.xpm
|
||||
lib/xcircuit-3.3/pixmaps/po2.xpm
|
||||
lib/xcircuit-3.3/pixmaps/pu2.xpm
|
||||
lib/xcircuit-3.3/pixmaps/pz.xpm
|
||||
lib/xcircuit-3.3/pixmaps/q.xpm
|
||||
lib/xcircuit-3.3/pixmaps/s.xpm
|
||||
lib/xcircuit-3.3/pixmaps/solid.xbm
|
||||
lib/xcircuit-3.3/pixmaps/stip12.xbm
|
||||
lib/xcircuit-3.3/pixmaps/stip25.xbm
|
||||
lib/xcircuit-3.3/pixmaps/stip38.xbm
|
||||
lib/xcircuit-3.3/pixmaps/stip50.xbm
|
||||
lib/xcircuit-3.3/pixmaps/stip62.xbm
|
||||
lib/xcircuit-3.3/pixmaps/stip75.xbm
|
||||
lib/xcircuit-3.3/pixmaps/stip88.xbm
|
||||
lib/xcircuit-3.3/pixmaps/t.xpm
|
||||
lib/xcircuit-3.3/pixmaps/uj.xpm
|
||||
lib/xcircuit-3.3/pixmaps/xcircuit.xpm
|
||||
lib/xcircuit-3.3/pixmaps/yp.xpm
|
||||
lib/xcircuit-3.3/pixmaps/z4.xpm
|
||||
lib/xcircuit-3.3/pixmaps/z5.xpm
|
||||
lib/xcircuit-3.3/quadparts.lps
|
||||
lib/xcircuit-3.3/resource.tcl
|
||||
lib/xcircuit-3.3/series74xx.lps
|
||||
lib/xcircuit-3.3/signal.lps
|
||||
lib/xcircuit-3.3/sue_xc.tcl
|
||||
lib/xcircuit-3.3/tkcon.tcl
|
||||
lib/xcircuit-3.3/wrapper.tcl
|
||||
lib/xcircuit-3.3/xcircexec
|
||||
lib/xcircuit-3.3/xcircps2.pro
|
||||
lib/xcircuit-3.3/xcircuit.so
|
||||
lib/xcircuit-3.3/xcircuit.tcl
|
||||
lib/xcircuit-3.3/xcstartup.tcl
|
||||
lib/xcircuit-3.4/analog.lps
|
||||
lib/xcircuit-3.4/analoglib2.lps
|
||||
lib/xcircuit-3.4/app-defaults/XCircuit
|
||||
lib/xcircuit-3.4/asg_spice.lps
|
||||
lib/xcircuit-3.4/avlsi.lps
|
||||
lib/xcircuit-3.4/bparams.tcl
|
||||
lib/xcircuit-3.4/console.tcl
|
||||
lib/xcircuit-3.4/digital.lps
|
||||
lib/xcircuit-3.4/fonts/courier.lps
|
||||
lib/xcircuit-3.4/fonts/courier.xfe
|
||||
lib/xcircuit-3.4/fonts/courieriso.xfe
|
||||
lib/xcircuit-3.4/fonts/courieriso2.lps
|
||||
lib/xcircuit-3.4/fonts/courieriso2.xfe
|
||||
lib/xcircuit-3.4/fonts/courieriso5.lps
|
||||
lib/xcircuit-3.4/fonts/courieriso5.xfe
|
||||
lib/xcircuit-3.4/fonts/helvetica.lps
|
||||
lib/xcircuit-3.4/fonts/helvetica.xfe
|
||||
lib/xcircuit-3.4/fonts/helveticaiso.xfe
|
||||
lib/xcircuit-3.4/fonts/helveticaiso2.lps
|
||||
lib/xcircuit-3.4/fonts/helveticaiso2.xfe
|
||||
lib/xcircuit-3.4/fonts/helveticaiso5.lps
|
||||
lib/xcircuit-3.4/fonts/helveticaiso5.xfe
|
||||
lib/xcircuit-3.4/fonts/myfont.lps
|
||||
lib/xcircuit-3.4/fonts/myfont.xfe
|
||||
lib/xcircuit-3.4/fonts/symbol.lps
|
||||
lib/xcircuit-3.4/fonts/symbol.xfe
|
||||
lib/xcircuit-3.4/fonts/times_roman.lps
|
||||
lib/xcircuit-3.4/fonts/times_roman.xfe
|
||||
lib/xcircuit-3.4/fonts/times_romaniso.xfe
|
||||
lib/xcircuit-3.4/fonts/times_romaniso2.lps
|
||||
lib/xcircuit-3.4/fonts/times_romaniso2.xfe
|
||||
lib/xcircuit-3.4/fonts/times_romaniso5.lps
|
||||
lib/xcircuit-3.4/fonts/times_romaniso5.xfe
|
||||
lib/xcircuit-3.4/generic.lps
|
||||
lib/xcircuit-3.4/ic_templates.lps
|
||||
lib/xcircuit-3.4/lgf.lps
|
||||
lib/xcircuit-3.4/library.tcl
|
||||
lib/xcircuit-3.4/musiclib.lps
|
||||
lib/xcircuit-3.4/ngspice.tcl
|
||||
lib/xcircuit-3.4/panzoom.tcl
|
||||
lib/xcircuit-3.4/pcb.lps
|
||||
lib/xcircuit-3.4/pcb_layout.lps
|
||||
lib/xcircuit-3.4/pcbout.tcl
|
||||
lib/xcircuit-3.4/pixmaps/a.gif
|
||||
lib/xcircuit-3.4/pixmaps/a.xpm
|
||||
lib/xcircuit-3.4/pixmaps/b.gif
|
||||
lib/xcircuit-3.4/pixmaps/b.xpm
|
||||
lib/xcircuit-3.4/pixmaps/bd.gif
|
||||
lib/xcircuit-3.4/pixmaps/bd.xpm
|
||||
lib/xcircuit-3.4/pixmaps/ccw.gif
|
||||
lib/xcircuit-3.4/pixmaps/ccw.xpm
|
||||
lib/xcircuit-3.4/pixmaps/co.gif
|
||||
lib/xcircuit-3.4/pixmaps/co.xpm
|
||||
lib/xcircuit-3.4/pixmaps/cp.gif
|
||||
lib/xcircuit-3.4/pixmaps/cp.xpm
|
||||
lib/xcircuit-3.4/pixmaps/cw.gif
|
||||
lib/xcircuit-3.4/pixmaps/cw.xpm
|
||||
lib/xcircuit-3.4/pixmaps/d2.gif
|
||||
lib/xcircuit-3.4/pixmaps/d2.xpm
|
||||
lib/xcircuit-3.4/pixmaps/e.gif
|
||||
lib/xcircuit-3.4/pixmaps/e.xpm
|
||||
lib/xcircuit-3.4/pixmaps/fi.gif
|
||||
lib/xcircuit-3.4/pixmaps/fi.xpm
|
||||
lib/xcircuit-3.4/pixmaps/fx.gif
|
||||
lib/xcircuit-3.4/pixmaps/fx.xpm
|
||||
lib/xcircuit-3.4/pixmaps/fy.gif
|
||||
lib/xcircuit-3.4/pixmaps/fy.xpm
|
||||
lib/xcircuit-3.4/pixmaps/i.gif
|
||||
lib/xcircuit-3.4/pixmaps/i.xpm
|
||||
lib/xcircuit-3.4/pixmaps/li.gif
|
||||
lib/xcircuit-3.4/pixmaps/li.xpm
|
||||
lib/xcircuit-3.4/pixmaps/mk.gif
|
||||
lib/xcircuit-3.4/pixmaps/mk.xpm
|
||||
lib/xcircuit-3.4/pixmaps/mv.gif
|
||||
lib/xcircuit-3.4/pixmaps/mv.xpm
|
||||
lib/xcircuit-3.4/pixmaps/pa.gif
|
||||
lib/xcircuit-3.4/pixmaps/pa.xpm
|
||||
lib/xcircuit-3.4/pixmaps/pl.gif
|
||||
lib/xcircuit-3.4/pixmaps/pl.xpm
|
||||
lib/xcircuit-3.4/pixmaps/pm.gif
|
||||
lib/xcircuit-3.4/pixmaps/pm.xpm
|
||||
lib/xcircuit-3.4/pixmaps/pn.gif
|
||||
lib/xcircuit-3.4/pixmaps/pn.xpm
|
||||
lib/xcircuit-3.4/pixmaps/po2.gif
|
||||
lib/xcircuit-3.4/pixmaps/po2.xpm
|
||||
lib/xcircuit-3.4/pixmaps/pu2.gif
|
||||
lib/xcircuit-3.4/pixmaps/pu2.xpm
|
||||
lib/xcircuit-3.4/pixmaps/pz.gif
|
||||
lib/xcircuit-3.4/pixmaps/pz.xpm
|
||||
lib/xcircuit-3.4/pixmaps/q.gif
|
||||
lib/xcircuit-3.4/pixmaps/q.xpm
|
||||
lib/xcircuit-3.4/pixmaps/s.gif
|
||||
lib/xcircuit-3.4/pixmaps/s.xpm
|
||||
lib/xcircuit-3.4/pixmaps/solid.xbm
|
||||
lib/xcircuit-3.4/pixmaps/stip12.xbm
|
||||
lib/xcircuit-3.4/pixmaps/stip25.xbm
|
||||
lib/xcircuit-3.4/pixmaps/stip38.xbm
|
||||
lib/xcircuit-3.4/pixmaps/stip50.xbm
|
||||
lib/xcircuit-3.4/pixmaps/stip62.xbm
|
||||
lib/xcircuit-3.4/pixmaps/stip75.xbm
|
||||
lib/xcircuit-3.4/pixmaps/stip88.xbm
|
||||
lib/xcircuit-3.4/pixmaps/t.gif
|
||||
lib/xcircuit-3.4/pixmaps/t.xpm
|
||||
lib/xcircuit-3.4/pixmaps/tg.gif
|
||||
lib/xcircuit-3.4/pixmaps/tg.xpm
|
||||
lib/xcircuit-3.4/pixmaps/ti.gif
|
||||
lib/xcircuit-3.4/pixmaps/ti.xpm
|
||||
lib/xcircuit-3.4/pixmaps/tp.gif
|
||||
lib/xcircuit-3.4/pixmaps/tp.xpm
|
||||
lib/xcircuit-3.4/pixmaps/uj.gif
|
||||
lib/xcircuit-3.4/pixmaps/uj.xpm
|
||||
lib/xcircuit-3.4/pixmaps/w.gif
|
||||
lib/xcircuit-3.4/pixmaps/w.xpm
|
||||
lib/xcircuit-3.4/pixmaps/xcircuit.gif
|
||||
lib/xcircuit-3.4/pixmaps/xcircuit.ico
|
||||
lib/xcircuit-3.4/pixmaps/xcircuit.xpm
|
||||
lib/xcircuit-3.4/pixmaps/yp.gif
|
||||
lib/xcircuit-3.4/pixmaps/yp.xpm
|
||||
lib/xcircuit-3.4/pixmaps/z4.gif
|
||||
lib/xcircuit-3.4/pixmaps/z4.xpm
|
||||
lib/xcircuit-3.4/pixmaps/z5.gif
|
||||
lib/xcircuit-3.4/pixmaps/z5.xpm
|
||||
lib/xcircuit-3.4/quadparts.lps
|
||||
lib/xcircuit-3.4/resource.tcl
|
||||
lib/xcircuit-3.4/series74xx.lps
|
||||
lib/xcircuit-3.4/signal.lps
|
||||
lib/xcircuit-3.4/startup.script
|
||||
lib/xcircuit-3.4/sue_xc.tcl
|
||||
lib/xcircuit-3.4/tkcon.tcl
|
||||
lib/xcircuit-3.4/wrapper.tcl
|
||||
lib/xcircuit-3.4/xcircexec
|
||||
lib/xcircuit-3.4/xcircps2.pro
|
||||
lib/xcircuit-3.4/xcircuit.so
|
||||
lib/xcircuit-3.4/xcircuit.tcl
|
||||
lib/xcircuit-3.4/xcstartup.tcl
|
||||
man/man1/xcircuit.1
|
||||
share/examples/xcircuit/FlareLED.ps
|
||||
share/examples/xcircuit/USAflag.ps
|
||||
share/examples/xcircuit/analog1.ps
|
||||
|
@ -104,17 +148,16 @@ share/examples/xcircuit/diffamp_test2.ps
|
|||
share/examples/xcircuit/diffamp_test3.ps
|
||||
share/examples/xcircuit/envelope.ps
|
||||
share/examples/xcircuit/fourttest.ps
|
||||
share/examples/xcircuit/logic.sim
|
||||
share/examples/xcircuit/logic8.ps
|
||||
share/examples/xcircuit/panzoom.py
|
||||
share/examples/xcircuit/prelude.ps
|
||||
share/examples/xcircuit/systemd1.lgf
|
||||
share/examples/xcircuit/test.py
|
||||
share/examples/xcircuit/threestage.ps
|
||||
share/examples/xcircuit/vcoblock.ps
|
||||
share/examples/xcircuit/xcclock.ps
|
||||
share/examples/xcircuit/xcircuitrc
|
||||
@dirrm share/examples/xcircuit
|
||||
@dirrm lib/xcircuit-3.3/pixmaps
|
||||
@dirrm lib/xcircuit-3.3/fonts
|
||||
@dirrm lib/xcircuit-3.3/app-defaults
|
||||
@dirrm lib/xcircuit-3.3
|
||||
@dirrm lib/xcircuit-3.4/app-defaults
|
||||
@dirrm lib/xcircuit-3.4/pixmaps
|
||||
@dirrm lib/xcircuit-3.4/fonts
|
||||
@dirrm lib/xcircuit-3.4
|
||||
|
|
|
@ -1,8 +1,14 @@
|
|||
$NetBSD: distinfo,v 1.10 2006/10/14 02:21:21 rillig Exp $
|
||||
$NetBSD: distinfo,v 1.11 2006/11/12 14:25:50 dmcmahill Exp $
|
||||
|
||||
<<<<<<< distinfo
|
||||
SHA1 (xcircuit-3.4.26.tgz) = cf3eda5c788376a09cca6a35ee120a3f12a08c33
|
||||
RMD160 (xcircuit-3.4.26.tgz) = fd9beb37f16670505ee9aadc394d6e722947d645
|
||||
Size (xcircuit-3.4.26.tgz) = 1054942 bytes
|
||||
=======
|
||||
SHA1 (xcircuit-3.3.0.tgz) = ec3c0995fd4f8755a50d39e278ca0ab293705b38
|
||||
RMD160 (xcircuit-3.3.0.tgz) = 2f3621b5201ce4597a34a300a7111349825e3045
|
||||
Size (xcircuit-3.3.0.tgz) = 1308602 bytes
|
||||
SHA1 (patch-aa) = 6655ff2ee38253c4bbc19c477f9fcd9e3e68a4ed
|
||||
SHA1 (patch-ab) = 8f81ac0b8c0a2fceed052668cf4cf27a96915f9f
|
||||
SHA1 (patch-ac) = 1f84054174f790bd32d14eafa6a91444737795ff
|
||||
>>>>>>> 1.10
|
||||
SHA1 (patch-aa) = 8ac2a3398cbd74ca0248737c753816dee4367f97
|
||||
SHA1 (patch-ab) = 71335b954491e2d45a2189f6e1579c36dd401563
|
||||
SHA1 (patch-ac) = 5921bc94c2288f6d1811fe5a72f136a0ef0f25e6
|
||||
|
|
|
@ -1,8 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.8 2006/10/14 02:21:22 rillig Exp $
|
||||
$NetBSD: patch-aa,v 1.9 2006/11/12 14:25:50 dmcmahill Exp $
|
||||
|
||||
--- configure.in.orig 2004-10-01 06:24:09.000000000 +0200
|
||||
+++ configure.in 2006-10-14 04:19:51.000000000 +0200
|
||||
@@ -255,7 +255,7 @@ xc_with_tk_libraries=""
|
||||
--- configure.in.orig 2006-04-10 21:51:35.000000000 +0000
|
||||
+++ configure.in
|
||||
@@ -165,7 +165,7 @@ AC_ARG_WITH(opengl,
|
||||
dnl Graphics double-buffering? Enabled by default unless OpenGL used.
|
||||
AC_ARG_ENABLE(double-buffer,
|
||||
[ --disable-double-buffer disable graphics double-buffering], , [
|
||||
- if test "x$xc_with_GL" == "x" ; then
|
||||
+ if test "x$xc_with_GL" = "x" ; then
|
||||
AC_DEFINE(DOUBLEBUFFER)
|
||||
else
|
||||
AC_MSG_WARN(Double-buffering option not applicable to OpenGL version.)
|
||||
@@ -298,7 +298,7 @@ xc_with_tk_libraries=""
|
||||
AC_ARG_WITH(tcl,
|
||||
[ --with-tcl=DIR Find tclConfig.sh in DIR], [
|
||||
xc_with_tcl=$withval
|
||||
|
@ -11,24 +20,31 @@ $NetBSD: patch-aa,v 1.8 2006/10/14 02:21:22 rillig Exp $
|
|||
xc_with_tcl=""
|
||||
fi
|
||||
], )
|
||||
@@ -469,6 +469,7 @@ fi
|
||||
if test "x$xc_with_tcl" != "x" ; then
|
||||
. $tcl_config_sh
|
||||
. $tk_config_sh
|
||||
+ LIBS="${LIBS} ${TCL_LIBS}"
|
||||
|
||||
if test "$TCL_VERSION" = "7.6" -a "$TK_VERSION" = "4.2" ; then
|
||||
:
|
||||
@@ -544,7 +545,7 @@ fi
|
||||
@@ -574,12 +574,12 @@ if test "x$xc_with_tcl" != "x" ; then
|
||||
if test "x${xc_with_tcl_includes}" != "x" ; then
|
||||
if test -r "${xc_with_tcl_includes}/tcl.h" ; then
|
||||
TCL_INC_DIR=${xc_with_tcl_includes}
|
||||
- elif test "x${TCL_INCLUDE_SPEC}" == "x" ; then
|
||||
+ elif test "x${TCL_INCLUDE_SPEC}" = "x" ; then
|
||||
echo "Can't find tcl.h in \"${xc_with_tcl_includes}\""
|
||||
echo "Reverting to non-Tcl compilation"
|
||||
xc_with_tcl=""
|
||||
fi
|
||||
- elif test "x${TCL_INCLUDE_SPEC}" == "x" ; then
|
||||
+ elif test "x${TCL_INCLUDE_SPEC}" = "x" ; then
|
||||
for dir in \
|
||||
${TCL_PREFIX}/include/tcl${TCL_MAJOR_VERSION}.${TCL_MINOR_VERSION} \
|
||||
${TCL_PREFIX}/include \
|
||||
@@ -633,7 +633,7 @@ fi
|
||||
|
||||
if test "x$xc_with_tcl" != "x" ; then
|
||||
case $target in
|
||||
- *-sunos4*|*-*-netbsd|NetBSD-*|FreeBSD-*|OpenBSD-*)
|
||||
- *-sunos4*|*-*-netbsd|NetBSD-*|FreeBSD-*|*-*-openbsd*|OpenBSD-*)
|
||||
+ *-sunos4*|*-*-netbsd|*-*-netbsdelf|NetBSD-*|FreeBSD-*|OpenBSD-*|*-*-dragonfly*)
|
||||
TCL_LIB_NAME="tcl${TCL_MAJOR_VERSION}${TCL_MINOR_VERSION}"
|
||||
TK_LIB_NAME="tk${TK_MAJOR_VERSION}${TK_MINOR_VERSION}"
|
||||
;;
|
||||
@@ -886,13 +887,13 @@ if test "x$xc_with_tcl" != "x" ; then
|
||||
@@ -1013,12 +1013,12 @@ if test "x$xc_with_tcl" != "x" ; then
|
||||
EXTRA_LIB_SPECS="-ldl"
|
||||
;;
|
||||
|
||||
|
@ -39,10 +55,8 @@ $NetBSD: patch-aa,v 1.8 2006/10/14 02:21:22 rillig Exp $
|
|||
if test "$test_ok" = yes; then
|
||||
- SHLIB_CFLAGS="-fpic"
|
||||
- SHLIB_LD="ld"
|
||||
- LDDL_FLAGS="-Bshareable -x ${LIB_SPEC}"
|
||||
+ SHLIB_CFLAGS="-fPIC"
|
||||
+ SHLIB_LD=$CC
|
||||
+ LDDL_FLAGS="-shared"
|
||||
LDDL_FLAGS="-shared"
|
||||
fi
|
||||
;;
|
||||
|
||||
|
|
|
@ -1,8 +1,17 @@
|
|||
$NetBSD: patch-ab,v 1.8 2006/10/14 02:21:22 rillig Exp $
|
||||
$NetBSD: patch-ab,v 1.9 2006/11/12 14:25:50 dmcmahill Exp $
|
||||
|
||||
--- configure.orig 2004-10-01 06:25:07.000000000 +0200
|
||||
+++ configure 2006-10-14 04:20:29.000000000 +0200
|
||||
@@ -7393,7 +7393,7 @@ if test "${with_tcl+set}" = set; then
|
||||
--- configure.orig 2006-06-09 17:54:33.000000000 +0000
|
||||
+++ configure
|
||||
@@ -7765,7 +7765,7 @@ if test "${enable_double_buffer+set}" =
|
||||
|
||||
else
|
||||
|
||||
- if test "x$xc_with_GL" == "x" ; then
|
||||
+ if test "x$xc_with_GL" = "x" ; then
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define DOUBLEBUFFER 1
|
||||
_ACEOF
|
||||
@@ -8144,7 +8144,7 @@ if test "${with_tcl+set}" = set; then
|
||||
withval="$with_tcl"
|
||||
|
||||
xc_with_tcl=$withval
|
||||
|
@ -11,24 +20,31 @@ $NetBSD: patch-ab,v 1.8 2006/10/14 02:21:22 rillig Exp $
|
|||
xc_with_tcl=""
|
||||
fi
|
||||
|
||||
@@ -7629,6 +7629,7 @@ fi
|
||||
if test "x$xc_with_tcl" != "x" ; then
|
||||
. $tcl_config_sh
|
||||
. $tk_config_sh
|
||||
+ LIBS="${LIBS} ${TCL_LIBS}"
|
||||
|
||||
if test "$TCL_VERSION" = "7.6" -a "$TK_VERSION" = "4.2" ; then
|
||||
:
|
||||
@@ -7704,7 +7705,7 @@ fi
|
||||
@@ -8735,12 +8735,12 @@ if test "x$xc_with_tcl" != "x" ; then
|
||||
if test "x${xc_with_tcl_includes}" != "x" ; then
|
||||
if test -r "${xc_with_tcl_includes}/tcl.h" ; then
|
||||
TCL_INC_DIR=${xc_with_tcl_includes}
|
||||
- elif test "x${TCL_INCLUDE_SPEC}" == "x" ; then
|
||||
+ elif test "x${TCL_INCLUDE_SPEC}" = "x" ; then
|
||||
echo "Can't find tcl.h in \"${xc_with_tcl_includes}\""
|
||||
echo "Reverting to non-Tcl compilation"
|
||||
xc_with_tcl=""
|
||||
fi
|
||||
- elif test "x${TCL_INCLUDE_SPEC}" == "x" ; then
|
||||
+ elif test "x${TCL_INCLUDE_SPEC}" = "x" ; then
|
||||
for dir in \
|
||||
${TCL_PREFIX}/include/tcl${TCL_MAJOR_VERSION}.${TCL_MINOR_VERSION} \
|
||||
${TCL_PREFIX}/include \
|
||||
@@ -8794,7 +8794,7 @@ fi
|
||||
|
||||
if test "x$xc_with_tcl" != "x" ; then
|
||||
case $target in
|
||||
- *-sunos4*|*-*-netbsd|NetBSD-*|FreeBSD-*|OpenBSD-*)
|
||||
- *-sunos4*|*-*-netbsd|NetBSD-*|FreeBSD-*|*-*-openbsd*|OpenBSD-*)
|
||||
+ *-sunos4*|*-*-netbsd|*-*-netbsdelf|NetBSD-*|FreeBSD-*|OpenBSD-*|*-*-dragonfly*)
|
||||
TCL_LIB_NAME="tcl${TCL_MAJOR_VERSION}${TCL_MINOR_VERSION}"
|
||||
TK_LIB_NAME="tk${TK_MAJOR_VERSION}${TK_MINOR_VERSION}"
|
||||
;;
|
||||
@@ -8105,7 +8106,7 @@ fi
|
||||
@@ -9246,7 +9246,7 @@ fi
|
||||
EXTRA_LIB_SPECS="-ldl"
|
||||
;;
|
||||
|
||||
|
@ -37,16 +53,23 @@ $NetBSD: patch-ab,v 1.8 2006/10/14 02:21:22 rillig Exp $
|
|||
# Not available on all versions: check for include file.
|
||||
if test "${ac_cv_header_dlfcn_h+set}" = set; then
|
||||
echo "$as_me:$LINENO: checking for dlfcn.h" >&5
|
||||
@@ -8244,9 +8245,9 @@ fi
|
||||
@@ -9393,8 +9393,8 @@ fi
|
||||
|
||||
|
||||
if test "$test_ok" = yes; then
|
||||
- SHLIB_CFLAGS="-fpic"
|
||||
- SHLIB_LD="ld"
|
||||
- LDDL_FLAGS="-Bshareable -x ${LIB_SPEC}"
|
||||
+ SHLIB_CFLAGS="-fPIC"
|
||||
+ SHLIB_LD=$CC
|
||||
+ LDDL_FLAGS="-shared"
|
||||
LDDL_FLAGS="-shared"
|
||||
fi
|
||||
;;
|
||||
|
||||
@@ -10542,6 +10542,8 @@ do
|
||||
_ACEOF
|
||||
cat >>$CONFIG_STATUS <<\_ACEOF
|
||||
-recheck | --recheck | --rechec | --reche | --rech | --rec | --re | --r)
|
||||
+ : Avoid regenerating within pkgsrc
|
||||
+ exit 0
|
||||
ac_cs_recheck=: ;;
|
||||
--version | --vers* | -V )
|
||||
echo "$ac_cs_version"; exit 0 ;;
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.2 2004/11/19 13:24:11 adam Exp $
|
||||
$NetBSD: patch-ac,v 1.3 2006/11/12 14:25:50 dmcmahill Exp $
|
||||
|
||||
--- Makefile.in.orig 2004-10-01 04:25:06.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -51,7 +51,7 @@ AUTOMAKE = @AUTOMAKE@
|
||||
--- Makefile.in.orig 2006-06-14 09:15:38.000000000 +0100
|
||||
+++ Makefile.in 2006-09-01 01:55:36.000000000 +0100
|
||||
@@ -102,7 +102,7 @@
|
||||
AWK = @AWK@
|
||||
CC = @CC@
|
||||
CCDEPMODE = @CCDEPMODE@
|
||||
|
@ -11,11 +11,56 @@ $NetBSD: patch-ac,v 1.2 2004/11/19 13:24:11 adam Exp $
|
|||
CPP = @CPP@
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
CYGPATH_W = @CYGPATH_W@
|
||||
@@ -82,6 +82,7 @@ LIBS = @LIBS@
|
||||
LIB_SPECS = @LIB_SPECS@
|
||||
LTLIBOBJS = @LTLIBOBJS@
|
||||
M4 = @M4@
|
||||
+RM ?= rm -f
|
||||
@@ -123,7 +123,7 @@
|
||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
INSTALL_TARGET = @INSTALL_TARGET@
|
||||
-INTERP_PATH = @INTERP_PATH@
|
||||
+INTERP_PATH = tcl
|
||||
LD = @LD@
|
||||
LDDL_FLAGS = @LDDL_FLAGS@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
@@ -155,7 +155,7 @@
|
||||
SHLIB_LD = @SHLIB_LD@
|
||||
SHLIB_LIB_SPECS = @SHLIB_LIB_SPECS@
|
||||
SPICE_EXEC = @SPICE_EXEC@
|
||||
-STARTUP_FILE = @STARTUP_FILE@
|
||||
+STARTUP_FILE = ../startup.script
|
||||
STDLIBS = @STDLIBS@
|
||||
STRIP = @STRIP@
|
||||
SUBDIRS = @SUBDIRS@
|
||||
@@ -226,7 +226,7 @@
|
||||
|
||||
# Man page
|
||||
M4_DEFS = @M4_DEFS@ @DEFS@
|
||||
# Directories for app-defaults file and manual page
|
||||
appdefaultsdir = $(datadir)/$(PACKAGE)-$(VERSION)/app-defaults
|
||||
-appmandir = $(datadir)/$(PACKAGE)-$(VERSION)/man
|
||||
+appmandir = $(mandir)
|
||||
PATHNAMES = -DPROG_VERSION=$(VERSION) \
|
||||
-DPROG_REVISION=$(REVISION) \
|
||||
-DCAD_DIR=\"$(libdir)\" \
|
||||
@@ -640,14 +640,14 @@
|
||||
xcwrap.c -c -o xcwrap.o
|
||||
|
||||
lib/tcl/xcircuit${SHDLIB_EXT}: xcwrap.o ${xcircuit_OBJECTS} ${xcircuit_DEPEND}
|
||||
- $(RM) lib/xcircuit${SHDLIB_EXT}
|
||||
+# $(RM) lib/xcircuit${SHDLIB_EXT}
|
||||
$(CC) ${CFLAGS} ${SHLIB_CFLAGS} -o $@ ${LDDL_FLAGS} xcwrap.o \
|
||||
${xcircuit_OBJECTS} ${xcircuit_LDADD} ${LDFLAGS} \
|
||||
${X_EXTRA_LIBS} ${EXTRA_LIBS} -lc ${LIBS} ${EXTRA_LIB_SPECS} \
|
||||
${SHLIB_LIB_SPECS}
|
||||
|
||||
xcircexec$(EXEEXT): xcircexec.o
|
||||
- $(RM) ./xcircexec$(EXEEXT)
|
||||
+# $(RM) ./xcircexec$(EXEEXT)
|
||||
$(CC) ${CFLAGS} ${CPPFLAGS} ${DEFS} $(PATHNAMES) $(INCLUDES) \
|
||||
xcircexec.c -o xcircexec$(EXEEXT) ${LDFLAGS} \
|
||||
${LIBS} ${LIB_SPECS} ${EXTRA_LIB_SPECS}
|
||||
@@ -694,7 +694,7 @@
|
||||
$(mkinstalldirs) $(DESTDIR)$(appdefaultsdir)
|
||||
$(mkinstalldirs) $(DESTDIR)$(appmandir)
|
||||
$(INSTALL_DATA) lib/XCircuit.ad $(DESTDIR)$(appdefaultsdir)/XCircuit
|
||||
- $(INSTALL_DATA) lib/xcircuit.1 $(DESTDIR)$(appmandir)/xcircuit.1
|
||||
+ $(INSTALL_DATA) lib/xcircuit.1 $(DESTDIR)$(appmandir)/man1/xcircuit.1
|
||||
@echo "Installing library files"
|
||||
$(mkinstalldirs) $(DESTDIR)$(librarydir)
|
||||
( cd lib ; for i in $(PROLOGUE_FILE) *.lps; do \
|
||||
|
|
Loading…
Reference in a new issue