update to bozohttpd 20090418. changes include:
o avoid dying in daemon mode for some uncommon, but recoverable, errors o close leaking file descriptors for CGI and daemon mode o handle poll errors properly o don't try to handle more than one request per process yet
This commit is contained in:
parent
119fb4810a
commit
8657e1bac2
3 changed files with 17 additions and 19 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.64 2009/04/18 07:01:38 mrg Exp $
|
||||
# $NetBSD: Makefile,v 1.65 2009/04/18 21:06:15 mrg Exp $
|
||||
#
|
||||
|
||||
DISTNAME= bozohttpd-20090417
|
||||
DISTNAME= bozohttpd-20090418
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.46 2009/04/18 07:01:38 mrg Exp $
|
||||
$NetBSD: distinfo,v 1.47 2009/04/18 21:06:15 mrg Exp $
|
||||
|
||||
SHA1 (bozohttpd-20090417.tar.bz2) = 3ffacc60ceb15ca4a4b247a07df74f2fbd99269a
|
||||
RMD160 (bozohttpd-20090417.tar.bz2) = 1dae43331e9e8a3ef9190d666e5b62bebb4b9f74
|
||||
Size (bozohttpd-20090417.tar.bz2) = 36304 bytes
|
||||
SHA1 (patch-aa) = f1934786cb309cee8ec1c77e0760ee1e79b90f8f
|
||||
SHA1 (bozohttpd-20090418.tar.bz2) = fa63ceb04d70f6928e92110d50a89ec541371b03
|
||||
RMD160 (bozohttpd-20090418.tar.bz2) = 46d5aa4d7c4852337821c4fc78865571b206a62e
|
||||
Size (bozohttpd-20090418.tar.bz2) = 41488 bytes
|
||||
SHA1 (patch-aa) = ed75188890b62910fc66e0bc83976c785193eaaa
|
||||
SHA1 (patch-ab) = 010c130d315975d8a5ffcc3995bd951f6ecb619a
|
||||
|
|
|
@ -1,21 +1,19 @@
|
|||
$NetBSD: patch-aa,v 1.17 2007/09/07 23:01:59 jlam Exp $
|
||||
$NetBSD: patch-aa,v 1.18 2009/04/18 21:06:15 mrg Exp $
|
||||
|
||||
--- auth-bozo.c.orig Wed May 17 08:19:10 2006
|
||||
+++ auth-bozo.c
|
||||
@@ -37,7 +37,12 @@
|
||||
#include <sys/param.h>
|
||||
--- auth-bozo.c.orig 2009-04-18 00:38:56.000000000 -0700
|
||||
+++ auth-bozo.c 2009-04-18 14:03:57.000000000 -0700
|
||||
@@ -38,6 +38,10 @@
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
|
||||
#include <string.h>
|
||||
+
|
||||
+#ifndef NO_SSL_SUPPORT
|
||||
+#include <openssl/des.h>
|
||||
+#else
|
||||
#include <unistd.h>
|
||||
+#endif
|
||||
|
||||
+
|
||||
#include "bozohttpd.h"
|
||||
|
||||
@@ -97,7 +102,7 @@ auth_check(http_req *request, const char
|
||||
#ifndef AUTH_FILE
|
||||
@@ -98,7 +102,7 @@
|
||||
request->hr_authpass));
|
||||
if (strcmp(request->hr_authuser, user) != 0)
|
||||
continue;
|
||||
|
@ -23,4 +21,4 @@ $NetBSD: patch-aa,v 1.17 2007/09/07 23:01:59 jlam Exp $
|
|||
+ if (strcmp(DES_crypt(request->hr_authpass, pass), pass))
|
||||
break;
|
||||
fclose(fp);
|
||||
return;
|
||||
return 0;
|
||||
|
|
Loading…
Reference in a new issue