Update dillo to 2.2. Changes:
+- Added keybindings for scrolling. - Help button and local help file. +- Add support for multiple class names in CSS. - Fix X11 coordinate overflows with huge borders. - Improve CSS font parsing. - Enable font face setting via <font> element. - Ignore XML comment markers in CSS. - Split up long lines in plain.cc to avoid X11 coordinate overflows. - Fix user agent style for nested <ul>. - Add support for CSS property list-style-position. - Support border-width: thin | medium | thick. - Fix CSS_SHORTHAND_DIRECTIONS case in CssParser. - Add quirk to reset font properties in tables (fixes e.g. gmail). +- Cleaned up system includes in dpid directory. - Fixed CustProgressBox() for systems without weak symbols. - Handle signed chars. Added dIsspace() and dIsalnum() to dlib. - Added a_Dpip_get_attr_l() to DPIP's API. - Changed the CCCs to build in one step (for both HTTP and DPI). This is simpler and helps to avoid race conditions. - Updated CCCwork.txt to the new scheme. - Fixed a bug with OPTION element (it was parsing entities twice). - Bugfix: remove the empty cache entry lingering after connection abort. - Switched capi to use dlib's Dlist instead of a_List_* methods. - Remove empty cache entries on Stop-button press and new link request! - Fixed URL unescaping in the datauri DPI. - Changed and reimplemented the DPI API. * Fixed bugs and updated all DPI programs: * Reimplemented the file dpi using select(). No pthreads-based anymore. * Fixed ftp dpi: downloads, streamed transfer, error feedback. * Fixed a bug in dillo with lingering cache entries. * Made dpidc a C language program. * Made the internal dsh implementation use unique functions for read/write. * Removed the write/fwrite mix in DPIP. * Made the DPIP API token-based. Packet assembling is coded inside DPIP! * Several cleanups and more error handling sprinkled all over too. +- Fix segfault from AREA when MAP is missing name attribute. - Fix image map coordinates when margin/border/padding present. - Handle stylesheet @charset. - Fix cache segfault when cache entry removed. - Split words that contain whitespace as numeric character references. - Allow linebreaks around Chinese/Japanese characters. - Fix segfault in Html_parse_doctype (BUG#918). - Change exit code used for bad command line argument. - By default, do not use proxy for localhost (BUG 921). - Fix scrolling for text search. - Added 'save' key action (not bound by default). - Tooltips - Fix segfault when radio button lacks name attribute. - Enable popup menu below bottom of page content (BUG#856). - Handle JPEGs with CMYK color space. - Allow keysyms in keysrc. - Explicitly check installation bindir for dpid (BUG 930) - General cookies overhaul. +- Support for the letter-spacing property. +- Fixed a bug in w3c_mode. In fact it wasn't working at all. - Improve stylesheet menu. +- Limit number of simultaneous connections (BUG 685).
This commit is contained in:
parent
6a9c8319a5
commit
865b34a67f
5 changed files with 32 additions and 29 deletions
|
@ -1,7 +1,6 @@
|
||||||
# $NetBSD: Makefile,v 1.46 2010/01/18 09:59:30 wiz Exp $
|
# $NetBSD: Makefile,v 1.47 2010/02/14 20:19:24 snj Exp $
|
||||||
|
|
||||||
DISTNAME= dillo-2.1.1
|
DISTNAME= dillo-2.2
|
||||||
PKGREVISION= 2
|
|
||||||
CATEGORIES= www
|
CATEGORIES= www
|
||||||
MASTER_SITES= http://www.dillo.org/download/
|
MASTER_SITES= http://www.dillo.org/download/
|
||||||
EXTRACT_SUFX= .tar.bz2
|
EXTRACT_SUFX= .tar.bz2
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
@comment $NetBSD: PLIST,v 1.15 2009/07/09 05:04:02 snj Exp $
|
@comment $NetBSD: PLIST,v 1.16 2010/02/14 20:19:25 snj Exp $
|
||||||
bin/dillo
|
bin/dillo
|
||||||
bin/dpid
|
bin/dpid
|
||||||
bin/dpidc
|
bin/dpidc
|
||||||
|
@ -18,11 +18,12 @@ share/doc/dillo/Dpid.txt
|
||||||
share/doc/dillo/Dw.txt
|
share/doc/dillo/Dw.txt
|
||||||
share/doc/dillo/HtmlParser.txt
|
share/doc/dillo/HtmlParser.txt
|
||||||
share/doc/dillo/IO.txt
|
share/doc/dillo/IO.txt
|
||||||
share/doc/dillo/Imgbuf.txt
|
|
||||||
share/doc/dillo/Images.txt
|
share/doc/dillo/Images.txt
|
||||||
|
share/doc/dillo/Imgbuf.txt
|
||||||
share/doc/dillo/NC_design.txt
|
share/doc/dillo/NC_design.txt
|
||||||
share/doc/dillo/README
|
share/doc/dillo/README
|
||||||
share/doc/dillo/Selection.txt
|
share/doc/dillo/Selection.txt
|
||||||
|
share/doc/dillo/user_help.html
|
||||||
share/examples/dillo/dillorc
|
share/examples/dillo/dillorc
|
||||||
share/examples/dillo/dpidrc
|
share/examples/dillo/dpidrc
|
||||||
share/examples/dillo/keysrc
|
share/examples/dillo/keysrc
|
||||||
|
|
|
@ -1,9 +1,9 @@
|
||||||
$NetBSD: distinfo,v 1.29 2009/07/09 05:04:02 snj Exp $
|
$NetBSD: distinfo,v 1.30 2010/02/14 20:19:25 snj Exp $
|
||||||
|
|
||||||
SHA1 (dillo-2.1.1.tar.bz2) = eb252663b9480e53e0376d75b81130404ccf40ce
|
SHA1 (dillo-2.2.tar.bz2) = 06b325a246a639d936dabfc73d005f951d23c151
|
||||||
RMD160 (dillo-2.1.1.tar.bz2) = 4b8fe423e3a0fd0e461cc8e1795bac39ad47d3b6
|
RMD160 (dillo-2.2.tar.bz2) = 050f5bcd46042764c9bba536e6e5fd97453e1d6f
|
||||||
Size (dillo-2.1.1.tar.bz2) = 612711 bytes
|
Size (dillo-2.2.tar.bz2) = 630259 bytes
|
||||||
SHA1 (patch-aa) = 3a7b8d9e70d82edebf63cd5a715754dfad935832
|
SHA1 (patch-aa) = df4222ae9a0bd58af4c5481f920b60893145dbc1
|
||||||
SHA1 (patch-ab) = 37bbf07cb5120cbc677ad12d4d9f3ab07a02722e
|
SHA1 (patch-ab) = 827ed561c4622cf0d940090fcaac37f98d6cbab4
|
||||||
SHA1 (patch-ac) = f129ed7bb341211895fc51a7b70a81c94e70b158
|
SHA1 (patch-ac) = f129ed7bb341211895fc51a7b70a81c94e70b158
|
||||||
SHA1 (patch-ad) = 005df4881ecea7b1a7aff51ea06697e9949547dd
|
SHA1 (patch-ad) = 005df4881ecea7b1a7aff51ea06697e9949547dd
|
||||||
|
|
|
@ -1,20 +1,23 @@
|
||||||
$NetBSD: patch-aa,v 1.8 2009/07/09 05:04:02 snj Exp $
|
$NetBSD: patch-aa,v 1.9 2010/02/14 20:19:25 snj Exp $
|
||||||
|
|
||||||
--- dpid/Makefile.in.orig 2009-07-01 10:56:37.000000000 -0700
|
--- dpid/Makefile.in.orig 2010-02-11 02:20:00.000000000 -0800
|
||||||
+++ dpid/Makefile.in 2009-07-08 20:42:08.000000000 -0700
|
+++ dpid/Makefile.in 2010-02-14 09:55:43.000000000 -0800
|
||||||
@@ -320,12 +320,12 @@ distclean-compile:
|
@@ -335,15 +335,15 @@ distclean-compile:
|
||||||
uninstall-info-am:
|
@am__fastdepCC_FALSE@ $(COMPILE) -c `$(CYGPATH_W) '$<'`
|
||||||
install-sysconfDATA: $(sysconf_DATA)
|
install-sysconfDATA: $(sysconf_DATA)
|
||||||
@$(NORMAL_INSTALL)
|
@$(NORMAL_INSTALL)
|
||||||
- test -z "$(sysconfdir)" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
|
- test -z "$(sysconfdir)" || $(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
|
||||||
+ test -z "$(datadir)/examples/$(PACKAGE)" || $(mkdir_p) "$(DESTDIR)$(datadir)/examples/$(PACKAGE)"
|
+ $(MKDIR_P) "$(DESTDIR)$(datadir)/examples/$(PACKAGE)"
|
||||||
@list='$(sysconf_DATA)'; for p in $$list; do \
|
@list='$(sysconf_DATA)'; test -n "$(sysconfdir)" || list=; \
|
||||||
|
for p in $$list; do \
|
||||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||||
f=$(am__strip_dir) \
|
echo "$$d$$p"; \
|
||||||
- echo " $(sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f'"; \
|
done | $(am__base_list) | \
|
||||||
- $(sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f"; \
|
while read files; do \
|
||||||
+ echo " $(sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(datadir)/examples/$(PACKAGE)/$$f'"; \
|
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(sysconfdir)'"; \
|
||||||
+ $(sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(datadir)/examples/$(PACKAGE)/$$f"; \
|
- $(INSTALL_DATA) $$files "$(DESTDIR)$(sysconfdir)" || exit $$?; \
|
||||||
|
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(datadir)/examples/$(PACKAGE)'"; \
|
||||||
|
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(datadir)/examples/$(PACKAGE)" || exit $$?; \
|
||||||
done
|
done
|
||||||
|
|
||||||
uninstall-sysconfDATA:
|
uninstall-sysconfDATA:
|
||||||
|
|
|
@ -1,9 +1,9 @@
|
||||||
$NetBSD: patch-ab,v 1.15 2009/07/09 05:04:03 snj Exp $
|
$NetBSD: patch-ab,v 1.16 2010/02/14 20:19:25 snj Exp $
|
||||||
|
|
||||||
--- Makefile.in.orig 2009-07-01 10:56:55.000000000 -0700
|
--- Makefile.in.orig 2010-02-11 02:20:01.000000000 -0800
|
||||||
+++ Makefile.in 2009-07-08 15:30:55.000000000 -0700
|
+++ Makefile.in 2010-02-14 09:56:36.000000000 -0800
|
||||||
@@ -194,7 +194,7 @@ target_os = @target_os@
|
@@ -244,7 +244,7 @@ top_builddir = @top_builddir@
|
||||||
target_vendor = @target_vendor@
|
top_srcdir = @top_srcdir@
|
||||||
SUBDIRS = lout dw dlib dpip src doc dpid dpi test
|
SUBDIRS = lout dw dlib dpip src doc dpid dpi test
|
||||||
EXTRA_DIST = Doxyfile dillorc install-dpi-local
|
EXTRA_DIST = Doxyfile dillorc install-dpi-local
|
||||||
-sysconf_DATA = dillorc
|
-sysconf_DATA = dillorc
|
||||||
|
|
Loading…
Reference in a new issue