Import of snownews-1.4.2 from Bruce J.A. Nourish via pkgsrc-wip.

Snownews is a small console RSS/RDF newsreader. It will handle RSS 1.0
feeds that comply with the W3C RDF specification, but will also support
userland's 0.91 and 2.0 versions.
This commit is contained in:
wiz 2003-12-27 23:04:23 +00:00
parent 8a16a06b30
commit 865d0a84f0
8 changed files with 118 additions and 0 deletions

3
www/snownews/DESCR Normal file
View file

@ -0,0 +1,3 @@
Snownews is a small console RSS/RDF newsreader. It will handle RSS 1.0
feeds that comply with the W3C RDF specification, but will also support
userland's 0.91 and 2.0 versions.

8
www/snownews/MESSAGE Normal file
View file

@ -0,0 +1,8 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2003/12/27 23:04:23 wiz Exp $
The NetBSD project provides several RSS feeds of interest to NetBSD users
and developers. Information on these feeds can be found at:
http://www.netbsd.org/Changes/rss.html
===========================================================================

28
www/snownews/Makefile Normal file
View file

@ -0,0 +1,28 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/12/27 23:04:23 wiz Exp $
DISTNAME= snownews-1.4.2
CATEGORIES= www
MASTER_SITES= http://home.kcore.de/~kiza/software/snownews/download/
MAINTAINER= bjan+pkgsrc@bjan.net
HOMEPAGE= http://home.kcore.de/~kiza/software/snownews/
COMMENT= Small, curses based RSS feed reader
BUILD_USES_MSGFMT= YES
USE_BUILDLINK2= YES
USE_GMAKE= YES
USE_NCURSES= # missing WA_BOLD, WA_REVERSE, KEY_RESIZE
USE_PKGLOCALEDIR= YES
MAKE_ENV+= PKGLOCALEDIR=${PKGLOCALEDIR} GMAKE=${GMAKE}
MAKE_ENV+= EXTRA_CFLAGS="${CFLAGS}"
# XXX -lintl hack suggested by Jeremy C. Reed: blocking on PR #23369
.include "../../devel/gettext-lib/buildlink2.mk"
MAKE_ENV+= EXTRA_LDFLAGS="${LDFLAGS} ${_BLNK_INTL_LDFLAGS}"
.include "../../converters/libiconv/buildlink2.mk"
.include "../../textproc/libxml2/buildlink2.mk"
.include "../../devel/ncurses/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

18
www/snownews/PLIST Normal file
View file

@ -0,0 +1,18 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/12/27 23:04:23 wiz Exp $
bin/opml2snow
bin/snownews
man/de/man1/snownews.1
man/fr/man1/snownews.1
man/it/man1/snownews.1
man/man1/snownews.1
man/nl/man1/snownews.1
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/snownews.mo
${PKGLOCALEDIR}/locale/es/LC_MESSAGES/snownews.mo
${PKGLOCALEDIR}/locale/it/LC_MESSAGES/snownews.mo
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/snownews.mo
${PKGLOCALEDIR}/locale/nl/LC_MESSAGES/snownews.mo
${PKGLOCALEDIR}/locale/sl/LC_MESSAGES/snownews.mo
@unexec ${RMDIR} %D/man/nl/man1 2> /dev/null || ${TRUE}
@unexec ${RMDIR} %D/man/nl 2> /dev/null || ${TRUE}
@unexec ${RMDIR} %D/man/it/man1 2> /dev/null || ${TRUE}
@unexec ${RMDIR} %D/man/it 2> /dev/null || ${TRUE}

7
www/snownews/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2003/12/27 23:04:23 wiz Exp $
SHA1 (snownews-1.4.2.tar.gz) = 6a935496d707f6fb456b6b259ca3ceb69b44505c
Size (snownews-1.4.2.tar.gz) = 88822 bytes
SHA1 (patch-aa) = e84554ea5d7919b21ea47f5de160d23eb95b2a7a
SHA1 (patch-ab) = b1daaff6a08e855c6a5e8126f90370db6c7873a8
SHA1 (patch-ac) = 95f21e21c99bbb4cecf271709904c27f3b2cd42a

View file

@ -0,0 +1,17 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/12/27 23:04:23 wiz Exp $
--- Makefile.inc.orig Tue Dec 23 19:28:09 2003
+++ Makefile.inc
@@ -1,8 +1,7 @@
-CC = gcc
-MAKE = make
-INSTALL = install
-PREFIX = /usr/local
-LOCALEPATH = $(PREFIX)/share/locale
+MAKE = $(GMAKE)
+INSTALL = ${BSD_INSTALL_DATA} -c
+PREFIX = $(LOCALBASE)
+LOCALEPATH = $(PREFIX)/$(PKGLOCALEDIR)/locale
DISTFILES = AUTHOR COPYING CREDITS Changelog README README.de README.colors INSTALL INSTALL.solaris INSTALL.FreeOpenNetBSD TODO opml2snow \
Makefile Makefile.inc Makefile.solaris \
doc po \

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2003/12/27 23:04:23 wiz Exp $
--- ../snownews-1.4.2.orig/conversions.c 2003-12-23 04:10:35.000000000 -0700
+++ conversions.c 2003-12-23 15:19:48.000000000 -0700
@@ -55,7 +55,7 @@
return NULL;
}
- if (iconv (cd, &inbuf, &inbytesleft, &outbuf, &outbytesleft) == -1) {
+ if (iconv (cd, (const char **)&inbuf, &inbytesleft, &outbuf, &outbytesleft) == -1) {
return NULL;
}

View file

@ -0,0 +1,24 @@
$NetBSD: patch-ac,v 1.1.1.1 2003/12/27 23:04:23 wiz Exp $
--- Makefile.orig Tue Dec 23 19:28:09 2003
+++ Makefile
@@ -2,7 +2,7 @@ include Makefile.inc
LDFLAGS = -lncurses `xml2-config --libs` $(EXTRA_LDFLAGS)
OBJFILES = main.o netio.o interface.o xmlparse.o updatecheck.o conversions.o dialog.o ui-support.o categories.o
-CFLAGS = -Wall -O2 -DLOCALEPATH="\"$(LOCALEPATH)\"" -DOS=\"$(shell uname)\" `xml2-config --cflags` $(EXTRA_CFLAGS)
+CFLAGS = -Wall -DLOCALEPATH="\"$(LOCALEPATH)\"" -DOS=\"$(shell uname)\" `xml2-config --cflags` $(EXTRA_CFLAGS)
VERSION = `grep VERSION version.h | sed s/\"//g | sed s/\#define\ VERSION\ //`
MAN = doc/man
DISTDIR = snownews-$(VERSION)
@@ -29,8 +29,8 @@ install: snownews snownews.1 locales
if [ ! -d "$(PREFIX)/bin" ]; then \
mkdir -p $(PREFIX)/bin; \
fi
- $(INSTALL) -s snownews $(PREFIX)/bin
- $(INSTALL) opml2snow $(PREFIX)/bin
+ $(BSD_INSTALL_PROGRAM) snownews $(PREFIX)/bin
+ $(BSD_INSTALL_SCRIPT) opml2snow $(PREFIX)/bin
$(MAKE) -C $(MAN) install-man
$(MAKE) -C po install
@echo ""