py-aiormq: updated to 6.8.0

6.8.0

python 3.12 support
update dev requirements
drop python 3.7 support
update pamqp
This commit is contained in:
adam 2024-02-23 19:47:42 +00:00
parent ac9ca06019
commit 86fe716dda
4 changed files with 16 additions and 34 deletions

View File

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.5 2022/01/04 20:54:24 wiz Exp $
# $NetBSD: Makefile,v 1.6 2024/02/23 19:47:42 adam Exp $
DISTNAME= aiormq-3.2.3
DISTNAME= aiormq-6.8.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=a/aiormq/}
@ -11,12 +10,13 @@ HOMEPAGE= https://github.com/mosquito/aiormq
COMMENT= Pure python AMQP asynchronous client library
LICENSE= apache-2.0
DEPENDS+= ${PYPKGPREFIX}-pamqp>=2.3.0:../../net/py-pamqp
TOOL_DEPENDS+= ${PYPKGPREFIX}-poetry-core-[0-9]*:../../devel/py-poetry-core
DEPENDS+= ${PYPKGPREFIX}-pamqp>=3.3.0:../../net/py-pamqp
DEPENDS+= ${PYPKGPREFIX}-yarl-[0-9]*:../../www/py-yarl
USE_LANGUAGES= # none
PYTHON_VERSIONS_INCOMPATIBLE= 27
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,12 +1,13 @@
@comment $NetBSD: PLIST,v 1.1 2020/02/13 18:38:42 adam Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
@comment $NetBSD: PLIST,v 1.2 2024/02/23 19:47:42 adam Exp $
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/aiormq/__init__.py
${PYSITELIB}/aiormq/__init__.pyc
${PYSITELIB}/aiormq/__init__.pyo
${PYSITELIB}/aiormq/abc.py
${PYSITELIB}/aiormq/abc.pyc
${PYSITELIB}/aiormq/abc.pyo
${PYSITELIB}/aiormq/auth.py
${PYSITELIB}/aiormq/auth.pyc
${PYSITELIB}/aiormq/auth.pyo
@ -29,6 +30,3 @@ ${PYSITELIB}/aiormq/tools.pyo
${PYSITELIB}/aiormq/types.py
${PYSITELIB}/aiormq/types.pyc
${PYSITELIB}/aiormq/types.pyo
${PYSITELIB}/aiormq/version.py
${PYSITELIB}/aiormq/version.pyc
${PYSITELIB}/aiormq/version.pyo

View File

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.7 2023/02/10 14:42:48 wiz Exp $
$NetBSD: distinfo,v 1.8 2024/02/23 19:47:42 adam Exp $
BLAKE2s (aiormq-3.2.3.tar.gz) = fb1c37967b3baa111a927b6e62c915734bbb58890897394da22c66505409683c
SHA512 (aiormq-3.2.3.tar.gz) = 46321fe2992ae44c7b7fea7e2ca5b58752d8bece2e8402b054424c1c7eb0edf6df4b9c4973c5cb7a2bebba15b192b1d157d380028835417d43ee2a586d52ca46
Size (aiormq-3.2.3.tar.gz) = 21758 bytes
SHA1 (patch-setup.py) = 9bf8395698edfe081c35e1303269245dd1ba5aa2
BLAKE2s (aiormq-6.8.0.tar.gz) = e91032510b488c9e03fdc6b2e7dae37278c1fe681e25052de12b8fe8cf439762
SHA512 (aiormq-6.8.0.tar.gz) = 8028af7d77e1e52cc442cbf56360fae229490997a8fc612208e28af168a06e0c5c1ab29e0308532c8600ec8b9661970a561c7ae87a03f2c99425fc0cd6fcf5d8
Size (aiormq-6.8.0.tar.gz) = 26582 bytes

View File

@ -1,15 +0,0 @@
$NetBSD: patch-setup.py,v 1.1 2023/02/10 14:42:48 wiz Exp $
Fix invalid pattern.
--- setup.py.orig 2020-07-28 17:59:58.000000000 +0000
+++ setup.py
@@ -43,7 +43,7 @@ setup(
"Programming Language :: Python :: Implementation :: PyPy",
"Programming Language :: Python :: Implementation :: CPython",
],
- python_requires=">3.5.*",
+ python_requires=">3.5",
package_data={"aiormq": ["py.typed"]},
extras_require={
"develop": [