Changes 2.1:
- aecho filter - perspective filter ported from libmpcodecs - ffprobe -show_programs option - compand filter - RTMP seek support - when transcoding with ffmpeg (i.e. not streamcopying), -ss is now accurate even when used as an input option. Previous behavior can be restored with the -noaccurate_seek option. - ffmpeg -t option can now be used for inputs, to limit the duration of data read from an input file - incomplete Voxware MetaSound decoder - read EXIF metadata from JPEG - DVB teletext decoder - phase filter ported from libmpcodecs - w3fdif filter - Opus support in Matroska - FFV1 version 1.3 is stable and no longer experimental - FFV1: YUVA(444,422,420) 9, 10 and 16 bit support - changed DTS stream id in lavf mpeg ps muxer from 0x8a to 0x88, to be more consistent with other muxers. - adelay filter - pullup filter ported from libmpcodecs - ffprobe -read_intervals option - Lossless and alpha support for WebP decoder - Error Resilient AAC syntax (ER AAC LC) decoding - Low Delay AAC (ER AAC LD) decoding - mux chapters in ASF files - SFTP protocol (via libssh) - libx264: add ability to encode in YUVJ422P and YUVJ444P - Fraps: use BT.709 colorspace by default for yuv, as reference fraps decoder does - make decoding alpha optional for prores, ffv1 and vp6 by setting the skip_alpha flag. - ladspa wrapper filter - native VP9 decoder - dpx parser - max_error_rate parameter in ffmpeg - PulseAudio output device - ReplayGain scanner - Enhanced Low Delay AAC (ER AAC ELD) decoding (no LD SBR support) - Linux framebuffer output device - HEVC decoder, raw HEVC demuxer, HEVC demuxing in TS, Matroska and MP4 - mergeplanes filter
This commit is contained in:
parent
a051cc6a92
commit
87688e7198
6 changed files with 60 additions and 32 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.4 2013/10/20 21:53:54 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2013/10/30 07:08:23 adam Exp $
|
||||
|
||||
PKGNAME= ${DISTNAME:S/ffmpeg/ffmpeg2/}
|
||||
PKGREVISION= 1
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://ffmpeg.mplayerhq.hu/
|
||||
COMMENT= Decoding, encoding and streaming software
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile.common,v 1.5 2013/10/12 17:23:01 tron Exp $
|
||||
# $NetBSD: Makefile.common,v 1.6 2013/10/30 07:08:23 adam Exp $
|
||||
# used by multimedia/ffmpeg2/Makefile
|
||||
# used by multimedia/ffplay2/Makefile
|
||||
|
||||
DISTNAME= ffmpeg-2.0.2
|
||||
DISTNAME= ffmpeg-2.1
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://www.ffmpeg.org/releases/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2013/08/04 10:29:02 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2013/10/30 07:08:23 adam Exp $
|
||||
bin/ffmpeg2
|
||||
bin/ffprobe2
|
||||
bin/ffserver2
|
||||
|
@ -85,23 +85,23 @@ include/ffmpeg2/libswscale/version.h
|
|||
lib/ffmpeg2/libavcodec.a
|
||||
lib/ffmpeg2/libavcodec.so
|
||||
lib/ffmpeg2/libavcodec.so.55
|
||||
lib/ffmpeg2/libavcodec.so.55.18.102
|
||||
lib/ffmpeg2/libavcodec.so.55.39.100
|
||||
lib/ffmpeg2/libavdevice.a
|
||||
lib/ffmpeg2/libavdevice.so
|
||||
lib/ffmpeg2/libavdevice.so.55
|
||||
lib/ffmpeg2/libavdevice.so.55.3.100
|
||||
lib/ffmpeg2/libavdevice.so.55.5.100
|
||||
lib/ffmpeg2/libavfilter.a
|
||||
lib/ffmpeg2/libavfilter.so
|
||||
lib/ffmpeg2/libavfilter.so.3
|
||||
lib/ffmpeg2/libavfilter.so.3.79.101
|
||||
lib/ffmpeg2/libavfilter.so.3.90.100
|
||||
lib/ffmpeg2/libavformat.a
|
||||
lib/ffmpeg2/libavformat.so
|
||||
lib/ffmpeg2/libavformat.so.55
|
||||
lib/ffmpeg2/libavformat.so.55.12.100
|
||||
lib/ffmpeg2/libavformat.so.55.19.104
|
||||
lib/ffmpeg2/libavutil.a
|
||||
lib/ffmpeg2/libavutil.so
|
||||
lib/ffmpeg2/libavutil.so.52
|
||||
lib/ffmpeg2/libavutil.so.52.38.100
|
||||
lib/ffmpeg2/libavutil.so.52.48.100
|
||||
lib/ffmpeg2/libpostproc.a
|
||||
lib/ffmpeg2/libpostproc.so
|
||||
lib/ffmpeg2/libpostproc.so.52
|
||||
|
@ -109,11 +109,11 @@ lib/ffmpeg2/libpostproc.so.52.3.100
|
|||
lib/ffmpeg2/libswresample.a
|
||||
lib/ffmpeg2/libswresample.so
|
||||
lib/ffmpeg2/libswresample.so.0
|
||||
lib/ffmpeg2/libswresample.so.0.17.102
|
||||
lib/ffmpeg2/libswresample.so.0.17.104
|
||||
lib/ffmpeg2/libswscale.a
|
||||
lib/ffmpeg2/libswscale.so
|
||||
lib/ffmpeg2/libswscale.so.2
|
||||
lib/ffmpeg2/libswscale.so.2.3.100
|
||||
lib/ffmpeg2/libswscale.so.2.5.101
|
||||
lib/ffmpeg2/pkgconfig/libavcodec.pc
|
||||
lib/ffmpeg2/pkgconfig/libavdevice.pc
|
||||
lib/ffmpeg2/pkgconfig/libavfilter.pc
|
||||
|
@ -122,6 +122,35 @@ lib/ffmpeg2/pkgconfig/libavutil.pc
|
|||
lib/ffmpeg2/pkgconfig/libpostproc.pc
|
||||
lib/ffmpeg2/pkgconfig/libswresample.pc
|
||||
lib/ffmpeg2/pkgconfig/libswscale.pc
|
||||
share/doc/ffmpeg/developer.html
|
||||
share/doc/ffmpeg/faq.html
|
||||
share/doc/ffmpeg/fate.html
|
||||
share/doc/ffmpeg/ffmpeg-all.html
|
||||
share/doc/ffmpeg/ffmpeg-bitstream-filters.html
|
||||
share/doc/ffmpeg/ffmpeg-codecs.html
|
||||
share/doc/ffmpeg/ffmpeg-devices.html
|
||||
share/doc/ffmpeg/ffmpeg-filters.html
|
||||
share/doc/ffmpeg/ffmpeg-formats.html
|
||||
share/doc/ffmpeg/ffmpeg-protocols.html
|
||||
share/doc/ffmpeg/ffmpeg-resampler.html
|
||||
share/doc/ffmpeg/ffmpeg-scaler.html
|
||||
share/doc/ffmpeg/ffmpeg-utils.html
|
||||
share/doc/ffmpeg/ffmpeg.html
|
||||
share/doc/ffmpeg/ffprobe-all.html
|
||||
share/doc/ffmpeg/ffprobe.html
|
||||
share/doc/ffmpeg/ffserver-all.html
|
||||
share/doc/ffmpeg/ffserver.html
|
||||
share/doc/ffmpeg/general.html
|
||||
share/doc/ffmpeg/git-howto.html
|
||||
share/doc/ffmpeg/libavcodec.html
|
||||
share/doc/ffmpeg/libavdevice.html
|
||||
share/doc/ffmpeg/libavfilter.html
|
||||
share/doc/ffmpeg/libavformat.html
|
||||
share/doc/ffmpeg/libavutil.html
|
||||
share/doc/ffmpeg/libswresample.html
|
||||
share/doc/ffmpeg/libswscale.html
|
||||
share/doc/ffmpeg/nut.html
|
||||
share/doc/ffmpeg/platform.html
|
||||
share/doc/ffmpeg2/avutil.txt
|
||||
share/doc/ffmpeg2/build_system.txt
|
||||
share/doc/ffmpeg2/errno.txt
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.3 2013/10/12 10:31:12 adam Exp $
|
||||
$NetBSD: distinfo,v 1.4 2013/10/30 07:08:23 adam Exp $
|
||||
|
||||
SHA1 (ffmpeg-2.0.2.tar.bz2) = 47d3b3d172ae81f0571549e4dfaadfe5b4fe06cc
|
||||
RMD160 (ffmpeg-2.0.2.tar.bz2) = 8be0593a1904e9f5575779fe7aaa4978d29fbb5d
|
||||
Size (ffmpeg-2.0.2.tar.bz2) = 6191390 bytes
|
||||
SHA1 (ffmpeg-2.1.tar.bz2) = b8336772bfa957ca4943831f26aa99e4f30688d5
|
||||
RMD160 (ffmpeg-2.1.tar.bz2) = 33e795ba1f4d3ddefd15002cdf4bc45ef7734a3b
|
||||
Size (ffmpeg-2.1.tar.bz2) = 6640774 bytes
|
||||
SHA1 (patch-Makefile) = ff8a7a5fdfd4987ef2835bd7360a78efd4310253
|
||||
SHA1 (patch-configure) = 394d203c5b89dd872d55a68141106de5fa03d32b
|
||||
SHA1 (patch-configure) = 6ff1b0cced416bac7afbc1a5801b5c4485a9b6b2
|
||||
SHA1 (patch-libavutil_common.h) = ebbd0c169f228af37ae2dd54b27d5dba11a34c5e
|
||||
SHA1 (patch-libavutil_x86_cpu.c) = 14006874aee07e7e41803269040f0ae0157d931d
|
||||
SHA1 (patch-libavutil_x86_cpu.c) = 3a8b7048af047657f6b36e30e64ffd2b3a1bb0b1
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-configure,v 1.1 2013/08/04 10:29:02 adam Exp $
|
||||
$NetBSD: patch-configure,v 1.2 2013/10/30 07:08:23 adam Exp $
|
||||
|
||||
--- configure.orig 2013-07-10 00:43:00.000000000 +0000
|
||||
--- configure.orig 2013-10-28 00:58:04.000000000 +0000
|
||||
+++ configure
|
||||
@@ -3426,6 +3426,11 @@ case $target_os in
|
||||
@@ -3514,6 +3514,11 @@ case $target_os in
|
||||
;;
|
||||
netbsd)
|
||||
disable symver
|
||||
|
@ -14,7 +14,7 @@ $NetBSD: patch-configure,v 1.1 2013/08/04 10:29:02 adam Exp $
|
|||
oss_indev_extralibs="-lossaudio"
|
||||
oss_outdev_extralibs="-lossaudio"
|
||||
enabled gcc || check_ldflags -Wl,-zmuldefs
|
||||
@@ -3782,10 +3787,13 @@ check_cc <<EOF && enable attribute_may_a
|
||||
@@ -3872,10 +3877,13 @@ check_cc <<EOF && enable attribute_may_a
|
||||
union { int x; } __attribute__((may_alias)) x;
|
||||
EOF
|
||||
|
||||
|
@ -29,9 +29,9 @@ $NetBSD: patch-configure,v 1.1 2013/08/04 10:29:02 adam Exp $
|
|||
EOF
|
||||
-od -t x1 $TMPO | grep -q '42 *49 *47 *45' && enable bigendian
|
||||
|
||||
if enabled alpha; then
|
||||
check_inline_asm inline_asm_labels '"1:\n"'
|
||||
|
||||
@@ -4348,6 +4356,7 @@ enabled xmm_clobber_test &&
|
||||
@@ -4448,6 +4456,7 @@ enabled xmm_clobber_test &&
|
||||
-Wl,--wrap,sws_scale ||
|
||||
disable xmm_clobber_test
|
||||
|
||||
|
@ -39,7 +39,7 @@ $NetBSD: patch-configure,v 1.1 2013/08/04 10:29:02 adam Exp $
|
|||
echo "X{};" > $TMPV
|
||||
if test_ldflags -Wl,--version-script,$TMPV; then
|
||||
append SHFLAGS '-Wl,--version-script,\$(SUBDIR)lib\$(NAME).ver'
|
||||
@@ -4360,6 +4369,7 @@ __asm__(".symver ff_foo,av_foo@VERSION")
|
||||
@@ -4460,6 +4469,7 @@ __asm__(".symver ff_foo,av_foo@VERSION")
|
||||
void ff_foo(void) {}
|
||||
EOF
|
||||
fi
|
||||
|
@ -47,7 +47,7 @@ $NetBSD: patch-configure,v 1.1 2013/08/04 10:29:02 adam Exp $
|
|||
|
||||
if [ -z "$optflags" ]; then
|
||||
if enabled small; then
|
||||
@@ -4834,7 +4844,7 @@ Version: $version
|
||||
@@ -4945,7 +4955,7 @@ Version: $version
|
||||
Requires: $(enabled shared || echo $requires)
|
||||
Requires.private: $(enabled shared && echo $requires)
|
||||
Conflicts:
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-libavutil_x86_cpu.c,v 1.1 2013/08/04 10:29:02 adam Exp $
|
||||
$NetBSD: patch-libavutil_x86_cpu.c,v 1.2 2013/10/30 07:08:23 adam Exp $
|
||||
|
||||
--- libavutil/x86/cpu.c.orig 2013-01-06 21:53:29.000000000 +0000
|
||||
--- libavutil/x86/cpu.c.orig 2013-10-28 00:58:06.000000000 +0000
|
||||
+++ libavutil/x86/cpu.c
|
||||
@@ -115,6 +115,7 @@ int ff_get_cpu_flags_x86(void)
|
||||
@@ -116,6 +116,7 @@ int ff_get_cpu_flags_x86(void)
|
||||
#if HAVE_SSE
|
||||
if (std_caps & (1 << 25))
|
||||
rval |= AV_CPU_FLAG_SSE;
|
||||
|
@ -10,9 +10,9 @@ $NetBSD: patch-libavutil_x86_cpu.c,v 1.1 2013/08/04 10:29:02 adam Exp $
|
|||
if (std_caps & (1 << 26))
|
||||
rval |= AV_CPU_FLAG_SSE2;
|
||||
if (ecx & 1)
|
||||
@@ -134,6 +135,7 @@ int ff_get_cpu_flags_x86(void)
|
||||
rval |= AV_CPU_FLAG_AVX;
|
||||
}
|
||||
@@ -143,6 +144,7 @@ int ff_get_cpu_flags_x86(void)
|
||||
}
|
||||
#endif /* HAVE_AVX2 */
|
||||
#endif /* HAVE_AVX */
|
||||
+#endif /* gcc >= 4.2 */
|
||||
#endif /* HAVE_SSE */
|
||||
|
|
Loading…
Reference in a new issue