Initial import of mapserver, one of the many packages provided by
brook at biology dot nmsu dot edu and his team at NMSU. MapServer is an OpenSource development environment for building spatially enabled Internet applications. It now supports MapScript which allows popular scripting languages such as Perl, Python, Tk/Tcl, Guile and even Java to access the MapServer C API. MapScript provides a rich environment for developing applications that integrate disparate data.
This commit is contained in:
parent
5a8d69dd03
commit
87871a645c
6 changed files with 174 additions and 0 deletions
5
geography/mapserver/DESCR
Normal file
5
geography/mapserver/DESCR
Normal file
|
@ -0,0 +1,5 @@
|
|||
MapServer is an OpenSource development environment for building spatially
|
||||
enabled Internet applications. It now supports MapScript which allows popular
|
||||
scripting languages such as Perl, Python, Tk/Tcl, Guile and even Java to
|
||||
access the MapServer C API. MapScript provides a rich environment for
|
||||
developing applications that integrate disparate data.
|
34
geography/mapserver/Makefile
Normal file
34
geography/mapserver/Makefile
Normal file
|
@ -0,0 +1,34 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/10/05 17:41:30 jschauma Exp $
|
||||
#
|
||||
|
||||
DISTNAME= mapserver-4.0
|
||||
CATEGORIES= geography www
|
||||
MASTER_SITES= http://cvs.gis.umn.edu/dist/
|
||||
|
||||
MAINTAINER= hdp@cs.msu.edu
|
||||
HOMEPAGE= http://mapserver.gis.umn.edu/dist/
|
||||
COMMENT= Environment for building spatially enabled Internet apps
|
||||
|
||||
USE_BUILDLINK2= yes
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_X11= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ARGS+= --with-gd=${PREFIX} \
|
||||
--with-libiconv=${PREFIX} \
|
||||
--with-zlib=${BUILDLINK_PREFIX.zlib}
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/libmap.a ${PREFIX}/lib
|
||||
${INSTALL_DATA} ${WRKSRC}/map.h ${PREFIX}/include
|
||||
.for PROGRAM in shp2img shp2pdf mapserv legend shptree shptreevis \
|
||||
shptreetst scalebar sortshp
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PROGRAM} ${PREFIX}/bin
|
||||
.endfor
|
||||
|
||||
.include "../../converters/libiconv/buildlink2.mk"
|
||||
.include "../../devel/zlib/buildlink2.mk"
|
||||
.include "../../graphics/gd/buildlink2.mk"
|
||||
.include "../../graphics/tiff/buildlink2.mk"
|
||||
.include "../../graphics/xpm/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
12
geography/mapserver/PLIST
Normal file
12
geography/mapserver/PLIST
Normal file
|
@ -0,0 +1,12 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/10/05 17:41:30 jschauma Exp $
|
||||
bin/legend
|
||||
bin/mapserv
|
||||
bin/scalebar
|
||||
bin/shp2img
|
||||
bin/shp2pdf
|
||||
bin/shptree
|
||||
bin/shptreetst
|
||||
bin/shptreevis
|
||||
bin/sortshp
|
||||
include/map.h
|
||||
lib/libmap.a
|
30
geography/mapserver/buildlink2.mk
Normal file
30
geography/mapserver/buildlink2.mk
Normal file
|
@ -0,0 +1,30 @@
|
|||
# $NetBSD: buildlink2.mk,v 1.1.1.1 2003/10/05 17:41:31 jschauma Exp $
|
||||
#
|
||||
# This Makefile fragment is included by packages that use mapserver.
|
||||
#
|
||||
# This file was created automatically using createbuildlink 2.6.
|
||||
#
|
||||
|
||||
.if !defined(MAPSERVER_BUILDLINK2_MK)
|
||||
MAPSERVER_BUILDLINK2_MK= # defined
|
||||
|
||||
BUILDLINK_PACKAGES+= mapserver
|
||||
BUILDLINK_DEPENDS.mapserver?= mapserver>=4.0
|
||||
BUILDLINK_PKGSRCDIR.mapserver?= ../../geography/mapserver
|
||||
|
||||
EVAL_PREFIX+= BUILDLINK_PREFIX.mapserver=mapserver
|
||||
BUILDLINK_PREFIX.mapserver_DEFAULT= ${LOCALBASE}
|
||||
BUILDLINK_FILES.mapserver+= include/map.h
|
||||
BUILDLINK_FILES.mapserver+= lib/libmap.*
|
||||
|
||||
.include "../../converters/libiconv/buildlink2.mk"
|
||||
.include "../../devel/zlib/buildlink2.mk"
|
||||
.include "../../graphics/gd/buildlink2.mk"
|
||||
.include "../../graphics/tiff/buildlink2.mk"
|
||||
.include "../../graphics/xpm/buildlink2.mk"
|
||||
|
||||
BUILDLINK_TARGETS+= mapserver-buildlink
|
||||
|
||||
mapserver-buildlink: _BUILDLINK_USE
|
||||
|
||||
.endif # MAPSERVER_BUILDLINK2_MK
|
5
geography/mapserver/distinfo
Normal file
5
geography/mapserver/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/10/05 17:41:31 jschauma Exp $
|
||||
|
||||
SHA1 (mapserver-4.0.tar.gz) = 1007771932e43f97d868862fdc3a7ad3ab3d9880
|
||||
Size (mapserver-4.0.tar.gz) = 857870 bytes
|
||||
SHA1 (patch-aa) = f2a6d9d332c55955f3813ca39f2f2c397175e92b
|
88
geography/mapserver/patches/patch-aa
Normal file
88
geography/mapserver/patches/patch-aa
Normal file
|
@ -0,0 +1,88 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/10/05 17:41:32 jschauma Exp $
|
||||
|
||||
--- Makefile.in.orig 2003-06-18 09:12:06.000000000 -0400
|
||||
+++ Makefile.in 2003-10-05 13:15:33.000000000 -0400
|
||||
@@ -155,10 +155,10 @@
|
||||
$(CURL_INC) $(MING_INC) $(ORACLESPATIAL_INC)
|
||||
|
||||
# Link flags and shared libs only
|
||||
-LDFLAGS= $(RUNPATHS) -L. -lmap $(GD_LIB) $(PDF_LIB) $(TIFF_LIB) $(PROJ_LIB) \
|
||||
+MSLDFLAGS= $(RUNPATHS) -L. -lmap $(GD_LIB) $(PDF_LIB) $(TIFF_LIB) $(PROJ_LIB) \
|
||||
$(JPEG_LIB) $(SDE_LIB) $(OGR_LIB) $(GDAL_LIB) \
|
||||
$(MING_LIB) $(POSTGIS_LIB) $(MYGIS_LIB) $(CURL_LIB) $(ORACLESPATIAL_LIB) \
|
||||
- $(MPATROL_LIB) $(THREAD_LIB) $(XTRALIBS)
|
||||
+ $(MPATROL_LIB) $(THREAD_LIB) $(XTRALIBS) ${LDFLAGS}
|
||||
|
||||
# STATIC_LIBS is full filename with path of libs that will be statically linked
|
||||
STATIC_LIBS= $(GD_STATIC) $(OGR_STATIC)
|
||||
@@ -200,55 +200,55 @@
|
||||
$(RANLIB) libmap.a
|
||||
|
||||
shp2pdf: libmap.a shp2pdf.o map.h
|
||||
- $(LD) $(CFLAGS) shp2pdf.o $(LDFLAGS) $(STATIC_LIBS) -o shp2pdf
|
||||
+ $(LD) $(CFLAGS) shp2pdf.o $(MSLDFLAGS) $(STATIC_LIBS) -o shp2pdf
|
||||
|
||||
shp2img: libmap.a shp2img.o map.h
|
||||
- $(LD) $(CFLAGS) shp2img.o $(LDFLAGS) $(STATIC_LIBS) -o shp2img
|
||||
+ $(LD) $(CFLAGS) shp2img.o $(MSLDFLAGS) $(STATIC_LIBS) -o shp2img
|
||||
|
||||
sym2img: libmap.a sym2img.o map.h
|
||||
- $(LD) $(CFLAGS) sym2img.o $(LDFLAGS) $(STATIC_LIBS) -o sym2img
|
||||
+ $(LD) $(CFLAGS) sym2img.o $(MSLDFLAGS) $(STATIC_LIBS) -o sym2img
|
||||
|
||||
legend: libmap.a legend.o map.h
|
||||
- $(LD) $(CFLAGS) legend.o $(LDFLAGS) $(STATIC_LIBS) -o legend
|
||||
+ $(LD) $(CFLAGS) legend.o $(MSLDFLAGS) $(STATIC_LIBS) -o legend
|
||||
|
||||
scalebar: libmap.a scalebar.o map.h
|
||||
- $(LD) $(CFLAGS) scalebar.o $(LDFLAGS) $(STATIC_LIBS) -o scalebar
|
||||
+ $(LD) $(CFLAGS) scalebar.o $(MSLDFLAGS) $(STATIC_LIBS) -o scalebar
|
||||
|
||||
mapserv: mapserv.h libmap.a mapserv.o cgiutil.o map.h
|
||||
- $(LD) $(CFLAGS) mapserv.o cgiutil.o $(LDFLAGS) $(STATIC_LIBS) -o mapserv
|
||||
+ $(LD) $(CFLAGS) mapserv.o cgiutil.o $(MSLDFLAGS) $(STATIC_LIBS) -o mapserv
|
||||
|
||||
mapserv.fcgi: mapserv.h libmap.a mapserv_fcgi.o cgiutil.o map.h
|
||||
$(LD) $(CFLAGS) mapserv_fcgi.o cgiutil.o \
|
||||
- $(LDFLAGS) $(STATIC_LIBS) -lfcgi \
|
||||
+ $(MSLDFLAGS) $(STATIC_LIBS) -lfcgi \
|
||||
-o mapserv.fcgi
|
||||
|
||||
shpindex: libmap.a shpindex.o map.h
|
||||
- $(LD) $(CFLAGS) shpindex.o $(LDFLAGS) $(STATIC_LIBS) -o shpindex
|
||||
+ $(LD) $(CFLAGS) shpindex.o $(MSLDFLAGS) $(STATIC_LIBS) -o shpindex
|
||||
|
||||
shptree: libmap.a shptree.o map.h
|
||||
- $(LD) $(CFLAGS) shptree.o $(LDFLAGS) $(STATIC_LIBS) -o shptree
|
||||
+ $(LD) $(CFLAGS) shptree.o $(MSLDFLAGS) $(STATIC_LIBS) -o shptree
|
||||
|
||||
shptreevis: libmap.a shptreevis.o map.h
|
||||
- $(LD) $(CFLAGS) shptreevis.o $(LDFLAGS) $(STATIC_LIBS) -o shptreevis
|
||||
+ $(LD) $(CFLAGS) shptreevis.o $(MSLDFLAGS) $(STATIC_LIBS) -o shptreevis
|
||||
|
||||
shptreetst: libmap.a shptreetst.o map.h
|
||||
- $(LD) $(CFLAGS) shptreetst.o $(LDFLAGS) $(STATIC_LIBS) -o shptreetst
|
||||
+ $(LD) $(CFLAGS) shptreetst.o $(MSLDFLAGS) $(STATIC_LIBS) -o shptreetst
|
||||
|
||||
sortshp: sortshp.o
|
||||
- $(LD) $(CFLAGS) sortshp.o $(LDFLAGS) $(STATIC_LIBS) -o sortshp
|
||||
+ $(LD) $(CFLAGS) sortshp.o $(MSLDFLAGS) $(STATIC_LIBS) -o sortshp
|
||||
|
||||
tile4ms: tile4ms.o
|
||||
- $(LD) $(CFLAGS) tile4ms.o $(LDFLAGS) $(STATIC_LIBS) -o tile4ms
|
||||
+ $(LD) $(CFLAGS) tile4ms.o $(MSLDFLAGS) $(STATIC_LIBS) -o tile4ms
|
||||
|
||||
testexpr: testexpr.o mapparser.o maplexer.o
|
||||
- $(LD) $(CFLAGS) testexpr.o $(LDFLAGS) $(STATIC_LIBS) -o testexpr
|
||||
+ $(LD) $(CFLAGS) testexpr.o $(MSLDFLAGS) $(STATIC_LIBS) -o testexpr
|
||||
|
||||
mapscriptvars:
|
||||
touch mapscriptvars
|
||||
pwd > mapscriptvars
|
||||
echo $(IGNORE_MISSING_DATA) $(STRINGS) $(EPPL) $(PROJ) $(TTF) $(TIFF) $(JPEG) $(GD) $(SDE) $(OGR) $(GDAL) >> mapscriptvars
|
||||
echo -I. $(PROJ_INC) $(GD_INC) $(TTF_INC) $(TIFF_INC) $(JPEG_INC) $(SDE_INC) $(OGR_INC) $(GDAL_INC) >> mapscriptvars
|
||||
- echo $(LDFLAGS) >> mapscriptvars
|
||||
+ echo $(MSLDFLAGS) >> mapscriptvars
|
||||
echo $(STATIC_LIBS) >> mapscriptvars
|
||||
|
||||
php3_mapscript_clean::
|
Loading…
Reference in a new issue