Make this compile on gcc 2.95 by removing an unneccessary C99 construct.

This commit is contained in:
kristerw 2004-05-10 22:06:43 +00:00
parent 7b5422e89b
commit 878fd4fcaa
2 changed files with 18 additions and 1 deletions

View file

@ -1,4 +1,5 @@
$NetBSD: distinfo,v 1.7 2004/05/04 17:16:26 jmmv Exp $
$NetBSD: distinfo,v 1.8 2004/05/10 22:06:43 kristerw Exp $
SHA1 (epiphany-1.2.5.tar.bz2) = 3342d78f67374b412051c8874f4eb4459bc2c241
Size (epiphany-1.2.5.tar.bz2) = 2529219 bytes
SHA1 (patch-aa) = cce862cea154154f6f686d0953d5a40e95074a32

View file

@ -0,0 +1,16 @@
$NetBSD: patch-aa,v 1.3 2004/05/10 22:06:43 kristerw Exp $
--- lib/ephy-dialog.c.orig Mon May 10 23:49:04 2004
+++ lib/ephy-dialog.c Mon May 10 23:49:53 2004
@@ -584,9 +584,10 @@
}
else
{
+ char *v;
gtk_combo_box_set_active (GTK_COMBO_BOX (info->widget), -1);
- char *v = g_strdup_value_contents (value);
+ v = g_strdup_value_contents (value);
g_warning ("Value '%s' not found in model for combo %s\n", v, info->id);
g_free (v);
}