Changes 1.0.2:

* Added explicit copy constructors to Imath::Matrix33<T> and
  ImathMatrix44<T> to make conversions between float and double
  matrices more convenient.
* Added slerpShortestArc() and euclideanInnerProduct() functions
  to Imath::Quat<T>.
* Added 4D vector class template Imath::Vec4<T>.
* Copy constructors and assignment operators for Matrix33<T>
  and Matrix44<T> are up to 25% faster.  Added matrix constructors
  that do not initialize the matrix (this is faster in cases where
  the initial value of the matrix is immediately overwritten anyway).
* Rewrote function closestPointOnBox(point,box).  Shortened
  the code, improved numerical accuracy, fixed a bug where
  closestPointOnBox(box.center(),box) would return the center
  of the +Z side of the box, even if the +/-X or +/-Y sides
  were closer.
* Rewrote function findEntryAndExitPoints() in ImathBoxAlgo.h.
  Results are now consistent with those from intersect(), also
  in ImathBoxAlgo.h.
* Made Vec2<T>::length() and Vec3<T>::length() more accurate for
  vectors whose length is less than sqrt(limits<T>::smallest());
* Made Quat<T>::angle() more accurate for small angles.
This commit is contained in:
adam 2010-12-14 09:52:51 +00:00
parent 66bdcc44f9
commit 87f2a50c0b
3 changed files with 36 additions and 6 deletions

View file

@ -1,12 +1,13 @@
# $NetBSD: Makefile,v 1.4 2009/01/28 13:14:54 tron Exp $
# $NetBSD: Makefile,v 1.5 2010/12/14 09:52:51 adam Exp $
DISTNAME= ilmbase-1.0.1
DISTNAME= ilmbase-1.0.2
CATEGORIES= graphics
MASTER_SITES= http://savannah.nongnu.org/download/openexr/
MAINTAINER= adam@NetBSD.org
HOMEPAGE= http://www.openexr.com/
COMMENT= High dynamic-range (HDR) image file format library and tools
LICENSE= modified-bsd
PKG_DESTDIR_SUPPORT= user-destdir

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2008/02/03 03:37:32 heinz Exp $
$NetBSD: distinfo,v 1.3 2010/12/14 09:52:51 adam Exp $
SHA1 (ilmbase-1.0.1.tar.gz) = 143adc547be83c6df75831ae957eef4b2706c9c0
RMD160 (ilmbase-1.0.1.tar.gz) = 124f10b6f4ebefc9bb5dba7715d8897c7d71b947
Size (ilmbase-1.0.1.tar.gz) = 463275 bytes
SHA1 (ilmbase-1.0.2.tar.gz) = fe6a910a90cde80137153e25e175e2b211beda36
RMD160 (ilmbase-1.0.2.tar.gz) = 40aed65079ee174be8ed237e5def941ae2b761b3
Size (ilmbase-1.0.2.tar.gz) = 496540 bytes
SHA1 (patch-aa) = 7498a0cfafaec4f1e43dd57270f514bc5a8e7b1f
SHA1 (patch-ab) = a4e80234beb617861d1ab01a8bcfd34e03675da4

View file

@ -0,0 +1,28 @@
$NetBSD: patch-ab,v 1.1 2010/12/14 09:52:51 adam Exp $
--- configure.orig 2010-12-14 09:46:18.000000000 +0000
+++ configure
@@ -20385,23 +20385,7 @@ else
fi;
if test "${osx_arch}" != default ; then
- osx_arch_flags="-arch ${osx_arch// / -arch }"
CXXFLAGS="$CXXFLAGS $osx_arch_flags"
-
- if test "$enable_dependency_tracking" != no ; then
- osx_arch_array=( ${osx_arch} )
- if test ${#osx_arch_array[@]} -gt 1 ; then
- { { echo "$as_me:$LINENO: error: building multiple OS X architectures requires --disable-dependency-tracking.
-Please re-run configure with these options:
- --enable-osx-arch=\"${osx_arch}\" --disable-dependency-tracking
- " >&5
-echo "$as_me: error: building multiple OS X architectures requires --disable-dependency-tracking.
-Please re-run configure with these options:
- --enable-osx-arch=\"${osx_arch}\" --disable-dependency-tracking
- " >&2;}
- { (exit 1); exit 1; }; }
- fi
- fi
fi
# Check whether --enable-osx-sdk or --disable-osx-sdk was given.