Fix this to compile on systems that don't have a make(1) from

post-1.5 NetBSD-current.

XXX is removal of NO_PATCH ok here? (Zoularis context etc.)
This commit is contained in:
hubertf 2001-03-07 00:17:29 +00:00
parent b6c579822f
commit 887bdb5a52
3 changed files with 38 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.39 2001/03/05 18:24:05 wiz Exp $
# $NetBSD: Makefile,v 1.40 2001/03/07 00:17:29 hubertf Exp $
# Note to package maintainers:
# To update the distfile of this pkg, cd to /usr/src/usr.sbin,
@ -20,7 +20,6 @@ WRKSRC= ${WRKDIR}/pkg_install
MAKE_ENV+= BINDIR=/usr/sbin MANDIR=/usr/share/man NOLINT=1
NO_CONFIGURE= yes
NO_MTREE= yes
NO_PATCH= yes
NO_PKG_REGISTER= yes
NO_PACKAGE= No package registration is done
MANCOMPRESSED_IF_MANZ= yes

View file

@ -0,0 +1,18 @@
$NetBSD: patch-aa,v 1.1 2001/03/07 00:17:29 hubertf Exp $
Index: Makefile
===================================================================
RCS file: /cvsroot/basesrc/usr.sbin/pkg_install/Makefile,v
retrieving revision 1.5
diff -u -r1.5 Makefile
--- Makefile 2001/01/09 03:13:43 1.5
+++ Makefile 2001/03/06 23:54:39
@@ -1,6 +1,7 @@
# $NetBSD: patch-aa,v 1.1 2001/03/07 00:17:29 hubertf Exp $
# Original from FreeBSD, no rcs id.
-SUBDIR=lib .WAIT add admin create delete info
+#HF#SUBDIR=lib .WAIT add admin create delete info
+SUBDIR=lib add admin create delete info
.include <bsd.subdir.mk>

View file

@ -0,0 +1,19 @@
$NetBSD: patch-ab,v 1.1 2001/03/07 00:17:30 hubertf Exp $
Index: Makefile.inc
===================================================================
RCS file: /cvsroot/basesrc/usr.sbin/pkg_install/Makefile.inc,v
retrieving revision 1.14
diff -u -r1.14 Makefile.inc
--- Makefile.inc 2001/01/07 08:00:58 1.14
+++ Makefile.inc 2001/03/06 23:54:39
@@ -3,6 +3,9 @@
.include <bsd.own.mk>
+.if !defined(PRINTOBJDIR)
+PRINTOBJDIR= printf "xxx: .MAKE\n\t@echo \$${.OBJDIR}\n" | ${MAKE} -B -s -f-
+.endif
LIBINSTALL != cd ${.CURDIR}/../lib && ${PRINTOBJDIR}
CPPFLAGS+=-I${.CURDIR}/../lib ${DEBUG} -DBINDIR='"${BINDIR}"'