Changes 51.1:
Common Changes ============== CLDR 23: Collation tailorings put native script first; non-Gregorian calendar formats are more consistent; much improved data for Armenian (hy), Georgian (ka), Mongolian (mn), and Welsh (cy); … Time zone data: 2013b Date format/parse now supports CLDR short weekday names ("EEEEEE", "cccccc"). Support DisplayContext for date formatting, locale display names. DateTimePatternGenerator behavior is now much more consistent between C and J. Support new timezone pattern characters in LDML spec: X+, x+, O, OOOO, V, VV, VVV. Updated SpoofChecker for v5 of UTS39. AlphabeticIndex enhancements: New thread-safe ImmutableIndex sub-API Build an index for a custom Collator. Make data-driven for Chinese collations. New API for CLDR script metadata. ICU4C Specific Changes ====================== Support for “dangi” Korean luni-solar calendar (already in ICU4J). Add CompactDecimalFormat (already in ICU4J). Add TerritoryContainment APIs (already in ICU4J). UnicodeString default constructor and destructor now inline. Layout engine now supports 'morx' tables. Fixed some ICU 50 regressions: Affixes set with e.g. DecimalFormat::setPositivePrefix were ignored for parse. UNUM_PARSE_INT_ONLY no longer handled grouping separator. Add ucal_getTimeZoneID. The C++ AlphabeticIndex implementation is now on par with Java, including full support for all Chinese collation tailorings. U8_NEXT() and similar low-level macros now support NUL-terminated UTF-8 strings. New macros like U8_NEXT_OR_FFFD() return U+FFFD for an ill-formed sequence. Conversion: New "good one-way" mapping type, for example for Variation Selector sequences.
This commit is contained in:
parent
8c938b217f
commit
887d5005d9
5 changed files with 19 additions and 81 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.80 2013/01/26 21:36:48 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.81 2013/05/09 07:10:08 adam Exp $
|
||||
|
||||
DISTNAME= icu4c-50_1_2-src
|
||||
DISTNAME= icu4c-51_1-src
|
||||
PKGNAME= ${DISTNAME:S/4c//:S/-src//:S/_/./g}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://download.icu-project.org/files/icu4c/${PKGVERSION_NOREV}/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.27 2013/01/04 09:29:55 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.28 2013/05/09 07:10:08 adam Exp $
|
||||
bin/derb
|
||||
bin/genbrk
|
||||
bin/gencfu
|
||||
|
@ -27,8 +27,6 @@ include/layout/plruns.h
|
|||
include/unicode/alphaindex.h
|
||||
include/unicode/appendable.h
|
||||
include/unicode/basictz.h
|
||||
include/unicode/bms.h
|
||||
include/unicode/bmsearch.h
|
||||
include/unicode/brkiter.h
|
||||
include/unicode/bytestream.h
|
||||
include/unicode/bytestrie.h
|
||||
|
@ -39,7 +37,7 @@ include/unicode/chariter.h
|
|||
include/unicode/choicfmt.h
|
||||
include/unicode/coleitr.h
|
||||
include/unicode/coll.h
|
||||
include/unicode/colldata.h
|
||||
include/unicode/compactdecimalformat.h
|
||||
include/unicode/curramt.h
|
||||
include/unicode/currpinf.h
|
||||
include/unicode/currunit.h
|
||||
|
@ -89,6 +87,7 @@ include/unicode/rbbi.h
|
|||
include/unicode/rbnf.h
|
||||
include/unicode/rbtz.h
|
||||
include/unicode/regex.h
|
||||
include/unicode/region.h
|
||||
include/unicode/rep.h
|
||||
include/unicode/resbund.h
|
||||
include/unicode/schriter.h
|
||||
|
@ -193,35 +192,35 @@ lib/icu/current
|
|||
lib/icu/pkgdata.inc
|
||||
lib/libicudata.a
|
||||
lib/libicudata.so
|
||||
lib/libicudata.so.50
|
||||
lib/libicudata.so.51
|
||||
lib/libicudata.so.${PKGVERSION}
|
||||
lib/libicui18n.a
|
||||
lib/libicui18n.so
|
||||
lib/libicui18n.so.50
|
||||
lib/libicui18n.so.51
|
||||
lib/libicui18n.so.${PKGVERSION}
|
||||
lib/libicuio.a
|
||||
lib/libicuio.so
|
||||
lib/libicuio.so.50
|
||||
lib/libicuio.so.51
|
||||
lib/libicuio.so.${PKGVERSION}
|
||||
lib/libicule.a
|
||||
lib/libicule.so
|
||||
lib/libicule.so.50
|
||||
lib/libicule.so.51
|
||||
lib/libicule.so.${PKGVERSION}
|
||||
lib/libiculx.a
|
||||
lib/libiculx.so
|
||||
lib/libiculx.so.50
|
||||
lib/libiculx.so.51
|
||||
lib/libiculx.so.${PKGVERSION}
|
||||
lib/libicutest.a
|
||||
lib/libicutest.so
|
||||
lib/libicutest.so.50
|
||||
lib/libicutest.so.51
|
||||
lib/libicutest.so.${PKGVERSION}
|
||||
lib/libicutu.a
|
||||
lib/libicutu.so
|
||||
lib/libicutu.so.50
|
||||
lib/libicutu.so.51
|
||||
lib/libicutu.so.${PKGVERSION}
|
||||
lib/libicuuc.a
|
||||
lib/libicuuc.so
|
||||
lib/libicuuc.so.50
|
||||
lib/libicuuc.so.51
|
||||
lib/libicuuc.so.${PKGVERSION}
|
||||
lib/pkgconfig/icu-i18n.pc
|
||||
lib/pkgconfig/icu-io.pc
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.22 2013/01/26 21:36:48 adam Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.23 2013/05/09 07:10:08 adam Exp $
|
||||
|
||||
BUILDLINK_TREE+= icu
|
||||
|
||||
|
@ -6,7 +6,7 @@ BUILDLINK_TREE+= icu
|
|||
ICU_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.icu+= icu>=3.4
|
||||
BUILDLINK_ABI_DEPENDS.icu+= icu>=50.1.2nb1
|
||||
BUILDLINK_ABI_DEPENDS.icu+= icu>=51.1
|
||||
BUILDLINK_PKGSRCDIR.icu?= ../../textproc/icu
|
||||
.endif # ICU_BUILDLINK3_MK
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.33 2013/01/23 11:36:29 adam Exp $
|
||||
$NetBSD: distinfo,v 1.34 2013/05/09 07:10:08 adam Exp $
|
||||
|
||||
SHA1 (icu4c-50_1_2-src.tgz) = ee121e3ba2c3599b36b3d3b4abf68f28e23c9b4a
|
||||
RMD160 (icu4c-50_1_2-src.tgz) = d674a9ba00931ce95fb388442f139d6b64193f24
|
||||
Size (icu4c-50_1_2-src.tgz) = 21189361 bytes
|
||||
SHA1 (icu4c-51_1-src.tgz) = 7905632335e3dcd6667224da0fa087b49f9095e9
|
||||
RMD160 (icu4c-51_1-src.tgz) = c1e8b2129b57fff5b63be060450761ce9e7326a8
|
||||
Size (icu4c-51_1-src.tgz) = 21815174 bytes
|
||||
SHA1 (patch-aa) = fcbebb03f4a48294faeebd600fee989cab351230
|
||||
SHA1 (patch-ab) = 32f0e4c241535e37e4cad9b871ed3d36b4184199
|
||||
SHA1 (patch-ac) = e7cee161315321d2580074054d87714b55319886
|
||||
|
@ -12,4 +12,3 @@ SHA1 (patch-common_putilimp.h) = ff97ae0b8fd96ec8296e5164c135610a1a358810
|
|||
SHA1 (patch-common_unicode_platform.h) = 36cb68164fcf9b2858acabe95f0206e8088bfbaa
|
||||
SHA1 (patch-common_uposixdefs.h) = abe1989ea4312702e5d0172b662409957b3e2d91
|
||||
SHA1 (patch-config_icu-config-bottom) = 4a167249d58cb6c729bc164e6abae869dd5e6b1a
|
||||
SHA1 (patch-tools_genrb_derb.c) = 2c652a66f842236721f03e159efc14b0313e4a8f
|
||||
|
|
|
@ -1,59 +0,0 @@
|
|||
$NetBSD: patch-tools_genrb_derb.c,v 1.1 2012/11/07 20:59:51 adam Exp $
|
||||
|
||||
Changes "truncate" variable to "trunc" to avoid compilation error.
|
||||
|
||||
--- tools/genrb/derb.c.orig 2012-11-07 20:07:56.000000000 +0000
|
||||
+++ tools/genrb/derb.c
|
||||
@@ -54,7 +54,7 @@ static UConverter *defaultConverter = 0;
|
||||
|
||||
static const int32_t indentsize = 4;
|
||||
static int32_t truncsize = DERB_DEFAULT_TRUNC;
|
||||
-static UBool truncate = FALSE;
|
||||
+static UBool trunc = FALSE;
|
||||
|
||||
static const char *getEncodingName(const char *encoding);
|
||||
static void reportError(const char *pname, UErrorCode *status, const char *when);
|
||||
@@ -152,14 +152,14 @@ main(int argc, char* argv[]) {
|
||||
}
|
||||
|
||||
if(options[4].doesOccur) {
|
||||
- truncate = TRUE;
|
||||
+ trunc = TRUE;
|
||||
if(options[4].value != NULL) {
|
||||
truncsize = atoi(options[4].value); /* user defined printable size */
|
||||
} else {
|
||||
truncsize = DERB_DEFAULT_TRUNC; /* we'll use default omitting size */
|
||||
}
|
||||
} else {
|
||||
- truncate = FALSE;
|
||||
+ trunc = FALSE;
|
||||
}
|
||||
|
||||
if(options[5].doesOccur) {
|
||||
@@ -473,7 +473,7 @@ static void printOutAlias(FILE *out, UC
|
||||
int32_t len = 0;
|
||||
const UChar* thestr = res_getAlias(&(parent->fResData), r, &len);
|
||||
UChar *string = quotedString(thestr);
|
||||
- if(truncate && len > truncsize) {
|
||||
+ if(trunc && len > truncsize) {
|
||||
char msg[128];
|
||||
printIndent(out, converter, indent);
|
||||
sprintf(msg, "// WARNING: this resource, size %li is truncated to %li\n",
|
||||
@@ -517,7 +517,7 @@ static void printOutBundle(FILE *out, UC
|
||||
UChar *string = quotedString(thestr);
|
||||
|
||||
/* TODO: String truncation */
|
||||
- if(truncate && len > truncsize) {
|
||||
+ if(trunc && len > truncsize) {
|
||||
char msg[128];
|
||||
printIndent(out, converter, indent);
|
||||
sprintf(msg, "// WARNING: this resource, size %li is truncated to %li\n",
|
||||
@@ -576,7 +576,7 @@ static void printOutBundle(FILE *out, UC
|
||||
{
|
||||
int32_t len = 0;
|
||||
const int8_t *data = (const int8_t *)ures_getBinary(resource, &len, status);
|
||||
- if(truncate && len > truncsize) {
|
||||
+ if(trunc && len > truncsize) {
|
||||
char msg[128];
|
||||
printIndent(out, converter, indent);
|
||||
sprintf(msg, "// WARNING: this resource, size %li is truncated to %li\n",
|
Loading…
Reference in a new issue