Remove unneeded patches after samba update to 2.2.0.
This commit is contained in:
parent
65c9bef91b
commit
8888c438d6
3 changed files with 0 additions and 175 deletions
|
@ -1,85 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.6 2001/05/10 09:00:24 abs Exp $
|
||||
|
||||
--- client/client.c.orig Wed Apr 18 00:00:52 2001
|
||||
+++ client/client.c
|
||||
@@ -1180,7 +1180,7 @@
|
||||
"find . -name \"%s\" -print > %s",p,tmpname);
|
||||
else
|
||||
slprintf(cmd,sizeof(pstring)-1,
|
||||
- "find . -maxdepth 1 -name \"%s\" -print > %s",p,tmpname);
|
||||
+ "ls -1 %s > %s",p,tmpname);
|
||||
system(cmd);
|
||||
close(fd);
|
||||
|
||||
@@ -1615,22 +1615,19 @@
|
||||
return True;
|
||||
}
|
||||
|
||||
-#if defined(HAVE_LIBREADLINE)
|
||||
+#if defined(HAVE_READLINE)
|
||||
# if defined(HAVE_READLINE_HISTORY_H) || defined(HAVE_HISTORY_H)
|
||||
/****************************************************************************
|
||||
history
|
||||
****************************************************************************/
|
||||
static void cmd_history(void)
|
||||
{
|
||||
- HIST_ENTRY **hlist;
|
||||
register int i;
|
||||
|
||||
- hlist = history_list (); /* Get pointer to history list */
|
||||
-
|
||||
- if (hlist) /* If list not empty */
|
||||
+ if (history_length) /* If history is not empty */
|
||||
{
|
||||
- for (i = 0; hlist[i]; i++) /* then display it */
|
||||
- DEBUG(0, ("%d: %s\n", i, hlist[i]->line));
|
||||
+ for (i = 1; i <= history_length; i++) /* then display it */
|
||||
+ DEBUG(0, ("%d: %s\n", i, history_get(i)->line));
|
||||
}
|
||||
}
|
||||
# endif
|
||||
@@ -1691,7 +1688,7 @@
|
||||
{"setmode",cmd_setmode,"filename <setmode string> change modes of file",{COMPL_REMOTE,COMPL_NONE}},
|
||||
{"help",cmd_help,"[command] give help on a command",{COMPL_NONE,COMPL_NONE}},
|
||||
{"?",cmd_help,"[command] give help on a command",{COMPL_NONE,COMPL_NONE}},
|
||||
-#ifdef HAVE_LIBREADLINE
|
||||
+#ifdef HAVE_READLINE
|
||||
{"history",cmd_history,"displays the command history",{COMPL_NONE,COMPL_NONE}},
|
||||
#endif
|
||||
{"!",NULL,"run a shell command on the local system",{COMPL_NONE,COMPL_NONE}},
|
||||
@@ -1751,7 +1748,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
-#ifndef HAVE_LIBREADLINE
|
||||
+#ifndef HAVE_READLINE
|
||||
/****************************************************************************
|
||||
wait for keyboard activity, swallowing network packets
|
||||
****************************************************************************/
|
||||
@@ -1830,7 +1827,7 @@
|
||||
pstring line;
|
||||
char *ptr;
|
||||
|
||||
-#ifdef HAVE_LIBREADLINE
|
||||
+#ifdef HAVE_READLINE
|
||||
/* Minimal readline support, 29Jun1999, s.xenitellis@rhbnc.ac.uk */
|
||||
#ifdef PROMPTSIZE
|
||||
#undef PROMPTSIZE
|
||||
@@ -1844,7 +1841,7 @@
|
||||
while (!feof(stdin)) {
|
||||
fstring tok;
|
||||
int i;
|
||||
-#ifdef HAVE_LIBREADLINE
|
||||
+#ifdef HAVE_READLINE
|
||||
if ( temp != (char *)NULL )
|
||||
{
|
||||
free( temp ); /* Free memory allocated every time by readline() */
|
||||
@@ -2231,7 +2228,7 @@
|
||||
|
||||
DEBUGLEVEL = 2;
|
||||
|
||||
-#ifdef HAVE_LIBREADLINE
|
||||
+#ifdef HAVE_READLINE
|
||||
/* Allow conditional parsing of the ~/.inputrc file. */
|
||||
rl_readline_name = "smbclient";
|
||||
#endif
|
|
@ -1,55 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.5 2001/05/10 09:00:24 abs Exp $
|
||||
|
||||
--- configure.in.orig Wed Apr 18 00:00:52 2001
|
||||
+++ configure.in
|
||||
@@ -234,9 +234,6 @@
|
||||
AC_CHECK_TYPE(offset_t,loff_t)
|
||||
AC_CHECK_TYPE(ssize_t, int)
|
||||
|
||||
-# we need libcups for CUPS support...
|
||||
-AC_CHECK_LIB(cups,httpConnect)
|
||||
-
|
||||
# we need libdl for PAM and the new VFS code
|
||||
AC_CHECK_LIB(dl,main)
|
||||
|
||||
@@ -312,7 +309,14 @@
|
||||
# test for where we get readline() from
|
||||
if test "$ac_cv_header_readline_h" = "yes" ||
|
||||
test "$ac_cv_header_readline_readline_h" = "yes"; then
|
||||
- AC_CHECK_LIB(readline,readline)
|
||||
+ AC_CHECK_LIB(termcap, tputs)
|
||||
+ if test "$ac_cv_lib_termcap_tputs" = "yes"; then
|
||||
+ AC_CHECK_LIB(edit, readline, , [AC_CHECK_LIB(readline, readline)])
|
||||
+ if test "$ac_cv_lib_edit_readline" = "yes" ||
|
||||
+ test "$ac_cv_lib_readline_readline" = "yes"; then
|
||||
+ AC_DEFINE(HAVE_READLINE)
|
||||
+ fi
|
||||
+ fi
|
||||
fi
|
||||
|
||||
|
||||
@@ -1160,6 +1164,24 @@
|
||||
AC_DEFINE(BROKEN_NISPLUS_INCLUDE_FILES)
|
||||
fi
|
||||
|
||||
+
|
||||
+#################################################
|
||||
+# check for CUPS support
|
||||
+AC_MSG_CHECKING(whether to use CUPS)
|
||||
+AC_ARG_WITH(cups,
|
||||
+[ --with-cups Include CUPS support
|
||||
+ --without-cups Don't include CUPS support (default)],
|
||||
+[ case "$withval" in
|
||||
+ yes)
|
||||
+ AC_MSG_RESULT(yes)
|
||||
+ AC_CHECK_LIB(cups, httpConnect)
|
||||
+ ;;
|
||||
+ *)
|
||||
+ AC_MSG_RESULT(no)
|
||||
+ ;;
|
||||
+ esac ],
|
||||
+ AC_MSG_RESULT(no)
|
||||
+)
|
||||
|
||||
#################################################
|
||||
# check for smbwrapper support
|
|
@ -1,35 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.4 2001/05/10 09:00:24 abs Exp $
|
||||
|
||||
--- include/includes.h.orig Thu Mar 16 22:59:09 2000
|
||||
+++ include/includes.h
|
||||
@@ -808,20 +808,20 @@
|
||||
#define ULTRIX_AUTH 1
|
||||
#endif
|
||||
|
||||
-#ifdef HAVE_LIBREADLINE
|
||||
-# ifdef HAVE_READLINE_READLINE_H
|
||||
-# include <readline/readline.h>
|
||||
-# ifdef HAVE_READLINE_HISTORY_H
|
||||
-# include <readline/history.h>
|
||||
+#ifdef HAVE_READLINE
|
||||
+# ifdef HAVE_READLINE_H
|
||||
+# include <readline.h>
|
||||
+# ifdef HAVE_HISTORY_H
|
||||
+# include <history.h>
|
||||
# endif
|
||||
# else
|
||||
-# ifdef HAVE_READLINE_H
|
||||
-# include <readline.h>
|
||||
-# ifdef HAVE_HISTORY_H
|
||||
-# include <history.h>
|
||||
+# ifdef HAVE_READLINE_READLINE_H
|
||||
+# include <readline/readline.h>
|
||||
+# ifdef HAVE_READLINE_HISTORY_H
|
||||
+# include <readline/history.h>
|
||||
# endif
|
||||
# else
|
||||
-# undef HAVE_LIBREADLINE
|
||||
+# undef HAVE_READLINE
|
||||
# endif
|
||||
# endif
|
||||
#endif
|
Loading…
Reference in a new issue