security/signify: update to 0.13

# pkgsrc changes

* use patch to blank file instead of 'files' dir.

# upstream changes

* fix bug whereby a package with an exact numbers of 64K chunks would
  produce a spurious error
* make sure that we got all the signed blocks at EOF
  before exit(0)
This commit is contained in:
vins 2024-01-16 14:18:59 +00:00
parent bbbe335345
commit 88c79be97c
4 changed files with 32 additions and 22 deletions

View File

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.5 2023/08/26 11:27:42 vins Exp $
# $NetBSD: Makefile,v 1.6 2024/01/16 14:18:59 vins Exp $
DISTNAME= outils-0.12
PKGREVISION= 1
DISTNAME= outils-0.13
PKGNAME= ${DISTNAME:S,outils,signify,}
CATEGORIES= security
MASTER_SITES= https://git.vuxu.org/outils/snapshot/
@ -50,16 +49,19 @@ SUBST_SED.ints= -e 's|u_int|uint|g'
post-patch:
.if ${OPSYS} == "NetBSD"
# The sys/* overrides are not needed on NetSD
${RM} ${WRKSRC}/src/liboutils/include/sys/*
${RUN}${RM} ${WRKSRC}/src/liboutils/include/sys/*
.elif ${OPSYS} == "SunOS"
# Solaris lacks MIN/MAX macros in sys/param.h
cd ${LIBSRCDIR} && ${CP} ${FILESDIR}/minmax.h . \
&& ${CAT} outils.h >> minmax.h && ${MV} minmax.h outils.h
cd ${LIBSRCDIR} && \
${RUN}${CAT} outils.h >> minmax.h && \
${RUN}${MV} minmax.h outils.h
.endif
do-install:
${INSTALL_PROGRAM} ${OUTDIR}/signify ${DESTDIR}${PREFIX}/bin
${INSTALL_MAN} ${OUTDIR}/signify.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
${INSTALL_PROGRAM} ${OUTDIR}/signify \
${DESTDIR}${PREFIX}/bin
${INSTALL_MAN} ${OUTDIR}/signify.1 \
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
.include "../../mk/bsd.pkg.mk"

View File

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.2 2022/11/05 16:16:21 pin Exp $
$NetBSD: distinfo,v 1.3 2024/01/16 14:18:59 vins Exp $
BLAKE2s (outils-0.12.tar.gz) = 1778fcbefe35c0ac2d6e7efc84599e6653fe5a7c7884b036e0424cc6c96ad38a
SHA512 (outils-0.12.tar.gz) = 2888bffcf53b31eea0f8091690fd2a46af49b961fe4fd5c5f83e4cb9c95884737bb9f22cc13de07a9991bd5ab991a7bdb52cda47a913c475e94ae4ec15b223f2
Size (outils-0.12.tar.gz) = 281837 bytes
BLAKE2s (outils-0.13.tar.gz) = 2cdae4781211a8b47cb17e07e9165394582c09cc416e28035ea89c7f906f505d
SHA512 (outils-0.13.tar.gz) = 8838dbce8e4df56846f1ad2ec1012f072584e5ac11000f378fb3303e615c084e5903f6d759078f8c24b836cc771652d815b737a50e69e99f6a55346f23e98bfd
Size (outils-0.13.tar.gz) = 281834 bytes
SHA1 (patch-Makefile) = 1d4ed8ff1a8d728eecab09f1dfebba95d7c461ea
SHA1 (patch-src_liboutils_minmax.h) = 123c67e825d38758e8d56139f75cb983c4115e08
SHA1 (patch-src_liboutils_sha2.c) = 03182d6019efd9d60ff05eee9cef8de53632caa8

View File

@ -1,10 +0,0 @@
/* MAX(a,b) returns the maximum of A and B. */
#ifndef MAX
# define MAX(a,b) ((a) > (b) ? (a) : (b))
#endif
/* MIN(a,b) returns the minimum of A and B. */
#ifndef MIN
# define MIN(a,b) ((a) < (b) ? (a) : (b))
#endif

View File

@ -0,0 +1,17 @@
$NetBSD: patch-src_liboutils_minmax.h,v 1.1 2024/01/16 14:19:00 vins Exp $
MIN/MAX macros for SunOS
--- src/liboutils/minmax.h.orig 2024-01-16 14:06:20.323098287 +0000
+++ src/liboutils/minmax.h
@@ -0,0 +1,10 @@
+/* MAX(a,b) returns the maximum of A and B. */
+#ifndef MAX
+# define MAX(a,b) ((a) > (b) ? (a) : (b))
+#endif
+
+/* MIN(a,b) returns the minimum of A and B. */
+#ifndef MIN
+# define MIN(a,b) ((a) < (b) ? (a) : (b))
+#endif
+