Update gxemul to 0.4.7.2, and also pull some fixes from upstream trunk
for running several NetBSD ports properly on the emulator. PR pkg/41742 Discussed with and okay'ed by wiz@. Upstream changes: The changes between release 0.4.6.6 and 0.4.7 are: * Motorola 88K emulation is now complete enough to run a guest operating system: OpenBSD/mvme88k 4.4. A big thank you goes to Miod Vallat, who sent me physical 88100 documentation, via snail mail. This has been invaluable when implementing the 88K emulation mode. The changes between release 0.4.7 and 0.4.7.1 are: * Applying a man page hypenation patch from Jonathan Wiltshire. * Minor documentation errors fixed. * Some more missing M88K instructions added. * NetBSD/hpcmips can now be installed and run using serial console (i.e. without -X), in addition to using the framebuffer. The changes between release 0.4.7.1 and 0.4.7.2 are: * NetBSD 5.0, OpenBSD 4.5, and HelenOS 0.4.0 have been released, and the guest OS page has been updated to reflect this. (Not all versions and architectures work; the versions listed on the guest OS page are the latest ones that have been tested.) * A bug has been fixed which prevented configuration files from being used. Patches pulled from upstream trunk: patch-aa: Applying a patch for setting the ARCBIOS OSLOADPARTITION environment variable in a more correct way. http://gxemul.svn.sourceforge.net/viewvc/gxemul?view=rev&revision=5473 This makes NetBSD/arc work on PICA emulation with VGA console. (more proper fix than the previous patch-aa) patch-ab: Better fix for the Cobalt board ID number. http://gxemul.svn.sourceforge.net/viewvc/gxemul?view=rev&revision=5485 (fixes in the previous patch-ab has been integrated in the latest release) patch-ac: Applying a patch which makes NetBSD/hpcmips work well with the clock again. http://gxemul.svn.sourceforge.net/viewvc/gxemul?view=rev&revision=5472 pkgsrc changes: - update MASTER_SITES and HOMEPAGE (now they are in sourceforge) - update PLIST (add share/doc/gxemul/unsupported.html)
This commit is contained in:
parent
32b4c3f6d6
commit
89611c9248
6 changed files with 58 additions and 42 deletions
|
@ -1,12 +1,12 @@
|
|||
# $NetBSD: Makefile,v 1.40 2008/11/14 06:42:34 minskim Exp $
|
||||
# $NetBSD: Makefile,v 1.41 2009/07/18 18:43:56 tsutsui Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gxemul-0.4.6.6
|
||||
DISTNAME= gxemul-0.4.7.2
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://gavare.se/gxemul/src/
|
||||
MASTER_SITES= http://gxemul.sourceforge.net/src/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://gavare.se/gxemul/
|
||||
HOMEPAGE= http://gxemul.sourceforge.net/
|
||||
COMMENT= Machine emulator
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.22 2009/06/14 17:51:05 joerg Exp $
|
||||
@comment $NetBSD: PLIST,v 1.23 2009/07/18 18:43:56 tsutsui Exp $
|
||||
bin/gxemul
|
||||
man/man1/gxemul.1
|
||||
share/doc/gxemul/20040504-ultrix45-boot1.png
|
||||
|
@ -132,3 +132,4 @@ share/doc/gxemul/technical.html
|
|||
share/doc/gxemul/translation.html
|
||||
share/doc/gxemul/ultrix4.5-20040706.png
|
||||
share/doc/gxemul/ultrix4.5-20040706_small.png
|
||||
share/doc/gxemul/unsupported.html
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.28 2008/11/14 06:42:34 minskim Exp $
|
||||
$NetBSD: distinfo,v 1.29 2009/07/18 18:43:56 tsutsui Exp $
|
||||
|
||||
SHA1 (gxemul-0.4.6.6.tar.gz) = 599072df5a14565dcd10eb31faddc96a92a49cbc
|
||||
RMD160 (gxemul-0.4.6.6.tar.gz) = e29e863587340982ddaa14f65a17d29621efd461
|
||||
Size (gxemul-0.4.6.6.tar.gz) = 3345312 bytes
|
||||
SHA1 (patch-aa) = d8dbe0cb32d02d392957d1434446e4c1bf1f58ea
|
||||
SHA1 (patch-ab) = beeb04eb1b987b8ed095b5551804b640fbce36dc
|
||||
SHA1 (gxemul-0.4.7.2.tar.gz) = 63a20b810ef4ea9d7ec4678f135470fb324f61f1
|
||||
RMD160 (gxemul-0.4.7.2.tar.gz) = a54fb4f1ecf567ff9f62e8b1541018b38dea1e1a
|
||||
Size (gxemul-0.4.7.2.tar.gz) = 3374450 bytes
|
||||
SHA1 (patch-aa) = 4ac6d1dae6b906c4f39a78eb70a5239820840923
|
||||
SHA1 (patch-ab) = f18ee9eb9b67f66e4bb2fbfe06dc1c7d94e0bbd9
|
||||
SHA1 (patch-ac) = 1c65a7bd85bcdda950c512fbc1329610532cd211
|
||||
|
|
|
@ -1,20 +1,11 @@
|
|||
$NetBSD: patch-aa,v 1.6 2008/10/24 19:31:01 minskim Exp $
|
||||
$NetBSD: patch-aa,v 1.7 2009/07/18 18:43:56 tsutsui Exp $
|
||||
|
||||
--- src/promemul/arcbios.c.orig 2008-01-18 11:12:33.000000000 -0800
|
||||
+++ src/promemul/arcbios.c
|
||||
@@ -2211,7 +2211,10 @@ static void arc_environment_setup(struct
|
||||
}
|
||||
|
||||
if (machine->machine_type == MACHINE_ARC)
|
||||
- strlcat(init_bootpath, "\\", bootpath_len);
|
||||
+ snprintf(init_bootpath + strlen(init_bootpath),
|
||||
+ bootpath_len - strlen(init_bootpath),
|
||||
+ "scsi(0)disk(%i)rdisk(0)partition(1)",
|
||||
+ machine->bootdev_id);
|
||||
|
||||
CHECK_ALLOCATION(machine->bootstr = malloc(ARC_BOOTSTR_BUFLEN));
|
||||
|
||||
@@ -2362,20 +2365,17 @@ static void arc_environment_setup(struct
|
||||
A patch pulled from upstream trunk for NetBSD/arc:
|
||||
http://gxemul.svn.sourceforge.net/viewvc/gxemul?view=rev&revision=5473
|
||||
|
||||
--- src/promemul/arcbios.c 2009/07/04 19:41:47
|
||||
+++ src/promemul/arcbios.c 2009/07/11 10:04:28
|
||||
@@ -2363,20 +2363,19 @@
|
||||
add_environment_string(cpu, "kernname=unix", &addr);
|
||||
} else {
|
||||
char *tmp;
|
||||
|
@ -23,13 +14,14 @@ $NetBSD: patch-aa,v 1.6 2008/10/24 19:31:01 minskim Exp $
|
|||
+ size_t mlen = ARC_BOOTSTR_BUFLEN;
|
||||
CHECK_ALLOCATION(tmp = malloc(mlen));
|
||||
snprintf(tmp, mlen, "OSLOADOPTIONS=%s", machine->bootarg);
|
||||
store_pointer_and_advance(cpu, &addr2, addr, is64bit);
|
||||
add_environment_string(cpu, tmp, &addr);
|
||||
-
|
||||
- store_pointer_and_advance(cpu, &addr2, addr, is64bit);
|
||||
- add_environment_string(cpu, tmp, &addr);
|
||||
|
||||
store_pointer_and_advance(cpu, &addr2, addr, is64bit);
|
||||
- add_environment_string(cpu, "OSLOADPARTITION=scsi(0)cdrom(6)"
|
||||
- "fdisk(0);scsi(0)disk(0)rdisk(0)partition(1)", &addr);
|
||||
-
|
||||
+ add_environment_string(cpu, tmp, &addr);
|
||||
|
||||
store_pointer_and_advance(cpu, &addr2, addr, is64bit);
|
||||
- add_environment_string(cpu, "SYSTEMPARTITION=scsi(0)cdrom(6)"
|
||||
- "fdisk(0);scsi(0)disk(0)rdisk(0)partition(1)", &addr);
|
||||
|
|
|
@ -1,13 +1,20 @@
|
|||
$NetBSD: patch-ab,v 1.3 2008/10/24 19:55:10 minskim Exp $
|
||||
$NetBSD: patch-ab,v 1.4 2009/07/18 18:43:56 tsutsui Exp $
|
||||
|
||||
--- src/devices/bus_pci.c.orig 2008-01-18 11:12:27.000000000 -0800
|
||||
+++ src/devices/bus_pci.c
|
||||
@@ -776,6 +776,8 @@ int piix_ide_cfg_reg_write(struct pci_de
|
||||
void *wdc1 = ((struct piix_ide_extra *)pd->extra)->wdc1;
|
||||
int enabled = 0;
|
||||
A patch pulled from upstream trunk for NetBSD/cobalt:
|
||||
http://gxemul.svn.sourceforge.net/viewvc/gxemul?view=rev&revision=5485
|
||||
|
||||
--- src/devices/bus_pci.c 2009/07/04 19:41:47
|
||||
+++ src/devices/bus_pci.c 2009/07/12 11:35:33
|
||||
@@ -974,7 +974,11 @@
|
||||
* netbsd/usr/src/sys/arch/cobalt/cobalt/machdep.c read_board_id()
|
||||
* for details.
|
||||
*/
|
||||
- PCI_SET_DATA(0x94, 4 << 4);
|
||||
+ if (machine->machine_type == MACHINE_COBALT) {
|
||||
+#define COBALT_PCIB_BOARD_ID_REG 0x94
|
||||
+#define COBALT_QUBE2_ID 5
|
||||
+ PCI_SET_DATA(COBALT_PCIB_BOARD_ID_REG, COBALT_QUBE2_ID << 4);
|
||||
+ }
|
||||
}
|
||||
|
||||
+ PCI_SET_DATA(reg, value);
|
||||
+
|
||||
switch (reg) {
|
||||
case PCI_COMMAND_STATUS_REG:
|
||||
if (value & PCI_COMMAND_IO_ENABLE)
|
||||
struct vt82c586_ide_extra {
|
||||
|
|
15
emulators/gxemul/patches/patch-ac
Normal file
15
emulators/gxemul/patches/patch-ac
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ac,v 1.3 2009/07/18 18:43:56 tsutsui Exp $
|
||||
|
||||
A patch pulled from upstream trunk for NetBSD/hpcmips:
|
||||
http://gxemul.svn.sourceforge.net/viewvc/gxemul?view=rev&revision=5472
|
||||
|
||||
--- src/devices/dev_vr41xx.c 2009/07/04 19:41:47
|
||||
+++ src/devices/dev_vr41xx.c 2009/07/10 16:07:32
|
||||
@@ -590,6 +590,7 @@
|
||||
switch (relative_addr) {
|
||||
case 0xc0:
|
||||
odata = (tv.tv_sec & 1) << 15;
|
||||
+ odata += (uint64_t)tv.tv_usec * 32768 / 1000000;
|
||||
break;
|
||||
case 0xc2:
|
||||
odata = (tv.tv_sec >> 1) & 0xffff;
|
Loading…
Reference in a new issue