Update to 1.39

Add missing BUILD_DEPENDS
Add a patch to fix test

Upstream changes:
1.39 - Thu Sep 11 05:46:58 2014
	* Allow tests to run in parallel (RT #89908 and RT #91862)

1.38 - Thu Sep 11 04:03:42 2014
	* Add xmikew's mtime test fucntions. GitHub issue #8

1.37 - Thu Sep 11 03:46:00 2014
	* Uncomment accidently commented symlink_target_is_absolute_ok
This commit is contained in:
wen 2014-09-12 08:49:52 +00:00
parent 9b6e67f743
commit 89849ab433
3 changed files with 22 additions and 7 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.4 2014/05/29 23:36:21 wiz Exp $
# $NetBSD: Makefile,v 1.5 2014/09/12 08:49:52 wen Exp $
#
DISTNAME= Test-File-1.36
DISTNAME= Test-File-1.39
PKGNAME= p5-${DISTNAME}
PKGREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Test/}
@ -14,5 +13,7 @@ LICENSE= ${PERL5_LICENSE}
PERL5_PACKLIST= auto/Test/File/.packlist
BUILD_DEPENDS+= p5-Test-utf8>=0:../../devel/p5-Test-utf8
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.2 2014/05/09 08:29:39 wen Exp $
$NetBSD: distinfo,v 1.3 2014/09/12 08:49:52 wen Exp $
SHA1 (Test-File-1.36.tar.gz) = aebe8e78120d786401bb0d2e29adf9aa79a2514f
RMD160 (Test-File-1.36.tar.gz) = f6af12671f1c6a1ec560783f44463da801a4558b
Size (Test-File-1.36.tar.gz) = 18308 bytes
SHA1 (Test-File-1.39.tar.gz) = dae3eda21950414bdc3513323ad63ae9ac856d0d
RMD160 (Test-File-1.39.tar.gz) = 3609d70c67eb78c1a77d6e93deddb6e1a5d63833
Size (Test-File-1.39.tar.gz) = 21247 bytes
SHA1 (patch-t_file__contains__encoded.t) = 438e9a8adfd956af91a35dc20fe5c8468c16cf8e

View file

@ -0,0 +1,13 @@
$NetBSD: patch-t_file__contains__encoded.t,v 1.1 2014/09/12 08:49:52 wen Exp $
Make test work.
--- t/file_contains_encoded.t.orig 2014-09-12 16:34:24.000000000 +0000
+++ t/file_contains_encoded.t
@@ -12,7 +12,7 @@ my $string1 = 'Привет мир!';
my $string2 = 'Я строкой';
my $encoding = 'KOI8-R';
-require 'setup_common';
+require 't/setup_common';
my $file = '$file';
open my $fh, '>', $file or print "bail out! Could not write to $file: $!";