Build with newer Qt needs more Gl/glu.h magic.

This commit is contained in:
joerg 2012-01-23 20:55:47 +00:00
parent 855c374ccb
commit 898aa475ef
3 changed files with 16 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.9 2012/01/13 10:55:51 obache Exp $ # $NetBSD: Makefile,v 1.10 2012/01/23 20:55:47 joerg Exp $
# #
DISTNAME= qwtplot3d-0.2.7 DISTNAME= qwtplot3d-0.2.7
@ -30,6 +30,7 @@ do-install:
${LIBTOOL} --mode=install ${INSTALL_DATA} \ ${LIBTOOL} --mode=install ${INSTALL_DATA} \
${WRKSRC}/lib/libqwtplot3d.la ${DESTDIR}${PREFIX}/lib ${WRKSRC}/lib/libqwtplot3d.la ${DESTDIR}${PREFIX}/lib
.include "../../graphics/glu/buildlink3.mk"
.include "../../x11/qt4-libs/buildlink3.mk" .include "../../x11/qt4-libs/buildlink3.mk"
.include "../../x11/qt4-tools/buildlink3.mk" .include "../../x11/qt4-tools/buildlink3.mk"
.include "../../mk/bsd.pkg.mk" .include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2009/12/11 19:22:10 drochner Exp $ $NetBSD: distinfo,v 1.2 2012/01/23 20:55:47 joerg Exp $
SHA1 (qwtplot3d-0.2.7.tgz) = 4463fafb8420a91825e165da7a296aaabd70abea SHA1 (qwtplot3d-0.2.7.tgz) = 4463fafb8420a91825e165da7a296aaabd70abea
RMD160 (qwtplot3d-0.2.7.tgz) = 0f28462cb95ef6091d73642c8b26ece60d50bfb8 RMD160 (qwtplot3d-0.2.7.tgz) = 0f28462cb95ef6091d73642c8b26ece60d50bfb8
Size (qwtplot3d-0.2.7.tgz) = 183836 bytes Size (qwtplot3d-0.2.7.tgz) = 183836 bytes
SHA1 (patch-aa) = e46978e1d3b0b68ed5481861fc99703b8fa44ff3 SHA1 (patch-aa) = e46978e1d3b0b68ed5481861fc99703b8fa44ff3
SHA1 (patch-include_qwt3d__openglhelper.h) = ffb9b5c4d883bd3823b1dd1efcdbd09620683d1f

View file

@ -0,0 +1,12 @@
$NetBSD: patch-include_qwt3d__openglhelper.h,v 1.1 2012/01/23 20:55:48 joerg Exp $
--- include/qwt3d_openglhelper.h.orig 2012-01-23 14:34:35.000000000 +0000
+++ include/qwt3d_openglhelper.h
@@ -6,6 +6,7 @@
#include <qgl.h>
#else
#include <QtOpenGL/qgl.h>
+#include <GL/glu.h>
#endif
namespace Qwt3D