Add DragonFly support.

This commit is contained in:
joerg 2005-12-30 23:49:08 +00:00
parent 36b1417ad4
commit 898e04c8c1
4 changed files with 32 additions and 3 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.45 2005/12/29 06:22:19 jlam Exp $
# $NetBSD: Makefile,v 1.46 2005/12/30 23:49:08 joerg Exp $
#
DISTNAME= icu-3.2
@ -37,7 +37,7 @@ CONFIGURE_ARGS+= --disable-threads
.include "../../mk/compiler.mk"
.if ${OPSYS} == "FreeBSD" || ${OPSYS} == "NetBSD" || ${OPSYS} == "OpenBSD"
.if ${OPSYS} == "FreeBSD" || ${OPSYS} == "NetBSD" || ${OPSYS} == "OpenBSD" || ${OPSYS} == "DragonFly"
PLIST_SUBST+= MH_NAME=mh-bsd-gcc
.elif ${OPSYS} == "Linux"
PLIST_SUBST+= MH_NAME=mh-linux

View file

@ -1,8 +1,10 @@
$NetBSD: distinfo,v 1.10 2005/03/27 10:27:20 recht Exp $
$NetBSD: distinfo,v 1.11 2005/12/30 23:49:08 joerg Exp $
SHA1 (icu-3.2.tgz) = 23fa1feb893a562408e6f13fcf968a6177d8aa6e
RMD160 (icu-3.2.tgz) = 69720d12c5076de4f7ff865a6709d405ce3f1bb5
Size (icu-3.2.tgz) = 9587961 bytes
SHA1 (patch-aa) = 108ac871bfbf72c97ef2241e2d7294f3084f9c8b
SHA1 (patch-ab) = 86ca3d2cd4ba2e71132b41f3a1d26fb2778448cf
SHA1 (patch-ad) = 4080b584553446485084b34f177131edecce9ba9
SHA1 (patch-ae) = 39ea97c492859e09386dde595004927a2d4537c8
SHA1 (patch-af) = cbf5c84b69c6a02d33d61f63c55838cda4ed5c17

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ad,v 1.6 2005/12/30 23:49:08 joerg Exp $
--- configure.orig 2005-12-30 22:47:03.000000000 +0000
+++ configure
@@ -1552,7 +1552,8 @@ powerpc*-*-linux*)
else
icu_cv_host_frag=mh-cygwin-msvc
fi ;;
-*-*-*bsd*) icu_cv_host_frag=mh-bsd-gcc ;;
+*-*-*bsd*|*-*-dragonfly*)
+ icu_cv_host_frag=mh-bsd-gcc ;;
*-*-aix*)
if test "$GCC" = yes; then
icu_cv_host_frag=mh-aix-gcc

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.6 2005/12/30 23:49:08 joerg Exp $
--- runConfigureICU.orig 2005-12-30 22:46:43.000000000 +0000
+++ runConfigureICU
@@ -284,7 +284,7 @@ case $platform in
RELEASE_CFLAGS='-O2'
RELEASE_CXXFLAGS='-O2'
;;
- *BSD)
+ *BSD | DragonFly)
THE_OS="BSD"
THE_COMP="the GNU C++"
CC=gcc; export CC