Fix idiotic configure script which creates po/Makefile.in dynamically

and therefore slips through the normal patching code.

Inspired by and supposed to fix: PR 35193
This commit is contained in:
joerg 2006-12-06 15:29:15 +00:00
parent 5d2e752454
commit 89b431af47
3 changed files with 18 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.30 2006/11/25 13:23:01 adam Exp $
# $NetBSD: Makefile,v 1.31 2006/12/06 15:29:15 joerg Exp $
DISTNAME= fontforge_full-${VERSION}
PKGNAME= fontforge-${VERSION}
@ -12,6 +12,8 @@ COMMENT= Postscript font editor
VERSION= 20061014
MAKE_ENV+= PKGLOCALEDIR=${PKGLOCALEDIR:Q}
USE_LIBTOOL= yes
USE_PKGLOCALEDIR= yes
USE_TOOLS+= gmake msgfmt

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.28 2006/11/25 13:23:01 adam Exp $
$NetBSD: distinfo,v 1.29 2006/12/06 15:29:15 joerg Exp $
SHA1 (fontforge_full-20061014.tar.bz2) = adb760d2162062dd25303ebb6cf17c3d5cad0b55
RMD160 (fontforge_full-20061014.tar.bz2) = 6f6c315b554b5399e78f07c7f3f8dd0b839cb160
@ -7,3 +7,4 @@ SHA1 (patch-aa) = 7f7a11310fc5050b58e901e08c182dc5025874c6
SHA1 (patch-ab) = ec93a47051186bcb901fd145edffad7c457c33fd
SHA1 (patch-ac) = 7fe3d9174e407e04966081155965ff994a0fd69b
SHA1 (patch-ad) = 6a76e7e5e4882eb5af6f31ff3dbc6e7c17b69784
SHA1 (patch-ae) = 33993f03402d12067b3335b0bbb830252a5b49ac

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.4 2006/12/06 15:29:16 joerg Exp $
--- configure.orig 2006-12-06 15:13:54.000000000 +0000
+++ configure
@@ -24030,7 +24030,7 @@ if test "$gww_has_gettext" = "yes" >/dev
cat </dev/null >po/Makefile.in
echo 'prefix = @prefix@' >> po/Makefile.in
- echo 'localedir = $(prefix)/share/locale' >> po/Makefile.in
+ echo 'localedir = ${PREFIX}/${PKGLOCALEDIR}/locale' >> po/Makefile.in
echo 'INSTALL = @INSTALL@' >> po/Makefile.in
echo 'INSTALL_DATA = @INSTALL_DATA@' >> po/Makefile.in
echo '' >> po/Makefile.in