blender: PLIST cleanup, python 3.7 patch, build patches
This commit is contained in:
parent
a63c784433
commit
89b89e8901
7 changed files with 2279 additions and 2205 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.142 2018/12/13 19:51:58 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.143 2019/03/27 11:05:57 markd Exp $
|
||||
|
||||
DISTNAME= blender-2.79b
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://download.blender.org/source/
|
||||
|
||||
|
@ -21,7 +21,7 @@ CMAKE_OPTS+= -DPYTHON_ROOT_DIR:STRING=${PREFIX}
|
|||
CMAKE_OPTS+= -DPYTHON_INCLUDE_DIR:STRING=${PREFIX}/${PYINC}
|
||||
CMAKE_OPTS+= -DPYTHON_INCLUDE_CONFIG_DIR:STRING=${PREFIX}/${PYINC}
|
||||
CMAKE_OPTS+= -DPYTHON_EXECUTABLE:FILEPATH=${PYTHONBIN}
|
||||
CMAKE_OPTS+= -DPYTHON_LIBRARY:FILEPATH=${PREFIX}/lib/libpython${PYVERSSUFFIX}.so
|
||||
CMAKE_OPTS+= -DPYTHON_LIBRARY:FILEPATH=${PREFIX}/lib/libpython${PYVERSSUFFIX}${M}.so
|
||||
CMAKE_OPTS+= -DCMAKE_INSTALL_PREFIX:PATH=${PREFIX}/share/blender
|
||||
CMAKE_OPTS+= -DCMAKE_MODULE_PATH:PATH=${_CMAKE_DIR}
|
||||
CMAKE_OPTS+= -DCMAKE_SKIP_RPATH:BOOL=TRUE
|
||||
|
@ -46,9 +46,13 @@ REPLACE_PYTHON= release/bin/blender-thumbnailer.py
|
|||
|
||||
.include "options.mk"
|
||||
|
||||
|
||||
M=
|
||||
|
||||
INSTALLATION_DIRS= bin share/blender
|
||||
|
||||
PLIST_SUBST+= PYVERSSUFFIX=${PYVERSSUFFIX}
|
||||
PLIST_SUBST+= M=${M}
|
||||
PLIST_SUBST+= BLENDERVER=${PKGVERSION_NOREV:C/[a-z]//}
|
||||
|
||||
.if !empty(MACHINE_PLATFORM:MNetBSD-8.*)
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,10 +1,12 @@
|
|||
@comment $NetBSD: PLIST.Linux,v 1.6 2017/12/19 09:16:29 markd Exp $
|
||||
@comment $NetBSD: PLIST.Linux,v 1.7 2019/03/27 11:05:57 markd Exp $
|
||||
${PLIST.py36}share/blender/${BLENDERVER}/python/lib/python${PYVERSSUFFIX}/_sysconfigdata_linux.py
|
||||
${PLIST.py37}share/blender/${BLENDERVER}/python/lib/python${PYVERSSUFFIX}/_sysconfigdata_linux.py
|
||||
share/blender/${BLENDERVER}/python/lib/python${PYVERSSUFFIX}/lib-dynload/_curses.so
|
||||
share/blender/${BLENDERVER}/python/lib/python${PYVERSSUFFIX}/lib-dynload/_elementtree.so
|
||||
share/blender/${BLENDERVER}/python/lib/python${PYVERSSUFFIX}/lib-dynload/_sqlite3.so
|
||||
share/blender/${BLENDERVER}/python/lib/python${PYVERSSUFFIX}/lib-dynload/ossaudiodev.so
|
||||
share/blender/${BLENDERVER}/python/lib/python${PYVERSSUFFIX}/lib-dynload/readline.so
|
||||
share/blender/${BLENDERVER}/python/lib/python${PYVERSSUFFIX}/lib-dynload/spwd.so
|
||||
${PLIST.py35}share/blender/${BLENDERVER}/python/lib/python${PYVERSSUFFIX}/plat-linux/CDROM.py
|
||||
${PLIST.py35}share/blender/${BLENDERVER}/python/lib/python${PYVERSSUFFIX}/plat-linux/DLFCN.py
|
||||
${PLIST.py35}share/blender/${BLENDERVER}/python/lib/python${PYVERSSUFFIX}/plat-linux/IN.py
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.50 2018/10/07 23:44:49 ryoon Exp $
|
||||
$NetBSD: distinfo,v 1.51 2019/03/27 11:05:57 markd Exp $
|
||||
|
||||
SHA1 (blender-2.79b.tar.gz) = 4fd307ccfd1d6df5cc1898009712d4b1ae35430f
|
||||
RMD160 (blender-2.79b.tar.gz) = 787fc2ee718157aa95ffcced4935355d3086ca0d
|
||||
|
@ -9,5 +9,8 @@ SHA1 (patch-extern_glog_src_base_mutex.h) = 34a20264581a093a1686f1d13a6fccbd5cd9
|
|||
SHA1 (patch-extern_glog_src_config.h) = 9666c5d925cfeebeef2f178418c9fc2403831da1
|
||||
SHA1 (patch-extern_glog_src_config__netbsd.h) = be4727135b8fe1ddbcb5ad52f8230aec51a1a909
|
||||
SHA1 (patch-extern_glog_src_utilities.h) = c78ef191ab6ec7e65837b88468a7e1b8eaf325d3
|
||||
SHA1 (patch-intern_cycles_util_util_sseb.h) = 5d5bf8d71a443b63959ec79072e458f1a43cde94
|
||||
SHA1 (patch-intern_guardedalloc_intern_mallocn__intern.h) = c7bc89af1c03b50ae0bd8af5aacc25cd82dfcbfc
|
||||
SHA1 (patch-intern_itasc_kdl_tree.hpp) = b0c6640853ace08c07b443ff8f18290367f1d8da
|
||||
SHA1 (patch-source_blender_imbuf_intern_dds_DirectDrawSurface.cpp) = b38f61900aa30b02479c7397062d71d295932847
|
||||
SHA1 (patch-source_blender_python_intern_bpy_rna.c) = e287c41e0196bfa3650bfaa5d4263f5862467b80
|
||||
|
|
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-intern_cycles_util_util_sseb.h,v 1.1 2019/03/27 11:05:57 markd Exp $
|
||||
|
||||
Fix bad register cast in sseb
|
||||
commit be587d76efff6610f3b6d65cf42f1ee31ec3bdee
|
||||
|
||||
--- intern/cycles/util/util_sseb.h.orig 2018-03-23 15:22:25.000000000 +0000
|
||||
+++ intern/cycles/util/util_sseb.h
|
||||
@@ -116,7 +116,7 @@ __forceinline const sseb unpacklo( const
|
||||
__forceinline const sseb unpackhi( const sseb& a, const sseb& b ) { return _mm_unpackhi_ps(a, b); }
|
||||
|
||||
template<size_t i0, size_t i1, size_t i2, size_t i3> __forceinline const sseb shuffle( const sseb& a ) {
|
||||
- return _mm_shuffle_epi32(a, _MM_SHUFFLE(i3, i2, i1, i0));
|
||||
+ return _mm_castsi128_ps(_mm_shuffle_epi32(a, _MM_SHUFFLE(i3, i2, i1, i0)));
|
||||
}
|
||||
|
||||
template<> __forceinline const sseb shuffle<0, 1, 0, 1>( const sseb& a ) {
|
16
graphics/blender/patches/patch-intern_itasc_kdl_tree.hpp
Normal file
16
graphics/blender/patches/patch-intern_itasc_kdl_tree.hpp
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-intern_itasc_kdl_tree.hpp,v 1.3 2019/03/27 11:05:57 markd Exp $
|
||||
|
||||
Added extra "const" to satisfy the strict clang version in Xcode 9
|
||||
commit ee30a4381f8989ed9f39b4baae9f74e45c9dcdc9
|
||||
|
||||
--- intern/itasc/kdl/tree.hpp.orig 2018-03-23 15:22:25.000000000 +0000
|
||||
+++ intern/itasc/kdl/tree.hpp
|
||||
@@ -34,7 +34,7 @@ namespace KDL
|
||||
//Forward declaration
|
||||
class TreeElement;
|
||||
// Eigen allocator is needed for alignment of Eigen data types
|
||||
- typedef std::map<std::string,TreeElement, std::less<std::string>, Eigen::aligned_allocator<std::pair<std::string, TreeElement> > > SegmentMap;
|
||||
+ typedef std::map<std::string,TreeElement, std::less<std::string>, Eigen::aligned_allocator<std::pair<const std::string, TreeElement> > > SegmentMap;
|
||||
|
||||
class TreeElement
|
||||
{
|
|
@ -0,0 +1,34 @@
|
|||
$NetBSD: patch-source_blender_python_intern_bpy_rna.c,v 1.1 2019/03/27 11:05:57 markd Exp $
|
||||
|
||||
From 1db47a2ccd1e68994bf8140eba6cc2a26a2bc91f Mon Sep 17 00:00:00 2001
|
||||
From: Campbell Barton <ideasman42@gmail.com>
|
||||
Date: Thu, 12 Jul 2018 08:28:06 +0200
|
||||
Subject: [PATCH] Fix PyRNA class registration w/ Python 3.7
|
||||
|
||||
In Python3.7 this now raises an error.
|
||||
|
||||
--- source/blender/python/intern/bpy_rna.c.orig 2018-03-23 15:22:25.000000000 +0000
|
||||
+++ source/blender/python/intern/bpy_rna.c
|
||||
@@ -7385,10 +7385,12 @@ static int bpy_class_validate_recursive(
|
||||
if (!(flag & PROP_REGISTER))
|
||||
continue;
|
||||
|
||||
+ /* TODO(campbell): Use Python3.7x _PyObject_LookupAttr(), also in the macro below. */
|
||||
identifier = RNA_property_identifier(prop);
|
||||
item = PyObject_GetAttrString(py_class, identifier);
|
||||
|
||||
if (item == NULL) {
|
||||
+ PyErr_Clear();
|
||||
/* Sneaky workaround to use the class name as the bl_idname */
|
||||
|
||||
#define BPY_REPLACEMENT_STRING(rna_attr, py_attr) \
|
||||
@@ -7404,6 +7406,9 @@ static int bpy_class_validate_recursive(
|
||||
} \
|
||||
Py_DECREF(item); \
|
||||
} \
|
||||
+ else { \
|
||||
+ PyErr_Clear(); \
|
||||
+ } \
|
||||
} /* intentionally allow else here */
|
||||
|
||||
if (false) {} /* needed for macro */
|
Loading…
Reference in a new issue