Update Window Maker to 0.60.0. From the ChangeLog:

Changes since version 0.53.0:
.............................

- fixed a bug that caused icon overlaping in Clip, when icon was moved around.
- this time really added libwmfun to distribution.
- made deiconification not automatically focus window in sloppy focus
- fixed crash with DisableMiniwindows and icon pixmap changes
- fixed crash when changing icon of window without WM_CLASS
- added hysteresys for offscreen menu scrollback
- fixed bug with IgnoreFocusClick
- fixed crash with windows with width == 1 (Alban Hertroys
                                        <dalroi@wit401310.student.utwente.nl>)
- added SHEXEC command
- fixed resizebarback for SHADOW_RESIZEBAR ( jim knoble jmknoble@pobox.com)
- added balloon help everywhere
- fixed bug with FullMaximize attribute
- GNOME: button events not bound in wmaker are proxyized (to gmc)
                                (Paul Warren <pdw@ferret.lmh.ox.ac.uk>)
- fixed bug with restoration of maximized window after restart with
  --enable-kde
- added high-quality filtered rescaling (smoothed rescaling) to wrlib/wmsetbg
- added SmoothWorkspaceBack
- fixed crash bug in Paths section of WPrefs
- optimized image rendering for 15/16 bpp
- user menus' paths were changed. See NEWS.
- added a timeout for the workspace name fading
- HP-UX compiler compatibility workarounds (Sebastien Bauer
                                                seb_bauer@bigfoot.com)
- fixed crash with attributes panel
- save state of all menus when exiting (Sebastien Bauer
                                                seb_bauer@bigfoot.com)
- added GNUstep info panel (still needs beautification..)
- made the paths selector in WPrefs.app use the open file panel
- fixed crash bug with hiding apps without dock/clip
- fixed a mem leak in superfluous mode caused by the ghost icon.
- added possibility to set omnipresent icons in Clip. See NEWS.
- fixed bug in WPrefs menu editor
- fixed crash when moving internal window with kbd
- fixed compilation problem on IRIX machines (Neil Muller
                                                <neil@octane.sun.ac.za>)
- replace xde support drop on dock with xdnd.
- added an (internal use) environment variable for telling WPrefs whats's
  the name of the wmaker binary being ran.
- more elegant text entries in Clip's menu, regarding single/multiple
  selected icons.
- fixed cosmetic bug in geom. dpy window for 8bpp
- removed --enable-kanji and added MultiByteText option
- rewrote font code to use WINGs
- made autoraise only work for the active window
- fixed compilation problem with OpenWindows and other non-X11R6 systems..
- fixed crash bug when iconsize=24
- fixed portability prob with raise() in SunOS
- fixed icon placement bug (Markus Schoder <Markus.Schoder@online.de>)
- added delete button in file panel.
This commit is contained in:
jlam 1999-06-21 04:46:52 +00:00
parent 8475357fcd
commit 89d0567ee7
5 changed files with 41 additions and 27 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.29 1999/05/20 20:09:53 tron Exp $
# $NetBSD: Makefile,v 1.30 1999/06/21 04:46:52 jlam Exp $
DISTNAME= WindowMaker-0.53.0
PKGNAME= windowmaker-0.53.0
DISTNAME= WindowMaker-0.60.0
PKGNAME= windowmaker-0.60.0
CATEGORIES= x11
MASTER_SITES= ftp://ftp.windowmaker.org/pub/beta/srcs/ \
ftp://shadowmere.student.utwente.nl/pub/WindowMaker/ \
@ -49,7 +49,7 @@ CONFIGURE_ARGS+= --enable-${OPTION}
# are installed.
#
.if defined(LINGUAS)
DEPENDS+= gettext-0.10.35:../../devel/gettext
BUILD_DEPENDS+= gettext-0.10.35:../../devel/gettext
CONFIGURE_ARGS+= --enable-modelock
CONFIGURE_ENV+= LINGUAS="${LINGUAS}"

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.10 1999/05/02 17:59:21 rh Exp $
$NetBSD: md5,v 1.11 1999/06/21 04:46:53 jlam Exp $
MD5 (WindowMaker-0.53.0.tar.gz) = dcee7132e06e9362a8b3c7ea56f29682
MD5 (WindowMaker-0.60.0.tar.gz) = caaf05d825f861ce4824638cda748827

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.6 1999/04/16 20:08:16 jlam Exp $
$NetBSD: patch-aa,v 1.7 1999/06/21 04:46:53 jlam Exp $
--- doc/Makefile.in.orig Thu Apr 1 11:49:35 1999
+++ doc/Makefile.in Wed Apr 14 02:41:54 1999
@@ -127,7 +127,7 @@
--- doc/Makefile.in.orig Thu Jun 3 07:56:15 1999
+++ doc/Makefile.in Thu Jun 10 23:13:47 1999
@@ -131,7 +131,7 @@
for i in $$list; do \
if test -f $(srcdir)/$$i; then file=$(srcdir)/$$i; \
else file=$$i; fi; \

View file

@ -1,21 +1,21 @@
$NetBSD: patch-ab,v 1.8 1999/04/16 20:08:16 jlam Exp $
$NetBSD: patch-ab,v 1.9 1999/06/21 04:46:53 jlam Exp $
--- configure.orig Thu Apr 1 11:49:36 1999
+++ configure Wed Apr 14 02:43:30 1999
@@ -1302,7 +1302,8 @@
echo "$ac_t""no" 1>&6
--- configure.orig Thu Jun 3 07:42:09 1999
+++ configure Thu Jun 10 23:19:53 1999
@@ -1478,7 +1478,8 @@
fi
rm -f confcache
-# Always use our own libtool.
+# Use NetBSD's pkglibtool
-
+# Use NetBSD's pkglibtool.
+if false; then
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
# Check for any special flags to pass to ltconfig.
@@ -1347,6 +1348,7 @@
${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig \
$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
# Actually configure libtool. ac_aux_dir is where install-sh is found.
CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
@@ -1507,6 +1508,7 @@
# Redirect the config.log output again, so that the ltconfig log is not
# clobbered by the next message.
exec 5>>./config.log
+fi

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST.nolinguas,v 1.5 1999/05/02 17:59:21 rh Exp $
@comment $NetBSD: PLIST.nolinguas,v 1.6 1999/06/21 04:46:53 jlam Exp $
GNUstep/Apps/WPrefs.app/WPrefs
GNUstep/Apps/WPrefs.app/WPrefs.tiff
GNUstep/Apps/WPrefs.app/WPrefs.xpm
@ -29,11 +29,15 @@ GNUstep/Apps/WPrefs.app/tiff/miscprefs2.tiff
GNUstep/Apps/WPrefs.app/tiff/moreanim.tiff
GNUstep/Apps/WPrefs.app/tiff/mousesettings.tiff
GNUstep/Apps/WPrefs.app/tiff/mousespeed.tiff
GNUstep/Apps/WPrefs.app/tiff/msty1.tiff
GNUstep/Apps/WPrefs.app/tiff/msty2.tiff
GNUstep/Apps/WPrefs.app/tiff/msty3.tiff
GNUstep/Apps/WPrefs.app/tiff/newstyle.tiff
GNUstep/Apps/WPrefs.app/tiff/nonopaque.tiff
GNUstep/Apps/WPrefs.app/tiff/oldstyle.tiff
GNUstep/Apps/WPrefs.app/tiff/opaque.tiff
GNUstep/Apps/WPrefs.app/tiff/paths.tiff
GNUstep/Apps/WPrefs.app/tiff/smooth.tiff
GNUstep/Apps/WPrefs.app/tiff/sound.tiff
GNUstep/Apps/WPrefs.app/tiff/speed0.tiff
GNUstep/Apps/WPrefs.app/tiff/speed0s.tiff
@ -94,11 +98,15 @@ GNUstep/Apps/WPrefs.app/xpm/miscprefs2.xpm
GNUstep/Apps/WPrefs.app/xpm/moreanim.xpm
GNUstep/Apps/WPrefs.app/xpm/mousesettings.xpm
GNUstep/Apps/WPrefs.app/xpm/mousespeed.xpm
GNUstep/Apps/WPrefs.app/xpm/msty1.xpm
GNUstep/Apps/WPrefs.app/xpm/msty2.xpm
GNUstep/Apps/WPrefs.app/xpm/msty3.xpm
GNUstep/Apps/WPrefs.app/xpm/newstyle.xpm
GNUstep/Apps/WPrefs.app/xpm/nonopaque.xpm
GNUstep/Apps/WPrefs.app/xpm/oldstyle.xpm
GNUstep/Apps/WPrefs.app/xpm/opaque.xpm
GNUstep/Apps/WPrefs.app/xpm/paths.xpm
GNUstep/Apps/WPrefs.app/xpm/smooth.xpm
GNUstep/Apps/WPrefs.app/xpm/sound.xpm
GNUstep/Apps/WPrefs.app/xpm/speed0.xpm
GNUstep/Apps/WPrefs.app/xpm/speed0s.xpm
@ -110,7 +118,10 @@ GNUstep/Apps/WPrefs.app/xpm/speed3.xpm
GNUstep/Apps/WPrefs.app/xpm/speed3s.xpm
GNUstep/Apps/WPrefs.app/xpm/speed4.xpm
GNUstep/Apps/WPrefs.app/xpm/speed4s.xpm
GNUstep/Apps/WPrefs.app/xpm/tdel.xpm
GNUstep/Apps/WPrefs.app/xpm/tedit.xpm
GNUstep/Apps/WPrefs.app/xpm/temp.xpm
GNUstep/Apps/WPrefs.app/xpm/textr.xpm
GNUstep/Apps/WPrefs.app/xpm/theme.xpm
GNUstep/Apps/WPrefs.app/xpm/timer0.xpm
GNUstep/Apps/WPrefs.app/xpm/timer0s.xpm
@ -124,6 +135,7 @@ GNUstep/Apps/WPrefs.app/xpm/timer4.xpm
GNUstep/Apps/WPrefs.app/xpm/timer4s.xpm
GNUstep/Apps/WPrefs.app/xpm/timer5.xpm
GNUstep/Apps/WPrefs.app/xpm/timer5s.xpm
GNUstep/Apps/WPrefs.app/xpm/tnew.xpm
GNUstep/Apps/WPrefs.app/xpm/whandling.xpm
GNUstep/Apps/WPrefs.app/xpm/windowfocus.xpm
GNUstep/Apps/WPrefs.app/xpm/workspace.xpm
@ -155,7 +167,7 @@ include/wraster.h
lib/libWINGs.a
lib/libWMaker.a
lib/libwraster.a
lib/libwraster.so.2.1
lib/libwraster.so.3.0
man/man1/geticonset.1
man/man1/getstyle.1
man/man1/seticons.1
@ -163,6 +175,7 @@ man/man1/setstyle.1
man/man1/wdwrite.1
man/man1/wmaker.1
man/man1/wmsetbg.1
man/man1/wsetfont.1
man/man1/wxcopy.1
man/man1/wxpaste.1
share/WINGs/Images.tiff
@ -285,9 +298,10 @@ share/WindowMaker/menu.tr
share/WindowMaker/menu.zh_CN
share/WindowMaker/menu.zh_TW.Big5
share/WindowMaker/plmenu
share/WindowMaker/plmenu.dk
share/WindowMaker/plmenu.da
share/WindowMaker/plmenu.fr
share/WindowMaker/plmenu.hr
share/WindowMaker/plmenu.it
share/WindowMaker/plmenu.zh_CN
share/WindowMaker/wmmacros
share/WindowMaker/xtree.dat