lang/php82: update to 8.2.11

28 Sep 2023, PHP 8.2.11

- Core:
  . Fixed bug GH-11937 (Constant ASTs containing objects). (ilutov)
  . Fixed bug GH-11790 (On riscv64 require libatomic if actually needed).
    (Jeremie Courreges-Anglas)
  . Fixed bug GH-11876: ini_parse_quantity() accepts invalid quantities.
    (Girgias)
  . Fixed bug GH-12073 (Segfault when freeing incompletely initialized
    closures). (ilutov)
  . Fixed bug GH-12060 (Internal iterator rewind handler is called twice).
    (ju1ius)
  . Fixed bug GH-12102 (Incorrect compile error when using array access on TMP
    value in function call). (ilutov)

- DOM:
  . Fix memory leak when setting an invalid DOMDocument encoding. (nielsdos)

- Iconv:
  . Fixed build for NetBSD which still uses the old iconv signature.
    (David Carlier)

- Intl:
  . Fixed bug GH-12020 (intl_get_error_message() broken after
    MessageFormatter::formatMessage() fails). (Girgias)

- MySQLnd:
  . Fixed bug GH-10270 (Invalid error message when connection via SSL fails:
    "trying to connect via (null)"). (Kamil Tekiela)

- ODBC:
  . Fixed memory leak with failed SQLPrepare. (NattyNarwhal)
  . Fixed persistent procedural ODBC connections not getting closed.
    (NattyNarwhal)

- SimpleXML:
  . Fixed bug #52751 (XPath processing-instruction() function is not
    supported). (nielsdos)

- SPL:
  . Fixed bug GH-11972 (RecursiveCallbackFilterIterator regression in 8.1.18).
    (nielsdos)

- SQLite3:
  . Fixed bug GH-11878 (SQLite3 callback functions cause a memory leak with
    a callable array). (nielsdos, arnaud-lb)
This commit is contained in:
taca 2023-09-29 15:08:06 +00:00
parent 87e32d2358
commit 89ed167762
3 changed files with 16 additions and 16 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: phpversion.mk,v 1.408 2023/09/02 14:49:39 taca Exp $
# $NetBSD: phpversion.mk,v 1.409 2023/09/29 15:08:06 taca Exp $
#
# This file selects a PHP version, based on the user's preferences and
# the installed packages. It does not add a dependency on the PHP
@ -91,7 +91,7 @@ PHP56_VERSION= 5.6.40
PHP74_VERSION= 7.4.33
PHP80_VERSION= 8.0.30
PHP81_VERSION= 8.1.23
PHP82_VERSION= 8.2.10
PHP82_VERSION= 8.2.11
# Define API version or initial release of major version.
PHP56_RELDATE= 20140828

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.12 2023/09/02 14:47:35 taca Exp $
$NetBSD: distinfo,v 1.13 2023/09/29 15:08:06 taca Exp $
BLAKE2s (php-8.2.10.tar.xz) = 6d8b2a687ed3acad58ac6cd174dc43acce92ff112bca095cbca8e39cb3232ed9
SHA512 (php-8.2.10.tar.xz) = b9123f63afc99fdce34182f49a022611d584bd4a26f624d0010785599e9b10af7924f8307bbca920d75cb7b0cc23fa57efd5d6ef1d2dd89d5a508578bd36b146
Size (php-8.2.10.tar.xz) = 12041348 bytes
SHA1 (patch-configure) = b2445d8b39c1e6c4a8d7abdd45f9cb217e7cd71b
BLAKE2s (php-8.2.11.tar.xz) = ee63ca3cecf20547ac0bda9d7280660c0e0ca7c41d4ca3ed2679ca768f16628d
SHA512 (php-8.2.11.tar.xz) = 3c8db245854c0221a952e0f11fc8fbf8944caf73ae0049a710db0db5ce9c018207444dc8a60e2b3c63a6d025c5d09cd17b0542e1b7df8ad2e49635ef5faf7f45
Size (php-8.2.11.tar.xz) = 12046180 bytes
SHA1 (patch-configure) = be51847b1641413b97d1dd998c8188160fce7a4c
SHA1 (patch-ext_enchant_enchant.c) = 7d999de1b2fde2ea11e4a6e16e7b59c085924b9b
SHA1 (patch-ext_phar_Makefile.frag) = 53ea5c58b0bc27d236118d5750a74b1cba43e5dd
SHA1 (patch-ext_standard_php__fopen__wrapper.c) = 0a2c19c18f089448a8d842e99738b292ab9e5640

View file

@ -1,12 +1,12 @@
$NetBSD: patch-configure,v 1.10 2023/09/02 14:47:35 taca Exp $
$NetBSD: patch-configure,v 1.11 2023/09/29 15:08:06 taca Exp $
* Do not include "PKG_CONFIG*" in CONFIGURE_OPTIONS.
* Don't autodetect maintainer-zts.
* Shell portability.
--- configure.orig 2023-08-29 15:31:38.000000000 +0000
--- configure.orig 2023-09-26 11:11:58.000000000 +0000
+++ configure
@@ -3732,6 +3732,10 @@ EOF
@@ -4323,6 +4323,10 @@ EOF
else
break
fi
@ -14,10 +14,10 @@ $NetBSD: patch-configure,v 1.10 2023/09/02 14:47:35 taca Exp $
+ \'PKG_CONFIG\=*) CURRENT_ARG="'PKG_CONFIG=@TOOLS_PATH.pkg-config@'";;
+ \'PKG_CONFIG_LIBDIR\=*) CURRENT_ARG="'PKG_CONFIG_LIBDIR=@PHP_PKGCONFIG_PATH@'";;
+ esac
$as_echo "$CURRENT_ARG \\" >>config.nice
printf "%s\n" "$CURRENT_ARG \\" >>config.nice
CONFIGURE_OPTIONS="$CONFIGURE_OPTIONS $CURRENT_ARG"
done
@@ -7023,30 +7027,6 @@ EOF
@@ -7554,30 +7558,6 @@ EOF
;;
esac
@ -42,18 +42,18 @@ $NetBSD: patch-configure,v 1.10 2023/09/02 14:47:35 taca Exp $
-
- fi
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; }
- { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-printf "%s\n" "yes" >&6; }
-
PHP_VAR_SUBST="$PHP_VAR_SUBST APXS"
else
@@ -78526,7 +78506,7 @@ $as_echo "#define HAVE_TIDYBUFFIO_H 1" >
@@ -81253,7 +81233,7 @@ printf "%s\n" "#define HAVE_TIDYBUFFIO_H
fi
TIDY_LIBDIR=$TIDY_DIR/$PHP_LIBDIR
- if test "$TIDY_LIB_NAME" == 'tidyp'; then
+ if test "$TIDY_LIB_NAME" = 'tidyp'; then
$as_echo "#define HAVE_TIDYP_H 1" >>confdefs.h
printf "%s\n" "#define HAVE_TIDYP_H 1" >>confdefs.h