Fix shared library path on Darwin
This commit is contained in:
parent
4d09fbc407
commit
8a08e4db28
2 changed files with 13 additions and 3 deletions
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.10 2013/10/06 16:45:04 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.11 2013/10/14 06:30:47 adam Exp $
|
||||
|
||||
SHA1 (serf-1.3.2.tar.bz2) = 90478cd60d4349c07326cb9c5b720438cf9a1b5d
|
||||
RMD160 (serf-1.3.2.tar.bz2) = 8e3caf78f5bf906c0e20f33eab3f018b03363683
|
||||
Size (serf-1.3.2.tar.bz2) = 139861 bytes
|
||||
SHA1 (patch-SConstruct) = 6bb757f55a9baf60de3cea43afe5fdbd6d24de18
|
||||
SHA1 (patch-SConstruct) = 78eb23e8b3b9cd0ba497a355136d742b6d887bfc
|
||||
SHA1 (patch-buckets_ssl__buckets.c) = f940e1703d3a8cf879d5a563cf57826f027ed8e1
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: patch-SConstruct,v 1.3 2013/10/06 16:45:04 wiz Exp $
|
||||
$NetBSD: patch-SConstruct,v 1.4 2013/10/14 06:30:47 adam Exp $
|
||||
|
||||
Hack: Use OPENSSL variable as final shared library path; fixes lib id on Darwin.
|
||||
Don't append -O2 compiler flag.
|
||||
|
||||
--- SConstruct.orig 2013-10-04 15:11:04.000000000 +0000
|
||||
|
@ -21,3 +22,12 @@ Don't append -O2 compiler flag.
|
|||
env.Append(CPPDEFINES='NDEBUG')
|
||||
|
||||
### works for Mac OS. probably needs to change
|
||||
@@ -410,7 +409,7 @@ if sys.platform == 'darwin':
|
||||
# make applications depend on the exact major.minor.patch version of serf.
|
||||
|
||||
install_shared_path = install_shared[0].abspath
|
||||
- target_install_shared_path = os.path.join(libdir, '%s.dylib' % LIBNAME)
|
||||
+ target_install_shared_path = os.path.join('$OPENSSL', '%s.dylib' % LIBNAME)
|
||||
env.AddPostAction(install_shared, ('install_name_tool -id %s %s'
|
||||
% (target_install_shared_path,
|
||||
install_shared_path)))
|
||||
|
|
Loading…
Reference in a new issue