Fixed a gcc warning reported in PR 36777:

read.c:1426: warning: 'stopc' may be used uninitialized in this function
This commit is contained in:
rillig 2007-08-14 09:08:07 +00:00
parent d2a43c5046
commit 8a2abcff89
2 changed files with 15 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.8 2007/05/29 12:25:03 martti Exp $
$NetBSD: distinfo,v 1.9 2007/08/14 09:08:07 rillig Exp $
SHA1 (binutils-2.17.tar.gz) = a9ac9ac4e918568b297033cdc44a38beef8f9f6a
RMD160 (binutils-2.17.tar.gz) = bc5e8b23457f0e2e91f70b93eff00134e2d50434
@ -8,3 +8,4 @@ SHA1 (patch-ab) = 9d8a52de59f73cce90a1e8fff5d20849724ceb26
SHA1 (patch-ac) = 8165e2adb19eca4ec9b6e7fd3b52c6614910fa65
SHA1 (patch-ad) = 4aa005a473d1c4af052eaee84b98b1c0aff90bf1
SHA1 (patch-ae) = 8aa22782397a59c17801c791dddaefdf757d824e
SHA1 (patch-af) = ca9171203123d2563e0c49bd8fed4d1366d35691

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.1 2007/08/14 09:08:07 rillig Exp $
--- gas/read.c.orig 2005-11-17 08:29:28.000000000 +0100
+++ gas/read.c 2007-08-14 11:03:42.000000000 +0200
@@ -1423,7 +1423,7 @@ s_comm_internal (int param,
offsetT temp, size;
symbolS *symbolP = NULL;
char *stop = NULL;
- char stopc;
+ char stopc = '\0'; /* XXX: gcc -Wuninitialized */
expressionS exp;
if (flag_mri)