Avoid invalid compiler flag -fcf-protection on sparc*
This commit is contained in:
parent
35603b9579
commit
8a62059865
2 changed files with 17 additions and 1 deletions
|
@ -1,9 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.33 2020/07/31 09:20:39 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.34 2020/09/10 11:31:58 martin Exp $
|
||||
|
||||
SHA1 (exiv2-0.27.3-Source.tar.gz) = f31a74793ce2cd0161915ed1fbec8e79c31cd54d
|
||||
RMD160 (exiv2-0.27.3-Source.tar.gz) = 7e3ce6de75aaf87b46d419f86b4b0fc55f133234
|
||||
SHA512 (exiv2-0.27.3-Source.tar.gz) = 3f5758ee862b811eeb89cc75fc2bbd8bf10329efa2ce1e68555cdc7729faa6cfd1603e0cc859fbdbe6d8fd5e53bd9b9e6d869d8a20ed17497bf87ce78c005de9
|
||||
Size (exiv2-0.27.3-Source.tar.gz) = 26447901 bytes
|
||||
SHA1 (patch-cmake_compilerFlags.cmake) = 862dffae1571137e8e719d2de29bac8ae229cd87
|
||||
SHA1 (patch-cmake_config.h.cmake) = b7e0336e5ca55a9df08958a05d8ac2a2c800e836
|
||||
SHA1 (patch-contrib_organize_Makefile) = 27348fdb0f80092b6e16f27e3ac1dca988eefe70
|
||||
SHA1 (patch-contrib_organize_helpers.cpp) = ec003c826d463b3e7e571ab4c41baffaca1240e9
|
||||
|
|
15
graphics/exiv2/patches/patch-cmake_compilerFlags.cmake
Normal file
15
graphics/exiv2/patches/patch-cmake_compilerFlags.cmake
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-cmake_compilerFlags.cmake,v 1.1 2020/09/10 11:31:58 martin Exp $
|
||||
|
||||
Gcc on sparc* does not support -fcf-protection.
|
||||
|
||||
--- cmake/compilerFlags.cmake.orig 2020-06-30 15:33:22.000000000 +0200
|
||||
+++ cmake/compilerFlags.cmake 2020-09-10 13:20:12.412480808 +0200
|
||||
@@ -25,7 +25,7 @@
|
||||
|
||||
# This fails under Fedora, MinGW GCC 8.3.0 and CYGWIN/MSYS 9.3.0
|
||||
if (NOT (MINGW OR CMAKE_HOST_SOLARIS OR CYGWIN OR MSYS) )
|
||||
- if (COMPILER_IS_GCC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 8.0)
|
||||
+ if (COMPILER_IS_GCC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 8.0 AND NOT (${CMAKE_SYSTEM_PROCESSOR} MATCHES sparc.*))
|
||||
add_compile_options(-fstack-clash-protection -fcf-protection)
|
||||
endif()
|
||||
|
Loading…
Reference in a new issue