Upgrade games/eboard to v1.1.1, the last pre-github release.

Note that this release, while declaring compatibility with gnuchess
v4, does not work correctly with the current v6.x.

From upstream's changelog:

eboard ChangeLog
----------------

[fics]    - applies to fics
[craf]    - applies to crafty
[gnuc]    - applies to gnu chess
[sjen]    - applies to sjeng
[ics]     - applies to all networked servers
[eng]     - applies to all engines
[all]     - applies to all

  * [all]  Text search (Ctrl-F) no longer requires a modal dialog box,
           the search text is typed in the input box (similar to the Firefox
           search behavior).

  * [ics]  Added ICS filtering options for Non-ASCII characters.

  * [all]  Fixed some "invalid UTF-8 string" warnings related to the text console.

  * [ics]  added an option to show timestamps for each text line

  * [ics]  eboard no longer sets the seek variable when logging in to an
           ICS

  * [all]  Fixed promotion bug in P2P mode (capture promotions such as
           exf8=Q did not work due to bad notation parsing).
           Closes SF ticket #1832106.

  * [ics]  Seek graph positioning now avoids text and marker overlaps.

1.1.0a:
  * [all]  Fixed compilation issue with GCC 4.1

1.1.0:
  * [ics]  The seek graph do not become red after updates (FICS sometimes
           sends bogus updates that are annoying to check).

  * [ics]  added seek graph, removed seek table

  * [ics]  eboard now displays clocks and move times with milisecond
           precision, on servers that support ivar ms

  * [all]  slightly faster console (less frivolous buffer formattings)

  * [all]  minor simplification of eboard-config script, patch from
           Han Boetes
This commit is contained in:
hauke 2020-01-14 08:48:44 +00:00
parent 2adbefc7c4
commit 8a637a073e
4 changed files with 28 additions and 18 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.51 2019/08/11 13:21:03 wiz Exp $
# $NetBSD: Makefile,v 1.52 2020/01/14 08:48:44 hauke Exp $
#
DISTNAME= eboard-1.0.4
PKGREVISION= 37
DISTNAME= eboard-1.1.1
#PKGREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=eboard/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.8 2015/11/03 20:56:48 agc Exp $
$NetBSD: distinfo,v 1.9 2020/01/14 08:48:44 hauke Exp $
SHA1 (eboard-1.0.4.tar.bz2) = 44938754140043fc64143e91067c95b6c5c99709
RMD160 (eboard-1.0.4.tar.bz2) = f12b0927ca848418eb45a75bcff8a641766ae33c
SHA512 (eboard-1.0.4.tar.bz2) = f45024f32a6ccf4d35418844e30808f2b96c23344eb34452cf77fca8b431cfa7b93fce7f83e3139f13763abf96abf4fa97675314a2b78739fd71fb12b8556c1d
Size (eboard-1.0.4.tar.bz2) = 453603 bytes
SHA1 (patch-cimg.cc) = fc545a2f543a6fd863fe7f9c029c81fce0299eb9
SHA1 (eboard-1.1.1.tar.bz2) = 029cf1e7503fc2a862b9880da9ea6ab91e5614cd
RMD160 (eboard-1.1.1.tar.bz2) = 13bdfe6d33a143d619c6c5be8d849ced9b95e2c4
SHA512 (eboard-1.1.1.tar.bz2) = 0e124abc786996070464c3d9ef5eafa107b990df7593d774bf302e01e0d07427f2a67bc33ab61a188d2902aa35abb8cec6356e4e088f4a6b40e189556b588704
Size (eboard-1.1.1.tar.bz2) = 462386 bytes
SHA1 (patch-cimg.cc) = 23c019b869c95d4336dda5272eb6c50177686b71
SHA1 (patch-proto__xboard.cc) = 5792bee2f90f0576e8a401e6d405b5cfb8b3744e

View file

@ -1,11 +1,11 @@
$NetBSD: patch-cimg.cc,v 1.2 2012/08/12 21:38:11 wiz Exp $
$NetBSD: patch-cimg.cc,v 1.3 2020/01/14 08:48:44 hauke Exp $
Fix build with png-1.5.
https://sourceforge.net/tracker/?func=detail&aid=3515237&group_id=11164&atid=111164
--- cimg.cc.orig 2007-05-23 18:57:45.000000000 +0000
--- cimg.cc.orig 2020-01-13 16:13:00.560205280 +0000
+++ cimg.cc
@@ -95,16 +95,16 @@ CImg::CImg(const char *filename) {
@@ -94,11 +94,11 @@ CImg::CImg(const char *filename) {
ct == PNG_COLOR_TYPE_GRAY_ALPHA)
png_set_gray_to_rgb(pngp);
@ -14,12 +14,6 @@ https://sourceforge.net/tracker/?func=detail&aid=3515237&group_id=11164&atid=111
if (!ok) { fclose(f); return; }
ok = 0;
- rp = (png_bytep *) malloc(sizeof(png_bytep) * (pngp->height));
+ rp = (png_bytep *) malloc(sizeof(png_bytep) * (png_get_image_height(pngp, infp)));
if (rp==NULL) {
fclose(f); return;
}
- for(i=0;i<pngp->height;i++) {
+ for(i=0;i<png_get_image_height(pngp, infp);i++) {
png_read_row(pngp, (png_bytep) (&data[i*rowlen]), NULL);

View file

@ -0,0 +1,15 @@
$NetBSD: patch-proto__xboard.cc,v 1.1 2020/01/14 08:48:44 hauke Exp $
We install the GNU chess binary as 'gnuchess'
--- proto_xboard.cc.orig 2008-02-22 15:51:22.000000000 +0000
+++ proto_xboard.cc
@@ -1304,7 +1304,7 @@ void GnuChess4Protocol::initEngine() {
void GnuChess4Protocol::readDialog() {
XBoardProtocol::readDialog();
- strcpy(EngineCommandLine,"gnuchessx");
+ strcpy(EngineCommandLine,"gnuchess");
EngineRunDir[0]=0;
if (ebm) {