Update databases/couchdb to 1.3.0. Changes since 1.2.1:
Version 1.3.0 ------------- HTTP Interface: * No longer rewrites the X-CouchDB-Requested-Path during recursive calls to the rewriter. * Limit recursion depth in the URL rewriter. Defaults to a maximum of 100 invocations but is configurable. * Fix _session for IE7. * Added Server-Sent Events protocol to db changes API. See http://www.w3.org/TR/eventsource/ for details. * Make password hashing synchronous when using the /_config/admins API. * Include user name in show/list ETags. * Experimental support for Cross-Origin Resource Sharing (CORS). See http://www.w3.org/TR/cors/ for details. Replicator: * The replicator will use a new server-wide UUID in checkpoint IDs to improve the chances of an efficient resume. Storage System: * Fixed unnecessary conflict when deleting and creating a document in the same batch. View Server: * Additional response headers may be varied prior to send(). * GetRow() is now side-effect free. Futon: * Disabled the link to the Futon test suite. These tests were causing problems when run from a browser, and are now available via the CLI instead. * Added view request duration to Futon. * Disable buttons for actions that the user doesn't have permissions to. Security: * Passwords are now hashed using the PBKDF2 algorithm with a configurable work factor. Test Suite: * Moved the JS test suite to the CLI. * Improved tracebacks printed by the JS CLI tests. * Improved the reliability of a number of tests. UUID Algorithms: * Added the utc_id algorithm. URL Rewriter & Vhosts: * Database name is encoded during rewriting (allowing embedded /'s, etc). * Reset rewrite counter on new request, avoiding unnecessary request failures due to bogus rewrite limit reports. Build System: * C/C++ compiler detection has been improved. * Autoconf v2.63 is now required if building from Git checkout directly. See DEVELOPERS file for more details. * Fixed issue in couchdb script where stopped status returns before process exits. Version 1.2.2 ------------- HTTP Interface: * Reset rewrite counter on new request, avoiding unnecessary request failures due to bogus rewrite limit reports. Build System: * Fixed issue in couchdb script where stopped status returns before process exits.
This commit is contained in:
parent
99bd9282bb
commit
8aaa84db56
5 changed files with 190 additions and 62 deletions
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.16 2013/03/04 14:12:40 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.17 2013/04/24 12:22:37 jperkin Exp $
|
||||
#
|
||||
|
||||
DISTNAME= apache-couchdb-1.2.1
|
||||
DISTNAME= apache-couchdb-1.3.0
|
||||
PKGNAME= ${DISTNAME:S/apache-//}
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= ${MASTER_SITE_APACHE:=couchdb/1.2.1/}
|
||||
MASTER_SITES= ${MASTER_SITE_APACHE:=couchdb/source/1.3.0/}
|
||||
|
||||
MAINTAINER= filip@joyent.com
|
||||
HOMEPAGE= http://couchdb.apache.org/
|
||||
|
@ -70,7 +70,7 @@ REPLACE_FILES.sh= bin/couchdb.tpl.in
|
|||
|
||||
SUBST_CLASSES+= paths
|
||||
SUBST_MESSAGE.paths= Setting standard paths
|
||||
SUBST_STAGE.paths= post-patch
|
||||
SUBST_STAGE.paths= pre-configure
|
||||
SUBST_FILES.paths+= configure bin/couchdb.tpl.in
|
||||
SUBST_SED.paths= -e 's,@EGDIR@,${COUCH_EGDIR},g'
|
||||
SUBST_SED.paths+= -e 's,@RUNDIR@,${COUCH_RUNDIR},g'
|
||||
|
|
|
@ -1,11 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2012/09/17 09:42:46 fhajny Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2013/04/24 12:22:37 jperkin Exp $
|
||||
bin/couch-config
|
||||
bin/couchdb
|
||||
bin/couchjs
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch.app
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_api_wrap.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_api_wrap_httpc.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_app.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_auth_cache.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_btree.beam
|
||||
|
@ -25,34 +23,26 @@ lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_event_sup.beam
|
|||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_external_manager.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_external_server.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_file.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpc_pool.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_auth.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_cors.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_db.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_external.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_misc_handlers.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_oauth.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_proxy.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_replicator.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_rewrite.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_show.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_stats_handlers.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_vhost.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_httpd_view.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_key_tree.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_log.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_native_process.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_os_daemons.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_os_process.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_passwords.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_primary_sup.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_query_servers.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_ref_counter.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_rep_sup.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_replication_manager.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_replication_notifier.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_replicator.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_replicator_utils.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_replicator_worker.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_secondary_sup.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_server.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_server_sup.beam
|
||||
|
@ -63,20 +53,44 @@ lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_task_status.beam
|
|||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_users_db.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_util.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_uuids.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_view.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_view_compactor.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_view_group.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_view_updater.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/couch_work_queue.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/ebin/json_stream_parse.beam
|
||||
lib/erlang/lib/couch-${PKGVERSION}/include/couch_api_wrap.hrl
|
||||
lib/erlang/lib/couch-${PKGVERSION}/include/couch_db.hrl
|
||||
lib/erlang/lib/couch-${PKGVERSION}/include/couch_js_functions.hrl
|
||||
lib/erlang/lib/couch-${PKGVERSION}/include/couch_replicator.hrl
|
||||
lib/erlang/lib/couch-${PKGVERSION}/priv/couchspawnkillable
|
||||
lib/erlang/lib/couch-${PKGVERSION}/priv/lib/couch_ejson_compare.la
|
||||
lib/erlang/lib/couch-${PKGVERSION}/priv/lib/couch_icu_driver.la
|
||||
lib/erlang/lib/couch-${PKGVERSION}/priv/stat_descriptions.cfg
|
||||
lib/erlang/lib/couch_index-0.1/ebin/couch_index.beam
|
||||
lib/erlang/lib/couch_index-0.1/ebin/couch_index_compactor.beam
|
||||
lib/erlang/lib/couch_index-0.1/ebin/couch_index_server.beam
|
||||
lib/erlang/lib/couch_index-0.1/ebin/couch_index_updater.beam
|
||||
lib/erlang/lib/couch_index-0.1/ebin/couch_index_util.beam
|
||||
lib/erlang/lib/couch_mrview-0.1/ebin/couch_mrview.app
|
||||
lib/erlang/lib/couch_mrview-0.1/ebin/couch_mrview.beam
|
||||
lib/erlang/lib/couch_mrview-0.1/ebin/couch_mrview_cleanup.beam
|
||||
lib/erlang/lib/couch_mrview-0.1/ebin/couch_mrview_compactor.beam
|
||||
lib/erlang/lib/couch_mrview-0.1/ebin/couch_mrview_http.beam
|
||||
lib/erlang/lib/couch_mrview-0.1/ebin/couch_mrview_index.beam
|
||||
lib/erlang/lib/couch_mrview-0.1/ebin/couch_mrview_show.beam
|
||||
lib/erlang/lib/couch_mrview-0.1/ebin/couch_mrview_test_util.beam
|
||||
lib/erlang/lib/couch_mrview-0.1/ebin/couch_mrview_updater.beam
|
||||
lib/erlang/lib/couch_mrview-0.1/ebin/couch_mrview_util.beam
|
||||
lib/erlang/lib/couch_mrview-0.1/include/couch_mrview.hrl
|
||||
lib/erlang/lib/couch_replicator-0.1/ebin/couch_replicator.app
|
||||
lib/erlang/lib/couch_replicator-0.1/ebin/couch_replicator.beam
|
||||
lib/erlang/lib/couch_replicator-0.1/ebin/couch_replicator_api_wrap.beam
|
||||
lib/erlang/lib/couch_replicator-0.1/ebin/couch_replicator_httpc.beam
|
||||
lib/erlang/lib/couch_replicator-0.1/ebin/couch_replicator_httpc_pool.beam
|
||||
lib/erlang/lib/couch_replicator-0.1/ebin/couch_replicator_httpd.beam
|
||||
lib/erlang/lib/couch_replicator-0.1/ebin/couch_replicator_job_sup.beam
|
||||
lib/erlang/lib/couch_replicator-0.1/ebin/couch_replicator_manager.beam
|
||||
lib/erlang/lib/couch_replicator-0.1/ebin/couch_replicator_notifier.beam
|
||||
lib/erlang/lib/couch_replicator-0.1/ebin/couch_replicator_utils.beam
|
||||
lib/erlang/lib/couch_replicator-0.1/ebin/couch_replicator_worker.beam
|
||||
lib/erlang/lib/couch_replicator-0.1/include/couch_replicator.hrl
|
||||
lib/erlang/lib/couch_replicator-0.1/include/couch_replicator_api_wrap.hrl
|
||||
lib/erlang/lib/couch_replicator-0.1/include/couch_replicator_js_functions.hrl
|
||||
lib/erlang/lib/ejson-${VERSION.ejson}/ebin/ejson.app
|
||||
lib/erlang/lib/ejson-${VERSION.ejson}/ebin/ejson.beam
|
||||
lib/erlang/lib/ejson-${VERSION.ejson}/ebin/mochijson2.beam
|
||||
|
@ -90,14 +104,6 @@ lib/erlang/lib/erlang-oauth/ebin/oauth_plaintext.beam
|
|||
lib/erlang/lib/erlang-oauth/ebin/oauth_unix.beam
|
||||
lib/erlang/lib/erlang-oauth/ebin/oauth_uri.beam
|
||||
lib/erlang/lib/etap/ebin/etap.beam
|
||||
lib/erlang/lib/etap/ebin/etap_application.beam
|
||||
lib/erlang/lib/etap/ebin/etap_can.beam
|
||||
lib/erlang/lib/etap/ebin/etap_exception.beam
|
||||
lib/erlang/lib/etap/ebin/etap_process.beam
|
||||
lib/erlang/lib/etap/ebin/etap_report.beam
|
||||
lib/erlang/lib/etap/ebin/etap_request.beam
|
||||
lib/erlang/lib/etap/ebin/etap_string.beam
|
||||
lib/erlang/lib/etap/ebin/etap_web.beam
|
||||
lib/erlang/lib/ibrowse-${VERSION.ibrowse}/ebin/ibrowse.app
|
||||
lib/erlang/lib/ibrowse-${VERSION.ibrowse}/ebin/ibrowse.beam
|
||||
lib/erlang/lib/ibrowse-${VERSION.ibrowse}/ebin/ibrowse_app.beam
|
||||
|
@ -167,6 +173,96 @@ share/couchdb/www/dialog/_save_view_as.html
|
|||
share/couchdb/www/dialog/_share_test_reports.html
|
||||
share/couchdb/www/dialog/_signup.html
|
||||
share/couchdb/www/dialog/_upload_attachment.html
|
||||
share/couchdb/www/docs/_images/futon-createdb.png
|
||||
share/couchdb/www/docs/_images/futon-editdoc.png
|
||||
share/couchdb/www/docs/_images/futon-editeddoc.png
|
||||
share/couchdb/www/docs/_images/futon-overview.png
|
||||
share/couchdb/www/docs/_images/futon-replform.png
|
||||
share/couchdb/www/docs/_sources/api-basics.txt
|
||||
share/couchdb/www/docs/_sources/api/authn.txt
|
||||
share/couchdb/www/docs/_sources/api/configuration.txt
|
||||
share/couchdb/www/docs/_sources/api/database.txt
|
||||
share/couchdb/www/docs/_sources/api/dbmaint.txt
|
||||
share/couchdb/www/docs/_sources/api/design.txt
|
||||
share/couchdb/www/docs/_sources/api/documents.txt
|
||||
share/couchdb/www/docs/_sources/api/local.txt
|
||||
share/couchdb/www/docs/_sources/api/misc.txt
|
||||
share/couchdb/www/docs/_sources/api/reference.txt
|
||||
share/couchdb/www/docs/_sources/changelog.txt
|
||||
share/couchdb/www/docs/_sources/changes.txt
|
||||
share/couchdb/www/docs/_sources/commonjs.txt
|
||||
share/couchdb/www/docs/_sources/config_reference.txt
|
||||
share/couchdb/www/docs/_sources/configuring.txt
|
||||
share/couchdb/www/docs/_sources/cors.txt
|
||||
share/couchdb/www/docs/_sources/ddocs.txt
|
||||
share/couchdb/www/docs/_sources/errors.txt
|
||||
share/couchdb/www/docs/_sources/http-proxying.txt
|
||||
share/couchdb/www/docs/_sources/index.txt
|
||||
share/couchdb/www/docs/_sources/intro.txt
|
||||
share/couchdb/www/docs/_sources/json-structure.txt
|
||||
share/couchdb/www/docs/_sources/os-daemons.txt
|
||||
share/couchdb/www/docs/_sources/pretty_urls.txt
|
||||
share/couchdb/www/docs/_sources/query-servers.txt
|
||||
share/couchdb/www/docs/_sources/range.txt
|
||||
share/couchdb/www/docs/_sources/release.txt
|
||||
share/couchdb/www/docs/_sources/replication.txt
|
||||
share/couchdb/www/docs/_sources/ssl.txt
|
||||
share/couchdb/www/docs/_static/ajax-loader.gif
|
||||
share/couchdb/www/docs/_static/basic.css
|
||||
share/couchdb/www/docs/_static/comment-bright.png
|
||||
share/couchdb/www/docs/_static/comment-close.png
|
||||
share/couchdb/www/docs/_static/comment.png
|
||||
share/couchdb/www/docs/_static/default.css
|
||||
share/couchdb/www/docs/_static/doctools.js
|
||||
share/couchdb/www/docs/_static/down-pressed.png
|
||||
share/couchdb/www/docs/_static/down.png
|
||||
share/couchdb/www/docs/_static/favicon.ico
|
||||
share/couchdb/www/docs/_static/file.png
|
||||
share/couchdb/www/docs/_static/jquery.js
|
||||
share/couchdb/www/docs/_static/logo.png
|
||||
share/couchdb/www/docs/_static/minus.png
|
||||
share/couchdb/www/docs/_static/plus.png
|
||||
share/couchdb/www/docs/_static/pygments.css
|
||||
share/couchdb/www/docs/_static/rtd.css
|
||||
share/couchdb/www/docs/_static/searchtools.js
|
||||
share/couchdb/www/docs/_static/sidebar.js
|
||||
share/couchdb/www/docs/_static/underscore.js
|
||||
share/couchdb/www/docs/_static/up-pressed.png
|
||||
share/couchdb/www/docs/_static/up.png
|
||||
share/couchdb/www/docs/_static/websupport.js
|
||||
share/couchdb/www/docs/api-basics.html
|
||||
share/couchdb/www/docs/api/authn.html
|
||||
share/couchdb/www/docs/api/configuration.html
|
||||
share/couchdb/www/docs/api/database.html
|
||||
share/couchdb/www/docs/api/dbmaint.html
|
||||
share/couchdb/www/docs/api/design.html
|
||||
share/couchdb/www/docs/api/documents.html
|
||||
share/couchdb/www/docs/api/local.html
|
||||
share/couchdb/www/docs/api/misc.html
|
||||
share/couchdb/www/docs/api/reference.html
|
||||
share/couchdb/www/docs/changelog.html
|
||||
share/couchdb/www/docs/changes.html
|
||||
share/couchdb/www/docs/commonjs.html
|
||||
share/couchdb/www/docs/config_reference.html
|
||||
share/couchdb/www/docs/configuring.html
|
||||
share/couchdb/www/docs/cors.html
|
||||
share/couchdb/www/docs/ddocs.html
|
||||
share/couchdb/www/docs/errors.html
|
||||
share/couchdb/www/docs/genindex.html
|
||||
share/couchdb/www/docs/http-proxying.html
|
||||
share/couchdb/www/docs/index.html
|
||||
share/couchdb/www/docs/intro.html
|
||||
share/couchdb/www/docs/json-structure.html
|
||||
share/couchdb/www/docs/objects.inv
|
||||
share/couchdb/www/docs/os-daemons.html
|
||||
share/couchdb/www/docs/pretty_urls.html
|
||||
share/couchdb/www/docs/query-servers.html
|
||||
share/couchdb/www/docs/range.html
|
||||
share/couchdb/www/docs/release.html
|
||||
share/couchdb/www/docs/replication.html
|
||||
share/couchdb/www/docs/search.html
|
||||
share/couchdb/www/docs/searchindex.js
|
||||
share/couchdb/www/docs/ssl.html
|
||||
share/couchdb/www/document.html
|
||||
share/couchdb/www/favicon.ico
|
||||
share/couchdb/www/image/add.png
|
||||
|
@ -317,6 +413,7 @@ share/couchdb/www/verify_install.html
|
|||
share/doc/couchdb/AUTHORS.gz
|
||||
share/doc/couchdb/BUGS.gz
|
||||
share/doc/couchdb/CHANGES.gz
|
||||
share/doc/couchdb/CouchDB.pdf.gz
|
||||
share/doc/couchdb/DEVELOPERS.gz
|
||||
share/doc/couchdb/INSTALL.Unix.gz
|
||||
share/doc/couchdb/INSTALL.Windows.gz
|
||||
|
@ -328,5 +425,7 @@ share/doc/couchdb/README.gz
|
|||
share/doc/couchdb/THANKS.gz
|
||||
share/examples/couchdb/default.ini
|
||||
share/examples/couchdb/local.ini
|
||||
share/info/CouchDB
|
||||
share/info/dir
|
||||
@pkgdir share/examples/couchdb/local.d
|
||||
@pkgdir share/examples/couchdb/default.d
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.5 2013/03/04 14:12:40 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.6 2013/04/24 12:22:37 jperkin Exp $
|
||||
|
||||
SHA1 (apache-couchdb-1.2.1.tar.gz) = 70dac0304cdc9f4313f524db583170a2c59e265c
|
||||
RMD160 (apache-couchdb-1.2.1.tar.gz) = b89604089565c1f909046329c7e9d5faf84f036f
|
||||
Size (apache-couchdb-1.2.1.tar.gz) = 1372433 bytes
|
||||
SHA1 (patch-aa) = 73d09a34292bfa813c2396e7db98890b7ff3ccad
|
||||
SHA1 (patch-ab) = 9175abe3746859b16430ce2e41415addde05aabc
|
||||
SHA1 (apache-couchdb-1.3.0.tar.gz) = 1085297fcabb020f407283aba1f74302c9923fa0
|
||||
RMD160 (apache-couchdb-1.3.0.tar.gz) = 0803f388673c181eff6ee287a76203a780c0ce8b
|
||||
Size (apache-couchdb-1.3.0.tar.gz) = 3420515 bytes
|
||||
SHA1 (patch-aa) = 9b3666dd90392304f43cbf6b42a1476d7956871c
|
||||
SHA1 (patch-ab) = f07acca555013b1bfde95bdd056cccd9a551440a
|
||||
SHA1 (patch-ac) = b5dd1be18110655b1494278b168cf1971e1ca872
|
||||
SHA1 (patch-ad) = 20fcfab5fe067d57703d2cc80e308b112ce60826
|
||||
SHA1 (patch-ae) = a760518711e7f013de91a478fc2353183aa5ac5e
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-aa,v 1.4 2013/03/04 14:12:40 fhajny Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2013/04/24 12:22:38 jperkin Exp $
|
||||
|
||||
Set pkgsrc standard paths.
|
||||
|
||||
--- configure.orig 2012-12-20 21:28:51.000000000 +0000
|
||||
+++ configure 2013-03-04 13:05:12.523266279 +0000
|
||||
@@ -757,6 +757,7 @@ localstatelogdir
|
||||
--- configure.orig 2013-03-30 14:46:50.000000000 +0000
|
||||
+++ configure
|
||||
@@ -646,6 +646,7 @@ localstatelogdir
|
||||
localstatelibdir
|
||||
locallibdir
|
||||
localdocdir
|
||||
|
@ -12,7 +12,34 @@ Set pkgsrc standard paths.
|
|||
localdatadir
|
||||
localconfdir
|
||||
bug_uri
|
||||
@@ -18159,13 +18160,15 @@ localdatadir=${datadir}/${package_identi
|
||||
@@ -18288,7 +18289,7 @@ fi
|
||||
done
|
||||
test -n "$CURL_CONFIG" || CURL_CONFIG="no"
|
||||
|
||||
- if test "$CURL_CONFIG" == "no"; then :
|
||||
+ if test "$CURL_CONFIG" = "no"; then :
|
||||
|
||||
:
|
||||
|
||||
@@ -18300,7 +18301,7 @@ $as_echo "$as_me: WARNING: You will be u
|
||||
|
||||
else
|
||||
|
||||
- if test x"" == x; then :
|
||||
+ if test x"" = x; then :
|
||||
|
||||
CURL_CFLAGS="`$CURL_CONFIG $curl_config_args --cflags`"
|
||||
|
||||
@@ -18310,7 +18311,7 @@ else
|
||||
|
||||
fi
|
||||
|
||||
- if test x"" == x; then :
|
||||
+ if test x"" = x; then :
|
||||
|
||||
CURL_LIBS="`$CURL_CONFIG $curl_config_args --libs`"
|
||||
|
||||
@@ -19116,13 +19117,15 @@ localdatadir=${datadir}/${package_identi
|
||||
|
||||
localdocdir=${datadir}/doc/${package_identifier}
|
||||
|
||||
|
@ -30,7 +57,7 @@ Set pkgsrc standard paths.
|
|||
|
||||
|
||||
# On Windows we install directly into our erlang distribution.
|
||||
@@ -18175,9 +18178,9 @@ if test x${IS_WINDOWS} = xTRUE; then
|
||||
@@ -19132,9 +19135,9 @@ if test x${IS_WINDOWS} = xTRUE; then
|
||||
localerlanglibdir=${libdir}
|
||||
|
||||
else
|
||||
|
|
|
@ -1,19 +1,19 @@
|
|||
$NetBSD: patch-ab,v 1.3 2013/03/04 14:12:40 fhajny Exp $
|
||||
$NetBSD: patch-ab,v 1.4 2013/04/24 12:22:38 jperkin Exp $
|
||||
|
||||
Install into examples, not sysconfdir.
|
||||
|
||||
--- etc/couchdb/Makefile.in.orig 2012-12-20 21:28:48.000000000 +0000
|
||||
+++ etc/couchdb/Makefile.in 2013-03-04 13:08:45.587487445 +0000
|
||||
@@ -73,7 +73,7 @@ am__nobase_list = $(am__nobase_strip_set
|
||||
am__base_list = \
|
||||
sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
|
||||
sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
|
||||
--- etc/couchdb/Makefile.in.orig 2013-03-30 14:46:47.000000000 +0000
|
||||
+++ etc/couchdb/Makefile.in
|
||||
@@ -99,7 +99,7 @@ am__uninstall_files_from_dir = { \
|
||||
|| { echo " ( cd '$$dir' && rm -f" $$files ")"; \
|
||||
$(am__cd) "$$dir" && rm -f $$files; }; \
|
||||
}
|
||||
-am__installdirs = "$(DESTDIR)$(localconfdir)"
|
||||
+am__installdirs = "$(DESTDIR)$(localegdir)"
|
||||
DATA = $(localconf_DATA) $(noinst_DATA)
|
||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||
transform = @program_transform_name@
|
||||
@@ -211,6 +211,7 @@ launchddir = @launchddir@
|
||||
@@ -240,6 +240,7 @@ launchddir = @launchddir@
|
||||
libdir = @libdir@
|
||||
libexecdir = @libexecdir@
|
||||
localconfdir = @localconfdir@
|
||||
|
@ -21,13 +21,18 @@ Install into examples, not sysconfdir.
|
|||
localdatadir = @localdatadir@
|
||||
localdocdir = @localdocdir@
|
||||
localedir = @localedir@
|
||||
@@ -303,24 +304,24 @@ clean-libtool:
|
||||
@@ -331,25 +332,25 @@ clean-libtool:
|
||||
-rm -rf .libs _libs
|
||||
install-localconfDATA: $(localconf_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(localconfdir)" || $(MKDIR_P) "$(DESTDIR)$(localconfdir)"
|
||||
+ test -z "$(localegdir)" || $(MKDIR_P) "$(DESTDIR)$(localegdir)"
|
||||
@list='$(localconf_DATA)'; test -n "$(localconfdir)" || list=; \
|
||||
- @list='$(localconf_DATA)'; test -n "$(localconfdir)" || list=; \
|
||||
+ @list='$(localconf_DATA)'; test -n "$(localegdir)" || list=; \
|
||||
if test -n "$$list"; then \
|
||||
- echo " $(MKDIR_P) '$(DESTDIR)$(localconfdir)'"; \
|
||||
- $(MKDIR_P) "$(DESTDIR)$(localconfdir)" || exit 1; \
|
||||
+ echo " $(MKDIR_P) '$(DESTDIR)$(localegdir)'"; \
|
||||
+ $(MKDIR_P) "$(DESTDIR)$(localegdir)" || exit 1; \
|
||||
fi; \
|
||||
for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
echo "$$d$$p"; \
|
||||
|
@ -44,15 +49,12 @@ Install into examples, not sysconfdir.
|
|||
- @list='$(localconf_DATA)'; test -n "$(localconfdir)" || list=; \
|
||||
+ @list='$(localconf_DATA)'; test -n "$(localegdir)" || list=; \
|
||||
files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
|
||||
test -n "$$files" || exit 0; \
|
||||
- echo " ( cd '$(DESTDIR)$(localconfdir)' && rm -f" $$files ")"; \
|
||||
- cd "$(DESTDIR)$(localconfdir)" && rm -f $$files
|
||||
+ echo " ( cd '$(DESTDIR)$(localegdir)' && rm -f" $$files ")"; \
|
||||
+ cd "$(DESTDIR)$(localegdir)" && rm -f $$files
|
||||
- dir='$(DESTDIR)$(localconfdir)'; $(am__uninstall_files_from_dir)
|
||||
+ dir='$(DESTDIR)$(localegdir)'; $(am__uninstall_files_from_dir)
|
||||
tags: TAGS
|
||||
TAGS:
|
||||
|
||||
@@ -362,7 +363,7 @@ check-am: all-am
|
||||
@@ -391,7 +392,7 @@ check-am: all-am
|
||||
check: check-am
|
||||
all-am: Makefile $(DATA)
|
||||
installdirs:
|
||||
|
@ -61,7 +63,7 @@ Install into examples, not sysconfdir.
|
|||
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
||||
done
|
||||
install: install-am
|
||||
@@ -517,20 +518,20 @@ local_dev.ini: local.ini
|
||||
@@ -558,20 +559,20 @@ local_dev.ini: local.ini
|
||||
fi
|
||||
|
||||
install-data-hook:
|
||||
|
|
Loading…
Reference in a new issue