Update rake to 0.8.4.
Changes: === New Features / Enhancements in Version 0.8.4 * Case is preserved on rakefile names. (patch from James M. Lawrence/quix) * Improved Rakefile case insensitivity testing (patch from Luis Lavena). * Windows system dir search order is now: HOME, HOMEDRIVE + HOMEPATH, APPDATA, USERPROFILE (patch from Luis Lavena) * MingGW is now recognized as a windows platform. (patch from Luis Lavena) === Bug Fixes in Version 0.8.4 * Removed reference to manage_gem to fix the warning produced by the gem package task. * Fixed stray ARGV option problem that was interfering with Test::Unit::Runner. (patch from Pivotal Labs) === Infrastructure Improvements in Version 0.8.4 * Numerous fixes to the windows test suite (patch from Luis Lavena). * Improved Rakefile case insensitivity testing (patch from Luis Lavena). * Better support for windows paths in the test task (patch from Simon Chiang/bahuvrihi)
This commit is contained in:
parent
ff41e1483c
commit
8aacaaea43
4 changed files with 17 additions and 13 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.11 2008/10/30 02:44:22 minskim Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2009/03/04 17:39:22 minskim Exp $
|
||||
|
||||
DISTNAME= rake-0.8.3
|
||||
DISTNAME= rake-0.8.4
|
||||
CATEGORIES= devel
|
||||
|
||||
MAINTAINER= minskim@NetBSD.org
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.9 2008/10/30 02:44:22 minskim Exp $
|
||||
@comment $NetBSD: PLIST,v 1.10 2009/03/04 17:39:22 minskim Exp $
|
||||
bin/rake
|
||||
${GEM_HOME}/cache/rake-${PKGVERSION}.gem
|
||||
${GEM_LIBDIR}/CHANGES
|
||||
|
@ -7,6 +7,7 @@ ${GEM_LIBDIR}/README
|
|||
${GEM_LIBDIR}/Rakefile
|
||||
${GEM_LIBDIR}/TODO
|
||||
${GEM_LIBDIR}/bin/rake
|
||||
${GEM_LIBDIR}/doc/command_line_usage.rdoc
|
||||
${GEM_LIBDIR}/doc/example/Rakefile1
|
||||
${GEM_LIBDIR}/doc/example/Rakefile2
|
||||
${GEM_LIBDIR}/doc/example/a.c
|
||||
|
@ -31,6 +32,7 @@ ${GEM_LIBDIR}/doc/release_notes/rake-0.7.3.rdoc
|
|||
${GEM_LIBDIR}/doc/release_notes/rake-0.8.0.rdoc
|
||||
${GEM_LIBDIR}/doc/release_notes/rake-0.8.2.rdoc
|
||||
${GEM_LIBDIR}/doc/release_notes/rake-0.8.3.rdoc
|
||||
${GEM_LIBDIR}/doc/release_notes/rake-0.8.4.rdoc
|
||||
${GEM_LIBDIR}/install.rb
|
||||
${GEM_LIBDIR}/lib/rake.rb
|
||||
${GEM_LIBDIR}/lib/rake/classic_namespace.rb
|
||||
|
@ -46,6 +48,7 @@ ${GEM_LIBDIR}/lib/rake/loaders/makefile.rb
|
|||
${GEM_LIBDIR}/lib/rake/packagetask.rb
|
||||
${GEM_LIBDIR}/lib/rake/rake_test_loader.rb
|
||||
${GEM_LIBDIR}/lib/rake/rdoctask.rb
|
||||
${GEM_LIBDIR}/lib/rake/repaired_system.rb
|
||||
${GEM_LIBDIR}/lib/rake/ruby182_test_unit_fix.rb
|
||||
${GEM_LIBDIR}/lib/rake/runtest.rb
|
||||
${GEM_LIBDIR}/lib/rake/tasklib.rb
|
||||
|
@ -92,6 +95,7 @@ ${GEM_LIBDIR}/test/test_namespace.rb
|
|||
${GEM_LIBDIR}/test/test_package_task.rb
|
||||
${GEM_LIBDIR}/test/test_pathmap.rb
|
||||
${GEM_LIBDIR}/test/test_rake.rb
|
||||
${GEM_LIBDIR}/test/test_rdoc_task.rb
|
||||
${GEM_LIBDIR}/test/test_require.rb
|
||||
${GEM_LIBDIR}/test/test_rules.rb
|
||||
${GEM_LIBDIR}/test/test_task_arguments.rb
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.10 2008/10/30 02:44:22 minskim Exp $
|
||||
$NetBSD: distinfo,v 1.11 2009/03/04 17:39:22 minskim Exp $
|
||||
|
||||
SHA1 (rake-0.8.3.gem) = fc3060c6c3ea3b804ef95576e41706b92fd51243
|
||||
RMD160 (rake-0.8.3.gem) = 8a81f35787c814b427177b88c07f6d2410b799a9
|
||||
Size (rake-0.8.3.gem) = 100352 bytes
|
||||
SHA1 (patch-ab) = 21701d38f5026e8fb0a9d5102a6de4bedaa191c3
|
||||
SHA1 (rake-0.8.4.gem) = 3d0d287df69b38e4ba1efd567669df1d27809691
|
||||
RMD160 (rake-0.8.4.gem) = 30e20fce53051afe2e7b5f03018b65a8ea8af9ab
|
||||
Size (rake-0.8.4.gem) = 103936 bytes
|
||||
SHA1 (patch-ab) = 76dff28958394720ae5af267798423dbe0323d66
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
$NetBSD: patch-ab,v 1.2 2008/10/30 02:44:23 minskim Exp $
|
||||
$NetBSD: patch-ab,v 1.3 2009/03/04 17:39:22 minskim Exp $
|
||||
|
||||
--- ../rake-0.8.3.gemspec.orig 2008-09-14 21:30:11.000000000 -0700
|
||||
+++ ../rake-0.8.3.gemspec
|
||||
@@ -115,7 +115,6 @@ files:
|
||||
--- ../rake-0.8.4.gemspec.orig 2009-03-04 09:34:56.000000000 -0800
|
||||
+++ ../rake-0.8.4.gemspec
|
||||
@@ -122,7 +122,6 @@ files:
|
||||
- test/data/namespace/Rakefile
|
||||
- test/data/statusreturn/Rakefile
|
||||
- test/data/unittest/Rakefile
|
||||
-- test/data/unittest/subdir
|
||||
- doc/command_line_usage.rdoc
|
||||
- doc/example
|
||||
- doc/example/a.c
|
||||
- doc/example/b.c
|
||||
|
|
Loading…
Reference in a new issue