Update to rep-gtk2-0.18.4.

0.18.4:
- small code cleanup
- reworked configure.in
- added ebuild (Thanks to Harald van Dijk)
- reworked autogen.sh
- removed libgnome, libgnomeui, libgnomecanvas and libglade bindings
- removed examples related to removed bindings
- reworked ebuild and specfile
- install rep-gtk.in in $prefix$libdir
- major update of the spec-file
- don't install example files

0.18.3:
- fixed the broken GtkCombo() Widgets
- fixed an issue with autoconf on RedHat

0.18.2:
- fixups in configure.in
- updated BUGS, README and HACKING
- removed functions no longer available in GTK 2.4+
- spec-file does now install all examples into the doc-dir

0.18.1:
- started code-cleanup
- added a .pc file
- added ATK-Accessibility Support (Thanks to Shobbit Marthur)
- added Status-Icon Widget (Thanks to Wang Diancheng)
- bumped gtk req to 2.6, glib req to 2.6 and glade req to 2.4
- dropped an function no longer available in GTK 2.5+
- added --tag=CC to libtool where nessacary
- renamed some of the Makefile targets (cvsclean -> svnclean a.s.o)
- updated the spec file
- ported the example glade files to glade2
This commit is contained in:
tnn 2009-04-16 18:14:25 +00:00
parent a326a154be
commit 8adc028248
5 changed files with 11 additions and 52 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.4 2008/06/20 01:09:45 joerg Exp $
# $NetBSD: Makefile,v 1.5 2009/04/16 18:14:25 tnn Exp $
DISTNAME= rep-gtk-0.18
PKGNAME= rep-gtk2-0.18
PKGREVISION= 1
DISTNAME= rep-gtk-0.18.4
PKGNAME= rep-gtk2-0.18.4
CATEGORIES= x11 lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=rep-gtk/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= tnn@NetBSD.org
HOMEPAGE= http://rep-gtk.sourceforge.net/
@ -17,8 +17,8 @@ CONFLICTS= rep-gtk-[0-9]*
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
USE_TOOLS+= gmake pkg-config
PKGCONFIG_OVERRIDE= rep-gtk.pc-in
.include "../../devel/libglade/buildlink3.mk"
.include "../../lang/librep/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +1,6 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2007/05/09 10:01:28 tnn Exp $
@comment $NetBSD: PLIST,v 1.2 2009/04/16 18:14:25 tnn Exp $
lib/pkgconfig/rep-gtk.pc
libexec/rep/${MACHINE_GNU_PLATFORM}/gui/gtk-2/gtk.la
libexec/rep/${MACHINE_GNU_PLATFORM}/gui/gtk-2/libglade.la
libexec/rep/${MACHINE_GNU_PLATFORM}/gui/gtk-2/types.la
@dirrm libexec/rep/${MACHINE_GNU_PLATFORM}/gui/gtk-2
@dirrm libexec/rep/${MACHINE_GNU_PLATFORM}/gui

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2007/05/09 10:01:28 tnn Exp $
$NetBSD: distinfo,v 1.2 2009/04/16 18:14:25 tnn Exp $
SHA1 (rep-gtk-0.18.tar.gz) = 9410c348bd0736a86063c6b0a46c2d7f9b0a8f4a
RMD160 (rep-gtk-0.18.tar.gz) = b6bd4210a26b2464b73295fb7009e7a75b5c1c8b
Size (rep-gtk-0.18.tar.gz) = 147665 bytes
SHA1 (patch-aa) = 48f44d05447b4a7934ff13a8b1c805f183abf274
SHA1 (patch-ab) = cc831a1393bc95b3cdeb261d5063650866d7a4cc
SHA1 (rep-gtk-0.18.4.tar.bz2) = 83ff2d64dd0918427af2d5f8c3eb12bded15587e
RMD160 (rep-gtk-0.18.4.tar.bz2) = 9f459980b5a736385d56628a8a7da0c07b3590fc
Size (rep-gtk-0.18.4.tar.bz2) = 252732 bytes

View file

@ -1,17 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2007/05/09 10:01:28 tnn Exp $
--- rep-gtk.h.orig 2004-09-02 19:40:23.000000000 +0200
+++ rep-gtk.h
@@ -291,10 +291,10 @@ void gtk_menu_popup_interp (GtkMenu *men
GtkWidget*
gtk_radio_menu_item_new_with_label_from_widget (GtkRadioMenuItem *group,
- gchar *label);
+ const gchar *label);
GtkWidget*
gtk_radio_menu_item_new_with_mnemonic_from_widget (GtkRadioMenuItem *group,
- gchar *label);
+ const gchar *label);
GtkWidget* gtk_radio_menu_item_new_from_widget (GtkRadioMenuItem *group);
GtkWidget* gtk_pixmap_new_interp (char *file, GtkWidget *intended_parent);

View file

@ -1,22 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2007/05/09 10:01:28 tnn Exp $
--- gtk-compat.c.orig 2004-09-02 19:43:49.000000000 +0200
+++ gtk-compat.c
@@ -64,7 +64,7 @@ gtk_menu_popup_interp (GtkMenu *menu,
GtkWidget*
gtk_radio_menu_item_new_with_label_from_widget (GtkRadioMenuItem *group,
- gchar *label)
+ const gchar *label)
{
GSList *g = group? gtk_radio_menu_item_group (group) : NULL;
return gtk_radio_menu_item_new_with_label (g, label);
@@ -72,7 +72,7 @@ gtk_radio_menu_item_new_with_label_from_
GtkWidget*
gtk_radio_menu_item_new_with_mnemonic_from_widget (GtkRadioMenuItem *group,
- gchar *label)
+ const gchar *label)
{
GSList *g = group? gtk_radio_menu_item_group (group) : NULL;
return gtk_radio_menu_item_new_with_mnemonic (g, label);