Don't break <atomic> with silly flags.

This commit is contained in:
joerg 2017-02-07 23:54:08 +00:00
parent 0266d441ab
commit 8ae17704f1
2 changed files with 17 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1 2016/11/21 18:20:30 minskim Exp $
$NetBSD: distinfo,v 1.2 2017/02/07 23:54:08 joerg Exp $
SHA1 (benchmark-1.1.0.tar.gz) = 8c539bbe2a212618fa87b6c38fba087100b6e4ae
RMD160 (benchmark-1.1.0.tar.gz) = 7e7f2d687ef515a846c04933545f7c63752d2de5
SHA512 (benchmark-1.1.0.tar.gz) = 533061531e6a37723a626addc9e779018c4c2cfc8634ae45860eec0d3800103b5b562f865ac1dc0c8dbe045579b81e59de887e1c48318cebf160f03c18321831
Size (benchmark-1.1.0.tar.gz) = 87199 bytes
SHA1 (patch-CMakeLists.txt) = b76675097fde2b85fc3c7e9601666007654c1d0c

View file

@ -0,0 +1,15 @@
$NetBSD: patch-CMakeLists.txt,v 1.1 2017/02/07 23:54:08 joerg Exp $
-pedantic breaks <atomic> with libc++.
--- CMakeLists.txt.orig 2017-01-08 19:22:40.698979204 +0000
+++ CMakeLists.txt
@@ -75,8 +75,6 @@ else()
add_cxx_compiler_flag(-Werror RELEASE)
add_cxx_compiler_flag(-Werror RELWITHDEBINFO)
add_cxx_compiler_flag(-Werror MINSIZEREL)
- add_cxx_compiler_flag(-pedantic)
- add_cxx_compiler_flag(-pedantic-errors)
add_cxx_compiler_flag(-Wshorten-64-to-32)
add_cxx_compiler_flag(-Wfloat-equal)
add_cxx_compiler_flag(-fstrict-aliasing)