Update devel/exctags to 5.8
Changes: ctags-5.8 (09 Jul 2009) * Removed ".ml" as a Lisp extension (now OCaml) [Lisp]. * Added support for Ant language, contributed by David Fishburn. * Added support for DOS Batch language, contributed by David Fishburn. * Added support for Flex (Adobe) language, contributed by David Fishburn. * Added support for MATLAB language, contributed by David Fishburn. * Added support for Objective Camel (OCaml), provided by Vincent Berthoux [Patch #2738723]. * Added support for TeX language, contributed by David Fishburn. * Added support for VHDL language, contributed by Nicolas Vincent [Bug #1943306]. * Added support for Pyrex/Cython declarations [Python]. * Added support for "v" kind, for variables [Python]. * Added support for class and member variables [PHP, Bug #1037086]. * Added support for recent enhancements to Eiffel language [Eiffel]. * Added support for ASP classes, contributed by Zendhi Nagao; changes meaning of 'c' kind flag [ASP]. * Added regex support when compiling with MinGW. Gnu regex module now included in all distributions. * Fixed detection of triple strings inside other strings [Python, Bug #1988130]. * Fixed an endless loop with comments in triple strings [Python, Bug #1988027]. * Fixed bug where functions were sometimes seen as methods [Python, Bug #1988026]. * Fixed parsing of method parameter annotations, fix contributed by Paolo "blaisorblade" Giarrusso [Java, Bug #2049723, #2117073]. * Fixed parsing of global scope qualifiers in base class lists [C++, Bug #1799343]. * Fixed bug where namespace members were given kinds corresponding to globals [C++, Bug #1924919, #1575055]. * Fixed parsing of "else" [C#, Bug #1830344]. * Fixed parsing of derived enums [C#, Bug #1515910]. * Fixed parsing of "foreach" [C#, Bug #1830343]. * Fixed parsing of simple generic classes [C#, Bug #1515910]. * Fixed bug with detecting identifiers inside variables [Python, Bug #1809024]. * Fixed bug with detecting identifiers at the start of variables [Python, Bug #1856363]. * Fixed parsing of triple single-quoted multi-line strings [Python, Bug #1906062]. * Changed to newer version of autoconf, changing configure.in to configure.ac.
This commit is contained in:
parent
88ce232852
commit
8b724b957e
3 changed files with 20 additions and 6 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.20 2009/02/07 23:54:39 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.21 2010/01/22 22:30:05 tonio Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ctags-5.7
|
||||
DISTNAME= ctags-5.8
|
||||
PKGNAME= ex${DISTNAME}
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ctags/}
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.10 2007/11/19 06:42:21 adrianp Exp $
|
||||
$NetBSD: distinfo,v 1.11 2010/01/22 22:30:05 tonio Exp $
|
||||
|
||||
SHA1 (ctags-5.7.tar.gz) = f7e435286c25181d6cb28ca1ac2d4ba63507a82d
|
||||
RMD160 (ctags-5.7.tar.gz) = 8d6d9c0a3e056abfb6356852808afe1c99f9224c
|
||||
Size (ctags-5.7.tar.gz) = 287496 bytes
|
||||
SHA1 (ctags-5.8.tar.gz) = 482da1ecd182ab39bbdc09f2f02c9fba8cd20030
|
||||
RMD160 (ctags-5.8.tar.gz) = 191495869fbfa2f77a9619a4920eba26d02eface
|
||||
Size (ctags-5.8.tar.gz) = 479927 bytes
|
||||
SHA1 (patch-aa) = 5c8fd497146cf49925210d551072e230b3b06a74
|
||||
SHA1 (patch-ab) = 5659b06f692cc210af42e4cf73d8598cedb12086
|
||||
|
|
13
devel/exctags/patches/patch-ab
Normal file
13
devel/exctags/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.8 2010/01/22 22:30:05 tonio Exp $
|
||||
|
||||
--- python.c.orig 2009-07-07 03:55:23.000000000 +0000
|
||||
+++ python.c
|
||||
@@ -135,7 +135,7 @@ static boolean isIdentifierCharacter (in
|
||||
* extract all relevant information and create a tag.
|
||||
*/
|
||||
static void makeFunctionTag (vString *const function,
|
||||
- vString *const parent, int is_class_parent, const char *arglist __unused__)
|
||||
+ vString *const parent, int is_class_parent, const char *arglist __unused_)
|
||||
{
|
||||
tagEntryInfo tag;
|
||||
initTagEntry (&tag, vStringValue (function));
|
Loading…
Reference in a new issue