Fix build on NetBSD < 4.0.

This commit is contained in:
ghen 2008-01-07 21:09:05 +00:00
parent 6334b22573
commit 8b93918fe5
2 changed files with 6 additions and 6 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.18 2008/01/05 22:15:24 wiz Exp $
$NetBSD: distinfo,v 1.19 2008/01/07 21:09:05 ghen Exp $
SHA1 (qt-x11-opensource-src-4.3.3.tar.gz) = 77d00e2438efa793f6c16c54b64c8ba440ee3228
RMD160 (qt-x11-opensource-src-4.3.3.tar.gz) = 410daca03b6802ba5cc6662219c2ba7a190bd292
@ -16,6 +16,6 @@ SHA1 (patch-aj) = e9ca9544f929bb4adf3ccb0ca2cad9352124289d
SHA1 (patch-ak) = bd5d0f766a6ddcd801b94b4387d19b62edc8e4e1
SHA1 (patch-al) = 606610ee684836d14e5893d295c0b131beeb9605
SHA1 (patch-am) = 0d4a4f2767cad5414c8bfe4dc8485064a9be4381
SHA1 (patch-an) = 338d0cf6cdf38689c9f3770222802206dd8035a3
SHA1 (patch-an) = 6c9044134516d089e97b47a2750beab0e4c4952f
SHA1 (patch-ao) = 04361d820325b1b8a0bc66ecaf47bab5f92e7825
SHA1 (patch-ap) = 99402ac9ef527e7fa9b1825c8e1b8a299bc4ffe7

View file

@ -1,13 +1,13 @@
$NetBSD: patch-an,v 1.2 2007/10/13 12:02:15 adam Exp $
$NetBSD: patch-an,v 1.3 2008/01/07 21:09:05 ghen Exp $
--- src/script/qscriptlexer.cpp.orig 2007-10-01 15:06:09.000000000 +0200
--- src/script/qscriptlexer.cpp.orig 2007-12-04 17:43:06.000000000 +0100
+++ src/script/qscriptlexer.cpp
@@ -706,7 +706,7 @@ int QScript::Lexer::lex()
@@ -704,7 +704,7 @@ int QScript::Lexer::lex()
double dval = 0;
if (state == Number) {
-#if defined(Q_WS_WIN) || defined(Q_OS_SOLARIS) || defined(Q_OS_IRIX) || defined(Q_CC_HPACC) || defined(Q_OS_AIX) || defined(Q_OS_OPENBSD)
+#if defined(Q_WS_WIN) || defined(Q_OS_SOLARIS) || defined(Q_OS_IRIX) || defined(Q_CC_HPACC) || defined(Q_OS_AIX) || defined(Q_OS_OPENBSD) || defined(__DragonFly__)
+#if defined(Q_WS_WIN) || defined(Q_OS_SOLARIS) || defined(Q_OS_IRIX) || defined(Q_CC_HPACC) || defined(Q_OS_AIX) || defined(Q_OS_OPENBSD) || defined(__DragonFly__) || ( defined(Q_OS_NETBSD) && (__NetBSD_Version__ < 400000000) )
// ### This may cause autotest failure, but that's just plain weird...
dval = strtod(buffer8, 0L);
#else