Updte from version 0.12 to 0.13.

Pkgsrc changes:
 o Fix the problem with the sqlite3-using regression test properly;
   apparently sqlite3 thinks it's an error to drop a nonexistent table.
   This is a follow-up on CPAN ticket #41769.
 o Adapt substitution pattern for sqlite3 after upstream change.
 o Add dependency on p5-IPC-Cmd, as per upstream change.

Upstream changes:

0.13    16 Dec 2008
        * fixes for Perl 5.10 File::Copy
        * use IPC::Cmd::run to create db in t/lib/MyDB.pm
This commit is contained in:
he 2008-12-20 16:12:47 +00:00
parent d62bb24765
commit 8bff092680
4 changed files with 93 additions and 21 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.3 2008/12/17 01:45:44 he Exp $
# $NetBSD: Makefile,v 1.4 2008/12/20 16:12:47 he Exp $
DISTNAME= Rose-DBx-Garden-Catalyst-0.12
DISTNAME= Rose-DBx-Garden-Catalyst-0.13
PKGNAME= p5-${DISTNAME}
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Rose/}
@ -35,12 +35,13 @@ DEPENDS+= p5-Scalar-List-Utils>=0:../../devel/p5-Scalar-List-Utils
# For tests:
BUILD_DEPENDS+= sqlite3>=0:../../databases/sqlite3
BUILD_DEPENDS+= p5-IPC-Cmd>=0:../../devel/p5-IPC-Cmd
SUBST_CLASSES+= sqlite3
SUBST_MESSAGE.sqlite3= Fixing sqlite3-using test
SUBST_STAGE.sqlite3= post-configure
SUBST_FILES.sqlite3= t/lib/MyDB.pm
SUBST_SED.sqlite3= -e "s!system(\"sqlite3!system(\"${PREFIX}/bin/sqlite3!"
SUBST_SED.sqlite3= -e "s!\"sqlite3!\"${PREFIX}/bin/sqlite3!"
USE_LANGUAGES= # empty
PERL5_PACKLIST= auto/Rose/DBx/Garden/Catalyst/.packlist

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2008/12/17 01:45:44 he Exp $
$NetBSD: distinfo,v 1.3 2008/12/20 16:12:47 he Exp $
SHA1 (Rose-DBx-Garden-Catalyst-0.12.tar.gz) = 4ff1bfd5402a8e60ff11e68f2fdc6d2ff50ccbe7
RMD160 (Rose-DBx-Garden-Catalyst-0.12.tar.gz) = 792034129df64b843f6714737919cf753e240c7b
Size (Rose-DBx-Garden-Catalyst-0.12.tar.gz) = 18133 bytes
SHA1 (patch-aa) = 9e7581161ce7cc3dcfcbda89fb60a61f33609fc9
SHA1 (Rose-DBx-Garden-Catalyst-0.13.tar.gz) = 910fae07b1e0e863b2b62c9ac4e0ced839449d61
RMD160 (Rose-DBx-Garden-Catalyst-0.13.tar.gz) = 0021f630afb31ce7046b9d75dbff6045319f1ef7
Size (Rose-DBx-Garden-Catalyst-0.13.tar.gz) = 17963 bytes
SHA1 (patch-ab) = 37c404a2d6674beebb86747c8bb243d09fe3ca74

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.1 2008/12/17 01:45:44 he Exp $
--- t/lib/MyDB.pm.orig 2008-12-17 02:30:18.000000000 +0100
+++ t/lib/MyDB.pm
@@ -27,7 +27,7 @@ $db = Path::Class::File->new( $base_pat
# create the db if it does not yet exist
if ( !-s $db ) {
- system("sqlite3 $db < $sql") and die "can't create $db with $sql: $!";
+ system("sqlite3 $db < $sql") or die "can't create $db with $sql: $!";
}
if ( !$db or !-s $db ) {

View file

@ -0,0 +1,84 @@
$NetBSD: patch-ab,v 1.1 2008/12/20 16:12:47 he Exp $
--- t/rdgc.sql.orig 2008-09-14 07:03:34.000000000 +0200
+++ t/rdgc.sql
@@ -1,6 +1,6 @@
/* SQL supplied by laust_frederiksen@hotmail.com */
-drop table addresses;
+/* drop table addresses; */
create table addresses
(
id serial primary key,
@@ -10,7 +10,7 @@ create table addresses
name4 char(40)
);
-drop table suppliers;
+/* drop table suppliers; */
create table suppliers
(
id serial primary key,
@@ -21,7 +21,7 @@ create table suppliers
create unique index suppliers_name on suppliers(name);
-drop table manufacturers;
+/* drop table manufacturers; */
create table manufacturers
(
id serial primary key,
@@ -32,7 +32,7 @@ create table manufacturers
create unique index manufacturers_name on manufacturers(name);
-drop table products;
+/* drop table products; */
create table products
(
id serial primary key,
@@ -45,7 +45,7 @@ create table products
create unique index products_manufacturer_name on products(manufacturer,name);
-drop table locations;
+/* drop table locations; */
create table locations
(
id serial primary key,
@@ -56,7 +56,7 @@ create table locations
create unique index locations_name on locations(name);
-drop table stocks;
+/* drop table stocks; */
create table stocks
(
id serial primary key,
@@ -69,7 +69,7 @@ create table stocks
create unique index stocks_location_product on stocks(location,product);
-drop table customers;
+/* drop table customers; */
create table customers
(
id integer auto increment not null,
@@ -80,7 +80,7 @@ create table customers
create unique index customers_name on customers(name);
-drop table invoices;
+/* drop table invoices; */
create table invoices
(
id integer auto increment not null,
@@ -92,7 +92,7 @@ create table invoices
foreign key (address) references addresses (id)
);
-drop table lines;
+/* drop table lines; */
create table lines
(
id serial primary key,