don't use xcrun checking for xcrun on osx

command line tools don't install xcrun in the toolkit
so do a simple check for cc instead
This commit is contained in:
dbj 2016-03-14 06:12:17 +00:00
parent 70a786b76d
commit 8c0d15c1bf
2 changed files with 12 additions and 3 deletions

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.29 2016/03/02 23:04:00 ryoon Exp $
$NetBSD: distinfo,v 1.30 2016/03/14 06:12:17 dbj Exp $
SHA1 (qtbase-opensource-src-5.5.1.tar.xz) = 0b651543fa013ae151b7a11f0d0dee092050aa3f
RMD160 (qtbase-opensource-src-5.5.1.tar.xz) = ce4bccd0703aaf8d904fbecd1f334ef13d698a44
SHA512 (qtbase-opensource-src-5.5.1.tar.xz) = 4d31de136870025dfb7544f255798884af1ad4f3060b0c00a0467c98af1f7de368eb298d4c52ba6d1ad27e36060b30c0314ce7ba0744b15642420ec89587a575
Size (qtbase-opensource-src-5.5.1.tar.xz) = 46389212 bytes
SHA1 (patch-config.tests_unix_iconv_iconv.cpp) = 05131870b21ff778b1e6f3d1e7287060b6b88764
SHA1 (patch-configure) = ad30163463ccc9310e34633f13ca27bfccca59f4
SHA1 (patch-configure) = 482815b5f3ec25fabe0995cfc70acf164928d192
SHA1 (patch-mkspecs_features_create__cmake.prf) = 3f6b3a592e29f5529e5c87dbac036c165470eac4
SHA1 (patch-mkspecs_features_mac_objective__c.prf) = 20838861017d969fbcf171960dfc07db1bd5a177
SHA1 (patch-mkspecs_features_qt__module__pris.prf) = edaab0b9e407cc52f4682ce1cf8441832c57fe39

View file

@ -1,4 +1,4 @@
$NetBSD: patch-configure,v 1.3 2016/03/02 23:04:00 ryoon Exp $
$NetBSD: patch-configure,v 1.4 2016/03/14 06:12:17 dbj Exp $
* Don't use SDKs on OS X
* Add NetBSD/sparc{,64} support
@ -21,6 +21,15 @@ $NetBSD: patch-configure,v 1.3 2016/03/02 23:04:00 ryoon Exp $
fi
getSingleQMakeVariable "$1" "$xspecvals"
}
@@ -527,7 +525,7 @@ if [ "$BUILD_ON_MAC" = "yes" ]; then
exit 2
fi
- if ! /usr/bin/xcrun -find xcrun >/dev/null 2>&1; then
+ if ! /usr/bin/xcrun -find cc >/dev/null 2>&1; then
echo >&2
echo " Xcode not set up properly. You may need to confirm the license" >&2
echo " agreement by running /usr/bin/xcodebuild without arguments." >&2
@@ -2897,6 +2895,19 @@ if [ -z "$PLATFORM" ]; then
UNIX_SV:*)
PLATFORM=unixware-g++