Update pgpool to 3.4.1.

Patch provided by Wen Heping in PR 43628.

Changes:
        * Fix handling failover when health_check was disabled. (Yoshiyuki)
          - The bug was introduced in 3.4.
        * Fix deadlock while processing Parse message. (Yoshiyuki)
        * Add new "replicate_select" directive, being the default value to
          be false. (Yoshiyuki)
          - If it is true, SELECT query is replicated. This behavior is
            same as V3.2 or earlier.
        * Improve signal handling. (Yoshiyuki)
          - Occasionaly, zombie processes were remained. Or processes were
            unstable.
        * Fix hang up when SELECT was error inside a transaction
          block. The bug was introduced in V3.3. (Yoshiyuki)
        * Fix PREPARE/EXECUTE handling in master slave mode. (Yoshiyuki)
        * Fix "kind mismatch error" when deadlock error
        * Fix hang up and SEGV in extended query protocol when a warning
          SQL like "SELECT '\'';" executed. (Yoshiyuki)
        * Fix memory leak when connection cache was full. (Yoshiyuki)
        * Improve replication. SELECT nextval() and SELECT setval() are
          now replicated. (Yoshiyuki)
        * Change SELECT query is only sent to the master node. (Yoshiyuki)
          - Use /*REPLICATION*/ comment to repliate a SELECT query.
        * Fix unexpected failover error due to receiving an interrupt
          signal while connecting to the backend. (Yoshiyuki)
        * Fix "ps" output to follow PostgreSQL's output. (Taiki)
        * Change the default value for enable_pool_hba to true. (Taiki)
        * Add "pgpool.pam" file, for PAM configuration file, to be
          installed under "$PREFIX/share/". (Taiki)
        * Support HBA authentication(Taiki)
        * Support log_connections(Taiki)
        * Support log_hostname(Tatsuo)
        * Show pgpool status in ps command(Tatsuo)
        * Fix bug with prepared query(Yoshiyuki)
        * Detach secondary server when "kind mismatch error" is detected(Tatsuo)
        * Re-open socket if it was closed by backend while reusing
          connection(Yoshiyuki)
        * Allow 0 weight(Tatsuo)
        * Return correct error messaes when pg_hba.conf auth fails. Patch
          contributed by Kenji Kikuchi
        * Fix kind mismatch errors with COPY FROM STDIN(Yoshiyuki)
        * Allow load balancing with extended protocol(Yoshiyuki)
        * Fix LISTEN/NOTIFY bug in master/slave mode reported by Michael
          Ulitskiy (Tatsuo)
        * Improve documentation. patches contributed by Mark Stosberg
        * Fix "kind is 0!" error in Execute(). Reads messages until
          receiving CommandComplete, EmptyQuery, ErrorResponse or
          PortalSuspend in Execute() (Yoshiyuki)
        * Add log_statement option. patches contributed by Thomas E
          Lackey, modifications and documents by Tatsuo
        * In SimpleForwardToFrontend() do not send SYNC and wait for ready for
          query when PANIC or FATAL error occurs. In this case the backend
          closes the communication channel immediately which will cause unwanted
          failover/degeneration by, for example, trying to connect to
          invalid database (Tatsuo)
        * Fix dealock problem in extended modd by calling synchronize() in
          Execute if replication_strict is enabled (Yoshiyuki)
        * Fix segfault problem in race conditions among
          connection_life_time, child_life_time and child_max_connections
        * pgpool does not exit even if pgpool.conf contents is wrong(Tatsuo)
        * Fix buffer overrun bug with long health_check_user name(Taiki)
        * Fix occasional segfault with replication and load balance
          enabled(bug id #1000548)(Tatsuo)
        * Fix pool_send_error_message to send properly NULL terminated
          string(Yoshiyuki)
        * Fix kind mismatch error in SimpleFowardFrontend(Yoshiyuki)
        * Enable to build with BSD make(Yoshiyuki)
        * Fix pool_debug and friends to block signals while
          executing(Tatsuo)
        * Fix numerous bugs with extended query(Yoshiyuki)
        * Fix INSERT LOCK(Yoshiyuki)
        * Do not reuse startup packet(Tatsuo)
        * Automatically DEALLOCTE prepared queries when client
          disconnects(Yoshiyuki)
        * Do not forward packets when length = 0 in
          SimpleForwardToFrontend/SimpleForwardToBackend(Tatsuo)
        * Fix lost of kind info(Tatsuo)
        * Fix bugs with master/slave mode introduced in 2.7.2. per report
          from David Boreham (Tatsuo)
        * Fix bugs with master/slave and prepared quries. per report
          from David Boreham (Tatsuo)
        * Changed Copyright to PgPool Global Development Group
        * Fix a typo in man page
        * PQnotifes() does not receive immediate responses from LISTEN
        * NOTIFY emits packet kind does not agree errors in master/slave
          mode
        * add pgpool man pages(Peter Eisentra)
        * Fix bug in show pool_status for ignore_leading_white_space
This commit is contained in:
minskim 2011-04-05 17:47:17 +00:00
parent e7f1c9ba3f
commit 8c28aaba06
4 changed files with 27 additions and 19 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.9 2008/06/12 02:14:18 joerg Exp $
# $NetBSD: Makefile,v 1.10 2011/04/05 17:47:17 minskim Exp $
DISTNAME= pgpool-2.7
DISTNAME= pgpool-3.4.1
CATEGORIES= databases
MASTER_SITES= http://pgfoundry.org/frs/download.php/572/
MASTER_SITES= http://pgfoundry.org/frs/download.php/1446/
MAINTAINER= minskim@NetBSD.org
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://pgpool.projects.postgresql.org/
COMMENT= Connection pooling/replication server for PostgreSQL
@ -16,10 +16,15 @@ CONFIGURE_ARGS+=--sysconfdir=${PKG_SYSCONFDIR:Q}
INSTALLATION_DIRS= share/examples
CONF_FILES= ${PREFIX}/share/examples/pgpool.conf.sample \
CONF_FILES= ${PREFIX}/share/examples/pgpool.conf.sample \
${PKG_SYSCONFDIR}/pgpool.conf
CONF_FILES+= ${PREFIX}/share/examples/pool_hba.conf.sample \
${PKG_SYSCONFDIR}/pool_hba.conf
post-install:
${INSTALL_DATA} ${WRKSRC}/pgpool.conf.sample ${DESTDIR}${PREFIX}/share/examples
${INSTALL_DATA} ${WRKSRC}/pgpool.conf.sample \
${DESTDIR}${PREFIX}/share/examples
${INSTALL_DATA} ${WRKSRC}/pool_hba.conf.sample \
${DESTDIR}${PREFIX}/share/examples
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +1,6 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/02/11 16:40:43 minskim Exp $
@comment $NetBSD: PLIST,v 1.2 2011/04/05 17:47:17 minskim Exp $
bin/pgpool
man/man8/pgpool.8
share/examples/pgpool.conf.sample
share/examples/pool_hba.conf.sample
share/pgpool/pgpool.pam

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.4 2006/01/15 17:09:50 minskim Exp $
$NetBSD: distinfo,v 1.5 2011/04/05 17:47:17 minskim Exp $
SHA1 (pgpool-2.7.tar.gz) = 25963c9956c5cb00019a38b2f89c0e8b4830b153
RMD160 (pgpool-2.7.tar.gz) = c143f763f978b93faa23d5b5b0b87ff34975bb4a
Size (pgpool-2.7.tar.gz) = 153554 bytes
SHA1 (patch-aa) = 868af0f14b2f03921e2ad2301658a4d3466586ae
SHA1 (pgpool-3.4.1.tar.gz) = 55027bfb0437b4edea38a480163e32762698c48a
RMD160 (pgpool-3.4.1.tar.gz) = ba409a8b2b424272cd458e689ea94234f9bc3f42
Size (pgpool-3.4.1.tar.gz) = 201509 bytes
SHA1 (patch-aa) = 3e222f3c8b82ff317c7e628ce3e6e8554d0a49cc

View file

@ -1,13 +1,13 @@
$NetBSD: patch-aa,v 1.2 2006/01/15 17:09:51 minskim Exp $
$NetBSD: patch-aa,v 1.3 2011/04/05 17:47:17 minskim Exp $
--- Makefile.in.orig 2006-01-02 16:33:53.000000000 -0800
+++ Makefile.in
@@ -177,7 +177,7 @@ pgpool_SOURCES = pool.h version.h pgpool
pool_process_query.c pool_stream.c pool_connection_pool.c pool_params.c \
pool_signal.h pool_signal.c
@@ -184,7 +184,7 @@ pgpool_SOURCES = pool.h version.h pgpool
pool_hba.c pool_list.h pool_list.c pool_path.h pool_path.c \
pool_type.h pool_ip.h pool_ip.c pool_hba.conf.sample pgpool.pam
-sysconf_DATA = pgpool.conf.sample
-sysconf_DATA = pgpool.conf.sample pool_hba.conf.sample
+sysconf_DATA =
pkgdata_DATA = pgpool.pam
AM_CPPFLAGS = -Wall -Wmissing-prototypes -Wmissing-declarations -D_GNU_SOURCE
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-am
man_MANS = pgpool.8