Update to 2.16.0:

2.16.0
* Add keyboard support for the DVD keys: Up, Down, Left, Right
* Add support for audio/AMR, audio/AMR-WB and Musepack
* Remove old GStreamer 0.8 hacks
* Avoid repeat being turned on when it shouldn't in the web browser plugin

1.5.92
* Fix a crash when HAL isn't available
* Fix compilation with older versions of HAL, without HAL, and with the
  Browser plugin disabled
* Save and restore the sidebar width
* Set and use the connection speed preference (GStreamer)

1.5.91
* Numerous Browser Plugin enhancements:
  - Playlist support
  - Split the plugin in 4 different plugins, to allow
    name-based detection to work, and different Javascript interfaces
    to be used (Real Player/Helix, Windows Media Player and Quicktime
    compatible, and basic Totem)
  - Handle repeat and autostart parameters
  - Make sure the plugin is available for all Mozilla-based browsers
  - Make scrolling on the volume widget work as it should
* New icon
* Use HAL to determine the disc type
* Save and restore which sidebar was showing, and whether Totem was
  maximised
* Fix the window title not changing when playing files with broken names
* Fix Ctrl+Q not working in fullscreen
* More logo mode fixes (xine-lib)
* Fix aspect ratio of visuals (xine-lib)

1.5.90
* Add a default filename to the save playlist dialogue
* Add supprot for more DVD related remote buttons
* Move the properties dialogue to the sidebar
* Fix build with newer versions of D-Bus
* Avoid linking directly against the Mozilla libraries, should allow
  build-time and run-time engines to be different (build against Mozilla,
  run in Firefox)
* Make the "Seek To" dialogue work correctly when using the keyboard
* Fix logo related redraws (xine-lib)
* Try harder to extract audio/subtitles languages from files (GStreamer)

1.5.4
 * update xine-lib requirement to avoid startup crashes

1.5.3
 * Text subtitle encoding is now selectable
 * Numerous Browser Plugin enhancements:
   - Try to cache files while playing them
   - Add support for cache=true hint
   - Fix getting the true path for relative paths
   - Add support for audio-only playback
   - Add a way to copy the URL from the right-click menu
   - Add "Open in Movie Player" in the right-click menu
 * Make showing/hiding the sidebar not resize the video or the window
 * Pop down language and subtitle menus to avoid hangs when the language or
 subtitle changes while the menu is open
 * Add AC3 and Monkey's audio to the known filetypes
 * Draw the logo ourselves, so we don't crash on startup if the logo is too
 big for the X video buffer (xine-lib)
 * Show the logo when playing audio without visualisations
 * Fix a crash with non-default buffering values (GStreamer)
 * Fix a leak each time the logo was set (GStreamer)
 * Fix the "Skip to" dialogue not working when paused (GStreamer)

1.5.2
 * Make Space Play/Pause when the video widget has the focus
 * Fix DVD playback when started from gnome-volume-manager
 * Allow localisation for time labels
 * Fix possible crash when using the Nautilus properties tab
 * Use HAL to detect presence of discs in the drives
 * Fix problems using the Mozilla plugin on PPC systems
 * Add Impulse Tracker and MOD files to the list of supported types
 * Add audio/vnd.rn-realaudio as a supported playlist format
 * Use theme friendly window icons
 * Fix a new installation of Totem not using visualisation (GStreamer)

1.5.1
 * Add XSPF playlists read and write support
 * Allow users to choose the type of playlist to write when saving

1.5.0
 * Remove unused DXR3 support
 * Remove GStreamer 0.8 support
 * Fix the GTK+-only version not displaying some menu items
 * Update the "Skip to" time label when entering time manually, fix sensitivity
 of the OK button in that dialogue
 * Fix crash on exit if the interface couldn't be loaded
 * Add basic support for the Quicktime Metalink playlists
 * Avoid deadlocks when forcing opening with a subtitle when there's none
 * Fix crash when setting the connection speed setting to the maximum
 * Make the previous/next icons in the popup the same as in the rest
 of the interface
 * Make menu shortcuts unaccessible in fullscreen
 * Make Ctrl+S show the "Skip to" dialogue as it should
 * Fix a small memory leak in the Nautilus properties plugin
 * Add debugging to the playlist parser
 * Make the preferences window appear on top of the main window at all times,
 and hide it straight away when exiting
 * Fix playback of non-Mozilla streams (such as mms) in the Mozilla plugin
 * Fix saving non-relative m3u playlists
 * Handle space as Play/pause in windowed mode if the video widget has
 the focus
 * Work-around broken .pls files from Virgin radio
 * Fix problems with sound not coming out when audio output selected
 isn't Stereo (xine-lib)
 * Fix pixel aspect ratio settings (GStreamer)
This commit is contained in:
jmmv 2006-09-15 15:23:51 +00:00
parent fcb74780b1
commit 8c648b01e0
7 changed files with 45 additions and 79 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.13 2006/06/14 11:28:53 drochner Exp $
# $NetBSD: Makefile,v 1.14 2006/09/15 15:23:51 jmmv Exp $
#
.include "Makefile.common"
@ -7,7 +7,9 @@ COMMENT+= (using GStreamer)
CONFLICTS+= totem-xine-[0-9]*
CONFIGURE_ARGS+= --enable-gstreamer=0.10
CONFIGURE_ARGS+= --enable-gstreamer=yes
BUILDLINK_API_DEPENDS.gst-plugins0.10-base+= gst-plugins0.10-base>=0.10.7
.include "../../multimedia/gst-plugins0.10-base/buildlink3.mk"
.include "../../multimedia/gst-plugins0.10-good/buildlink3.mk"

View file

@ -1,10 +1,9 @@
# $NetBSD: Makefile.common,v 1.24 2006/08/23 09:49:35 jmmv Exp $
# $NetBSD: Makefile.common,v 1.25 2006/09/15 15:23:51 jmmv Exp $
#
DISTNAME= totem-1.4.4
PKGREVISION= 1
DISTNAME= totem-2.16.0
CATEGORIES= multimedia gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/totem/1.4/}
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/totem/2.16/}
MAINTAINER= jmmv@NetBSD.org
HOMEPAGE= http://www.hadess.net/totem.php3
@ -27,14 +26,17 @@ GCONF2_SCHEMAS= totem.schemas
GCONF2_SCHEMAS+= totem-handlers.schemas
GCONF2_SCHEMAS+= totem-video-thumbnail.schemas
BUILDLINK_API_DEPENDS.glib2+= glib2>=2.6.3
BUILDLINK_API_DEPENDS.glib2+= glib2>=2.8.0
BUILDLINK_API_DEPENDS.gnome-icon-theme+= gnome-icon-theme>=2.10.0
BUILDLINK_API_DEPENDS.gnome-vfs2+= gnome-vfs2>=2.8.2
BUILDLINK_API_DEPENDS.gtk2+= gtk2+>=2.6.0
.include "../../devel/GConf2/schemas.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/libglade2/buildlink3.mk"
.include "../../devel/libgnomeui/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../graphics/gnome-icon-theme/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../sysutils/gnome-vfs2/buildlink3.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.9 2006/07/02 11:24:24 drochner Exp $
@comment $NetBSD: PLIST,v 1.10 2006/09/15 15:23:51 jmmv Exp $
bin/totem
bin/totem-video-thumbnailer
include/totem/1/plparser/totem-disc.h
@ -71,18 +71,25 @@ share/gnome/help/totem/uk/figures/totem_volume_maximum_button.png
share/gnome/help/totem/uk/figures/totem_volume_mute_button.png
share/gnome/help/totem/uk/legal.xml
share/gnome/help/totem/uk/totem.xml
share/icons/hicolor/16x16/apps/totem.png
share/icons/hicolor/22x22/apps/totem.png
share/icons/hicolor/24x24/apps/totem.png
share/icons/hicolor/32x32/apps/totem.png
share/icons/hicolor/scalable/apps/totem.svg
share/locale/am/LC_MESSAGES/totem.mo
share/locale/ar/LC_MESSAGES/totem.mo
share/locale/az/LC_MESSAGES/totem.mo
share/locale/be/LC_MESSAGES/totem.mo
share/locale/bg/LC_MESSAGES/totem.mo
share/locale/bn/LC_MESSAGES/totem.mo
share/locale/bn_IN/LC_MESSAGES/totem.mo
share/locale/br/LC_MESSAGES/totem.mo
share/locale/ca/LC_MESSAGES/totem.mo
share/locale/cs/LC_MESSAGES/totem.mo
share/locale/cy/LC_MESSAGES/totem.mo
share/locale/da/LC_MESSAGES/totem.mo
share/locale/de/LC_MESSAGES/totem.mo
share/locale/dz/LC_MESSAGES/totem.mo
share/locale/el/LC_MESSAGES/totem.mo
share/locale/en_CA/LC_MESSAGES/totem.mo
share/locale/en_GB/LC_MESSAGES/totem.mo
@ -116,6 +123,7 @@ share/locale/nb/LC_MESSAGES/totem.mo
share/locale/ne/LC_MESSAGES/totem.mo
share/locale/nl/LC_MESSAGES/totem.mo
share/locale/nn/LC_MESSAGES/totem.mo
share/locale/or/LC_MESSAGES/totem.mo
share/locale/pa/LC_MESSAGES/totem.mo
share/locale/pl/LC_MESSAGES/totem.mo
share/locale/pt/LC_MESSAGES/totem.mo
@ -124,10 +132,12 @@ share/locale/ro/LC_MESSAGES/totem.mo
share/locale/ru/LC_MESSAGES/totem.mo
share/locale/rw/LC_MESSAGES/totem.mo
share/locale/sk/LC_MESSAGES/totem.mo
share/locale/sl/LC_MESSAGES/totem.mo
share/locale/sq/LC_MESSAGES/totem.mo
share/locale/sr/LC_MESSAGES/totem.mo
share/locale/sr@Latn/LC_MESSAGES/totem.mo
share/locale/sv/LC_MESSAGES/totem.mo
share/locale/ta/LC_MESSAGES/totem.mo
share/locale/te/LC_MESSAGES/totem.mo
share/locale/th/LC_MESSAGES/totem.mo
share/locale/tr/LC_MESSAGES/totem.mo
@ -146,12 +156,10 @@ share/omf/totem/totem-es.omf
share/omf/totem/totem-fr.omf
share/omf/totem/totem-ru.omf
share/omf/totem/totem-uk.omf
share/pixmaps/media-player-48.png
share/pixmaps/vanity.png
share/totem/filmholes-big-left.png
share/totem/filmholes-big-right.png
share/totem/filmholes.png
share/totem/media-player-48.png
share/totem/mozilla-viewer.glade
share/totem/playlist-playing.png
share/totem/playlist.glade
@ -175,6 +183,12 @@ share/totem/vanity.png
@comment in xdg-dirs: @dirrm share/pixmaps
@dirrm share/omf/totem
@comment in scrollkeeper: @dirrm share/omf
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/scalable/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/32x32/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/24x24/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/22x22/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/16x16/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor
@dirrm share/gnome/help/totem/uk/figures
@dirrm share/gnome/help/totem/uk
@dirrm share/gnome/help/totem/ru/figures

View file

@ -1,9 +1,7 @@
$NetBSD: distinfo,v 1.11 2006/08/06 21:26:18 jmmv Exp $
$NetBSD: distinfo,v 1.12 2006/09/15 15:23:51 jmmv Exp $
SHA1 (totem-1.4.4.tar.gz) = 310c2255c9bf03521552ab1428b61dccb1bbd7bd
RMD160 (totem-1.4.4.tar.gz) = 194f0e32a66a493fd10709e08ec9e2156496aef7
Size (totem-1.4.4.tar.gz) = 2352083 bytes
SHA1 (patch-aa) = 1267125093c4e76fc61575b83890b9adacff9a0d
SHA1 (patch-ab) = 6327cf86050bf2fbd9d6b37c338304ddeb08092c
SHA1 (patch-ac) = eb08ead97a419da14a7d870fff075b24d8d6da27
SHA1 (totem-2.16.0.tar.gz) = 17f107fb62e1664cb044cb9d58c3baa7d354a6af
RMD160 (totem-2.16.0.tar.gz) = 59eafa2627e9680117b9c567c7c8924007ea7374
Size (totem-2.16.0.tar.gz) = 2536646 bytes
SHA1 (patch-aa) = 6b000bf0e24244377d0c01307a7c9e650286e51d
SHA1 (patch-ad) = b5bcd9a86094c68624f2f3cc408d09730f514c29

View file

@ -1,36 +1,13 @@
$NetBSD: patch-aa,v 1.4 2006/01/12 16:57:49 jmmv Exp $
--- src/plparse/totem-disc.c.orig 2005-03-13 14:37:57.000000000 +0100
+++ src/plparse/totem-disc.c
@@ -43,7 +43,31 @@
#include <glib/gi18n.h>
#include <libgnomevfs/gnome-vfs.h>
+#if defined(__linux__)
#include <linux/cdrom.h>
+#elif defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
+#include <sys/cdio.h>
+#include <sys/disklabel.h>
+
+#define CDROM_DRIVE_STATUS 0x5326
+#define CDROM_DISC_STATUS 0x5327
+#define CDS_AUDIO 100
+#define CDS_MIXED 105
+#define CDS_DATA_1 101
+#define CDS_DATA_2 102
+#define CDS_NO_INFO 0 /* if not implemented */
+#define CDS_NO_DISC 1
+#define CDS_TRAY_OPEN 2
+#define CDS_DRIVE_NOT_READY 3
+#define CDS_DISC_OK 4
+#define CDS_XA_2_1 103
+#define CDS_XA_2_2 104
+#define CDC_DVD 0x8000
+#define ENOMEDIUM ENODEV
+#define CDROM_GET_CAPABILITY CDIOCCLRDEBUG
+#else
+#error "No support to access the CD in this platform."
+#endif
#include "totem-disc.h"
$NetBSD: patch-aa,v 1.5 2006/09/15 15:23:51 jmmv Exp $
--- Makefile.in.orig 2006-09-03 21:39:11.000000000 +0200
+++ Makefile.in
@@ -315,7 +315,7 @@ sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
-SUBDIRS = po data src browser-plugin help
+SUBDIRS = po data src help
EXTRA_DIST = \
COPYING.LIB \
autogen.sh \

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ab,v 1.3 2006/01/12 16:57:49 jmmv Exp $
--- src/Makefile.in.orig 2005-09-05 12:12:20.000000000 +0200
+++ src/Makefile.in
@@ -652,7 +652,8 @@ clean-noinstLTLIBRARIES:
echo "rm -f \"$${dir}/so_locations\""; \
rm -f "$${dir}/so_locations"; \
done
-install-pluginLTLIBRARIES: $(plugin_LTLIBRARIES)
+install-pluginLTLIBRARIES:
+do-not-install-pluginLTLIBRARIES: $(plugin_LTLIBRARIES)
@$(NORMAL_INSTALL)
test -z "$(plugindir)" || $(mkdir_p) "$(DESTDIR)$(plugindir)"
@list='$(plugin_LTLIBRARIES)'; for p in $$list; do \

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ac,v 1.1 2006/05/29 14:01:03 joerg Exp $
--- src/plparse/totem-disc.c.orig 2006-05-29 13:39:20.000000000 +0000
+++ src/plparse/totem-disc.c
@@ -45,7 +45,7 @@
#if defined(__linux__)
#include <linux/cdrom.h>
-#elif defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
+#elif defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)
#include <sys/cdio.h>
#include <sys/disklabel.h>