Disable optimisations for Clang for the Scribus 1.3.4 import filter.
This commit is contained in:
parent
e75a4cc3b6
commit
8c65c29f0a
3 changed files with 21 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
||||||
# $NetBSD: Makefile,v 1.27 2013/08/09 11:06:28 drochner Exp $
|
# $NetBSD: Makefile,v 1.28 2013/12/15 19:44:02 joerg Exp $
|
||||||
|
|
||||||
DISTNAME= scribus-1.4.3
|
DISTNAME= scribus-1.4.3
|
||||||
CATEGORIES= print
|
CATEGORIES= print
|
||||||
|
@ -21,6 +21,11 @@ CMAKE_ARGS+= -DPNG_LIBRARY_RELEASE=${LOCALBASE}/lib
|
||||||
|
|
||||||
INSTALLATION_DIRS+= share/pixmaps
|
INSTALLATION_DIRS+= share/pixmaps
|
||||||
|
|
||||||
|
.include "../../mk/compiler.mk"
|
||||||
|
.if !empty(PKGSRC_COMPILER:Mclang)
|
||||||
|
CMAKE_ARGS+= -DCLANG_NO_OPT=-O0
|
||||||
|
.endif
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
${INSTALL_DATA} ${WRKSRC}/resources/icons/scribus.png \
|
${INSTALL_DATA} ${WRKSRC}/resources/icons/scribus.png \
|
||||||
${DESTDIR}${PREFIX}/share/pixmaps
|
${DESTDIR}${PREFIX}/share/pixmaps
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: distinfo,v 1.6 2013/08/09 11:06:28 drochner Exp $
|
$NetBSD: distinfo,v 1.7 2013/12/15 19:44:02 joerg Exp $
|
||||||
|
|
||||||
SHA1 (scribus-1.4.3.tar.xz) = 30c111762790e4407c13236bbb4b06f04e907f71
|
SHA1 (scribus-1.4.3.tar.xz) = 30c111762790e4407c13236bbb4b06f04e907f71
|
||||||
RMD160 (scribus-1.4.3.tar.xz) = 0c3103536610ca1881d1b65b549886bf9f0d8650
|
RMD160 (scribus-1.4.3.tar.xz) = 0c3103536610ca1881d1b65b549886bf9f0d8650
|
||||||
|
@ -9,3 +9,4 @@ SHA1 (patch-ai) = fbd6212fc9190d1b2ede4d54806355e5d0ed389e
|
||||||
SHA1 (patch-ba) = ecddb2304b0ab37fbca41a662773107923df273b
|
SHA1 (patch-ba) = ecddb2304b0ab37fbca41a662773107923df273b
|
||||||
SHA1 (patch-bb) = c39d78679e0cd17a0fe19a98ecabe7eadfc5b881
|
SHA1 (patch-bb) = c39d78679e0cd17a0fe19a98ecabe7eadfc5b881
|
||||||
SHA1 (patch-bc) = 1b93d844b40ebe9b425ac7e6fb6b05189c194b6b
|
SHA1 (patch-bc) = 1b93d844b40ebe9b425ac7e6fb6b05189c194b6b
|
||||||
|
SHA1 (patch-scribus_plugins_fileloader_scribus134format_CMakeLists.txt) = b0fa6cabcbcdc46d2a662df313b02f61f4926d2b
|
||||||
|
|
|
@ -0,0 +1,13 @@
|
||||||
|
$NetBSD: patch-scribus_plugins_fileloader_scribus134format_CMakeLists.txt,v 1.1 2013/12/15 19:44:02 joerg Exp $
|
||||||
|
|
||||||
|
--- scribus/plugins/fileloader/scribus134format/CMakeLists.txt.orig 2013-12-14 22:12:14.000000000 +0000
|
||||||
|
+++ scribus/plugins/fileloader/scribus134format/CMakeLists.txt
|
||||||
|
@@ -14,6 +14,8 @@ scribus134format_save.cpp
|
||||||
|
scribus134formatimpl.cpp
|
||||||
|
)
|
||||||
|
|
||||||
|
+SET_SOURCE_FILES_PROPERTIES(scribus134format.cpp PROPERTIES COMPILE_FLAGS "${CLANG_NO_OPT}")
|
||||||
|
+
|
||||||
|
SET(SCRIBUS_SCR134FORMAT_FL_PLUGIN "scribus134format")
|
||||||
|
|
||||||
|
QT4_WRAP_CPP(SCR134FORMAT_FL_PLUGIN_MOC_SOURCES ${SCR134FORMAT_FL_PLUGIN_MOC_CLASSES})
|
Loading…
Reference in a new issue