Update cdrecord to 1.9.
Changes to 1.8.1 are: All: - Fallback code to use the USCSI interface on Solaris This should add ATAPI support on Solaris 8 sparc. Solaris 8 x86 does support ATAPI with the scg driver as Sun fixed the structural bug for thw Intel version. Warning: The USCI interface has several drawbacks: - Only finds disk type devices with -scanbus - Cannot open devices that are currently attached to the volume management system - The Goldstar ATAPI CD-ROM in a U-10 transfers data but the DMA residual count shows that there has been no transfer at all. Facit: Test by your own if this interface is usable. Please report problems! To check the difference: cdrecord -scanbus uses the scg driver cdrecord -scanbus dev=USCSI uses the USCSI interface cdrecord -toc dev=1,6,0 uses the scg driver cdrecord -toc dev=USCSI:1,6,0 uses the USCSI interface NOTE: If you are using the USCSI interface you will need to shut down the volume management for the drives you like to use. - Linux code in libscg now tries to use new features of the Linus sg driver: - Trying to use more then 32 kB for DMA The interface for raising the DMA limit from 32 kB is a real pain. It needs a lot of code to adopt the interface to libscg. - Trying to use the new ioctl() interface if present. This interface now supports: - SCSI CDB sizes for vendor unique commands - SCSI status byte - SCSI command transport status - More than 16 bytes of sense data (not yet working!) - DMA residual count (not yet working!) - Arbitrary DMA address pointers !!! - Trying to use the new RESET ioctl() (not yet working!) All items marked (not yet working!) will turn funtional after the Linux kernel starts to support them. It seems that my shouting for a better SCSI interface succeeded. Linux-2.4 supports or at least includes an interface that may support the needed things in future. As from now it is unclear whether the code will expose any portability problems, please test on different Linux versions from 2.0 ... 2.4 if available and report problems. - README.macosX added (needed to know how to compile). As Apple deliveres an inconsistent OS, you need to follow the instuctions in this README file before you may compile cdrtools on Mac OS X. TODO: - Better BeOS integration Cdrecord: - include sys/select.h if needed (AIX) - Support for Ricoh 9060 CD-RW/DVD-ROM drive - Support for Plextor PX-W1210TA (with BURN-Proof) - Printing of new features added to -prcap function - New Disk manufacturers: "WEALTH FAIR INVESTMENT LIMITE" "General Magnetics Ld" "MPO" - DAO now should work with pregapsize == 0 when using Sony or Goldstar drives. Cdrecord retries with pregaps set to 1 - New options -shorttrack & -noshorttrack will allow to copy CD's with supershort tracks in DAO mode if the drive supports it. - Fix for a buffer overflow with cdrecord dev= This problem did not exist on sparc systems, for this reason it has not been detected before. - ATIP Decoder now decodes disk sub type for High speed CD-RW - Support for 99 minute CD's. - Force the user to use -ignsize to allow >= 90 Minutes on CD even when the current CD is not in the blank capacity database. Cdda2wav: - support for cds with illegal leadout (like HIM-CD) - bugfix for cd-text detection with plextor/Sony command sets - should compile and run under Mac-OS-X now - bugfix with the -q (quiet) option - bugfix use extra libs (like lossaudio for NetBSD) - bugfix use the correct sound device for Solaris - hardened cdda2wav against illegal ISRC codes - more diagnostics for illegal ISRCs - use setpriority in favor of nice - updated cdda2mp3 script for lame usage (alpha) Readcd: - minor bugfixes with timing - New options -noerror & retries=# - restructured to be more flexible - Support for C2 error pointer scan with MMC drives & the Plextor U-Plex 40 CD-ROM Mkisofs: - Now mkhybrid code is completely integrated into mkisofs. There is only one binary. To help users of mkhybrid, make install creates a hard link from mkhybroid to mkisofs. - man page cleaned up. - Now mkhybrid code is completely integrated into mkisofs. There is only one binary. To help users of mkhybrid, make install creates a hard link from mkhybroid to mkisofs. - New Option -eltorito-alt-boot allows to specify more than one Al Torito boot image (up to 63). Thanks to Egor Duda (deo@logos-m.ru). - fixed a core dump problem in multi.c - write.c now uses static buffer to circumvent a problem with the stone age Metrowerks C found on BeOS/PPC - Allow printing of percentage ready without floatingpoint code in printf. - apple_driver now compiles, but need to call make -f apple_driver.mk by hand - graft pointers are now really usable: - Graft points are now disabled by default - To enable, specify the -graft-point option dir=dir only works if the '=' is not escaped by '\' '\\' and '=' must be escaped by a '\\' if -graft-points has been specified. - Now there is no more a need to specify a command line arg if -path-list has been specified.
This commit is contained in:
parent
786810fdc8
commit
8c74841c09
9 changed files with 89 additions and 102 deletions
|
@ -1,43 +1,40 @@
|
|||
# $NetBSD: Makefile,v 1.31 2000/07/06 00:05:22 dmcmahill Exp $
|
||||
# FreeBSD Id: Makefile,v 1.2 1997/11/05 23:55:31 asami Exp
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.32 2000/07/22 16:14:48 rh Exp $
|
||||
|
||||
DISTNAME= cdrecord-1.8
|
||||
DISTNAME= cdrecord-1.9
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ftp://ftp.fokus.gmd.de/pub/unix/cdrecord/
|
||||
|
||||
MAINTAINER= hubertf@netbsd.org
|
||||
HOMEPAGE= http://www.fokus.gmd.de/nthp/employees/schilling/cdrecord.html
|
||||
HOMEPAGE= http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/cdrecord.html
|
||||
|
||||
CONFLICTS= mkisofs-*
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:C/a.*//}
|
||||
TARGET_ARCH= ${MACHINE_ARCH}-netbsd-cc
|
||||
TARGET_DIR= OBJ/${TARGET_ARCH}
|
||||
#override ARCH to avoid picking up a bad ${ARCH} during the build
|
||||
MAKE_ENV+= ARCH=""
|
||||
MAKE_ENV+= ARCH=""
|
||||
|
||||
post-configure:
|
||||
do-configure:
|
||||
${MKDIR} ${WRKSRC}/include/sys
|
||||
${LN} -fs /usr/include/soundcard.h ${WRKSRC}/include/sys
|
||||
cd ${WRKSRC}/RULES ; \
|
||||
cd ${WRKSRC}/RULES; \
|
||||
${TEST} -f netbsd-cc.rul || ${MV} i386-netbsd-cc.rul netbsd-cc.rul; \
|
||||
${TEST} -f netbsd-gcc.rul || ${MV} i386-netbsd-gcc.rul netbsd-gcc.rul; \
|
||||
${LN} -sf netbsd-gcc.rul ${MACHINE}-netbsd-gcc.rul; \
|
||||
${LN} -sf netbsd-cc.rul ${TARGET_ARCH}.rul;
|
||||
${LN} -sf netbsd-cc.rul ${TARGET_ARCH}.rul
|
||||
|
||||
do-install:
|
||||
cd ${WRKSRC}/cdda2wav; \
|
||||
${INSTALL_PROGRAM} ${TARGET_DIR}/cdda2wav ${PREFIX}/bin; \
|
||||
${INSTALL_MAN} cdda2wav.1 ${PREFIX}/man/man1
|
||||
${INSTALL_PROGRAM} ${TARGET_DIR}/cdda2wav ${PREFIX}/bin; \
|
||||
${INSTALL_MAN} cdda2wav.1 ${PREFIX}/man/man1
|
||||
cd ${WRKSRC}/cdrecord; \
|
||||
${INSTALL_PROGRAM} ${TARGET_DIR}/cdrecord ${PREFIX}/bin; \
|
||||
${INSTALL_MAN} cdrecord.1 ${PREFIX}/man/man1
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/misc/${TARGET_DIR}/readcd ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${TARGET_DIR}/cdrecord ${PREFIX}/bin; \
|
||||
${INSTALL_MAN} cdrecord.1 ${PREFIX}/man/man1
|
||||
cd ${WRKSRC}/mkisofs; \
|
||||
${INSTALL_PROGRAM} ${TARGET_DIR}/mkisofs ${PREFIX}/bin; \
|
||||
${INSTALL_MAN} mkisofs.8 ${PREFIX}/man/man8
|
||||
${INSTALL_PROGRAM} ${TARGET_DIR}/mkisofs ${PREFIX}/bin; \
|
||||
${INSTALL_MAN} mkisofs.8 ${PREFIX}/man/man8
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/misc/${TARGET_DIR}/readcd ${PREFIX}/bin
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.5 2000/03/03 15:22:19 scw Exp $
|
||||
$NetBSD: md5,v 1.6 2000/07/22 16:14:53 rh Exp $
|
||||
|
||||
MD5 (cdrecord-1.8.tar.gz) = ec22b0b1d9a7da2976dee40d2f2cb9e7
|
||||
MD5 (cdrecord-1.9.tar.gz) = 0fa360d9280d16370d7738ec0b62affb
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-sum,v 1.6 2000/05/22 02:00:57 hubertf Exp $
|
||||
$NetBSD: patch-sum,v 1.7 2000/07/22 16:14:53 rh Exp $
|
||||
|
||||
MD5 (patch-aa) = 7490f9d7cc82b64927a630b8fb6683ca
|
||||
MD5 (patch-ab) = 39b1982d628e4b004c9d0e5901c156b3
|
||||
MD5 (patch-ac) = fbf28297f94c6609087ce37b936d98c8
|
||||
MD5 (patch-ae) = 5d9bcff9749c4c9378ea949d69bf4b02
|
||||
MD5 (patch-aa) = 215cf68dff1a2f803801ec715a5a871b
|
||||
MD5 (patch-ab) = 3a20ed15fd69037fc67d9d7172125c23
|
||||
MD5 (patch-ac) = ae67c9a36c6b7370ca040f8b86e3b5d0
|
||||
MD5 (patch-ae) = 4c3938baa5a03adc55193361aa43c697
|
||||
MD5 (patch-af) = 82018d82a174d9d22e4f0f09d2a20276
|
||||
|
|
|
@ -1,21 +1,11 @@
|
|||
$NetBSD: patch-aa,v 1.4 2000/03/04 16:59:13 scw Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2000/07/22 16:14:53 rh Exp $
|
||||
|
||||
--- include/btorder.h.orig Wed Jan 5 17:42:40 2000
|
||||
+++ include/btorder.h Sat Mar 4 16:28:55 2000
|
||||
@@ -25,6 +25,7 @@
|
||||
#define _BTORDER_H
|
||||
|
||||
#include <sys/types.h> /* try to load isa_defs.h on Solaris */
|
||||
+#include <sys/endian.h>
|
||||
|
||||
#ifndef _MCONFIG_H
|
||||
#include <mconfig.h>
|
||||
@@ -74,7 +75,7 @@
|
||||
# if defined(__ppc__) || defined(ppc) || defined(__ppc) || \
|
||||
defined(__PPC) || defined(powerpc) || defined(__powerpc__)
|
||||
|
||||
-# if defined(__BIG_ENDIAN__)
|
||||
+# if defined(__BIG_ENDIAN__) || BYTE_ORDER == BIG_ENDIAN
|
||||
# define _BIT_FIELDS_HTOL
|
||||
# else
|
||||
# define _BIT_FIELDS_LTOH
|
||||
--- TARGETS/Targetdirs.orig Sun Apr 30 01:14:51 2000
|
||||
+++ TARGETS/Targetdirs Mon May 22 04:14:51 2000
|
||||
@@ -1,5 +1,5 @@
|
||||
#ident %W% %E% %Q%
|
||||
###########################################################################
|
||||
DIRS= patches conf inc lib libdeflt libscg libhfs_iso libfile libunls \
|
||||
- cdrecord mkisofs mkisofs/diag cdda2wav misc man
|
||||
+ cdrecord mkisofs mkisofs/diag cdda2wav misc
|
||||
###########################################################################
|
||||
|
|
|
@ -1,38 +1,22 @@
|
|||
$NetBSD: patch-ab,v 1.3 2000/03/03 15:22:19 scw Exp $
|
||||
$NetBSD: patch-ab,v 1.4 2000/07/22 16:14:53 rh Exp $
|
||||
|
||||
*** DEFAULTS/Defaults.netbsd.orig Wed Nov 12 23:52:33 1997
|
||||
--- DEFAULTS/Defaults.netbsd Wed Nov 12 23:55:30 1997
|
||||
***************
|
||||
*** 19,25 ****
|
||||
CWARNOPTS=
|
||||
|
||||
DEFINCDIRS= $(SRCROOT)/include
|
||||
! LDPATH= -L/opt/schily/lib
|
||||
#RUNPATH= -R $(INS_BASE)/lib -R /opt/schily/lib -R $(OLIBSDIR) Will probably not work
|
||||
|
||||
###########################################################################
|
||||
--- 19,25 ----
|
||||
CWARNOPTS=
|
||||
|
||||
DEFINCDIRS= $(SRCROOT)/include
|
||||
! LDPATH= -L$(SRCROOT)/lib
|
||||
#RUNPATH= -R $(INS_BASE)/lib -R /opt/schily/lib -R $(OLIBSDIR) Will probably not work
|
||||
|
||||
###########################################################################
|
||||
***************
|
||||
*** 27,33 ****
|
||||
# Installation config stuff
|
||||
#
|
||||
###########################################################################
|
||||
! INS_BASE= /opt/schily
|
||||
INS_KBASE= /
|
||||
#
|
||||
DEFUMASK= 002
|
||||
--- 27,33 ----
|
||||
# Installation config stuff
|
||||
#
|
||||
###########################################################################
|
||||
! INS_BASE= $(PREFIX)
|
||||
INS_KBASE= /
|
||||
#
|
||||
DEFUMASK= 002
|
||||
--- DEFAULTS/Defaults.netbsd.orig Tue Nov 2 12:41:03 1999
|
||||
+++ DEFAULTS/Defaults.netbsd Mon Nov 15 20:29:31 1999
|
||||
@@ -19,7 +19,7 @@
|
||||
CWARNOPTS=
|
||||
|
||||
DEFINCDIRS= $(SRCROOT)/include
|
||||
-LDPATH= -L/opt/schily/lib
|
||||
+LDPATH= -L$(SRCROOT)/lib
|
||||
#RUNPATH= -R $(INS_BASE)/lib -R /opt/schily/lib -R $(OLIBSDIR) Will probably not work
|
||||
|
||||
###########################################################################
|
||||
@@ -27,7 +27,7 @@
|
||||
# Installation config stuff
|
||||
#
|
||||
###########################################################################
|
||||
-INS_BASE= /opt/schily
|
||||
+INS_BASE= $(PREFIX)
|
||||
INS_KBASE= /
|
||||
#
|
||||
DEFUMASK= 002
|
||||
|
|
|
@ -1,13 +1,21 @@
|
|||
$NetBSD: patch-ac,v 1.10 2000/03/15 00:09:07 hubertf Exp $
|
||||
$NetBSD: patch-ac,v 1.11 2000/07/22 16:14:53 rh Exp $
|
||||
|
||||
--- include/btorder.h.orig Wed Mar 15 00:22:54 2000
|
||||
+++ include/btorder.h Wed Mar 15 00:23:14 2000
|
||||
@@ -25,7 +25,7 @@
|
||||
--- include/btorder.h.orig Wed Jan 5 17:42:40 2000
|
||||
+++ include/btorder.h Sat Mar 4 16:28:55 2000
|
||||
@@ -25,6 +25,7 @@
|
||||
#define _BTORDER_H
|
||||
|
||||
#include <sys/types.h> /* try to load isa_defs.h on Solaris */
|
||||
-#include <sys/endian.h>
|
||||
+#include <machine/endian.h>
|
||||
|
||||
#ifndef _MCONFIG_H
|
||||
#include <mconfig.h>
|
||||
@@ -74,7 +75,7 @@
|
||||
# if defined(__ppc__) || defined(ppc) || defined(__ppc) || \
|
||||
defined(__PPC) || defined(powerpc) || defined(__powerpc__)
|
||||
|
||||
-# if defined(__BIG_ENDIAN__)
|
||||
+# if defined(__BIG_ENDIAN__) || BYTE_ORDER == BIG_ENDIAN
|
||||
# define _BIT_FIELDS_HTOL
|
||||
# else
|
||||
# define _BIT_FIELDS_LTOH
|
||||
|
|
|
@ -1,13 +1,23 @@
|
|||
$NetBSD: patch-ae,v 1.2 2000/03/03 15:22:19 scw Exp $
|
||||
$NetBSD: patch-ae,v 1.3 2000/07/22 16:14:53 rh Exp $
|
||||
|
||||
--- include/vadefs.h.orig Sat Nov 27 19:25:44 1999
|
||||
+++ include/vadefs.h Fri Mar 3 14:41:00 2000
|
||||
@@ -51,7 +51,7 @@
|
||||
# endif
|
||||
#endif
|
||||
--- cdda2wav/Makefile.orig Tue Nov 16 00:48:52 1999
|
||||
+++ cdda2wav/Makefile Tue Nov 16 00:49:23 1999
|
||||
@@ -7,7 +7,8 @@
|
||||
|
||||
-#if (defined(__linux__) || defined(__linux) || defined(sun)) && \
|
||||
+#if (defined(__linux__) || defined(__linux) || defined(sun) || defined(__NetBSD__)) && \
|
||||
(defined(__ppc) || defined(__PPC) || defined(powerpc) || defined(__powerpc__))
|
||||
INSDIR= bin
|
||||
TARGET= cdda2wav
|
||||
-CPPOPTS += -DFIFO -I../cdrecord $(CDDA2WAVDEFS)
|
||||
+CPPOPTS += -DFIFO -I../cdrecord $(CDDA2WAVDEFS) \
|
||||
+ -DECHO_TO_SOUNDCARD -DHAVE_OSS=1 -DHAVE_SYS_SOUNDCARD_H
|
||||
CFILES= cdda2wav.c interface.c semshm.c resample.c \
|
||||
toc.c wav.c sun.c raw.c md5c.c setuid.c ringbuff.c \
|
||||
sndconfig.c scsi_cmds.c aiff.c aifc.c \
|
||||
@@ -17,7 +18,7 @@
|
||||
config.h saveargs.h sndfile.h aiff.h aifc.h \
|
||||
sndconfig.h scsi_cmds.h lowlevel.h byteorder.h mycdrom.h \
|
||||
base64.h sha.h mmsystem.h
|
||||
-LIBS= -lscg -lschily $(SCSILIB) $(EXTRALIB)
|
||||
+LIBS= -lscg -lschily $(SCSILIB) $(EXTRALIB) -lossaudio
|
||||
XMK_FILE= Makefile.man
|
||||
|
||||
# ifndef VA_LIST_IS_ARRAY
|
||||
LCONFIG= local.cnf
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-af,v 1.1 2000/05/22 02:00:57 hubertf Exp $
|
||||
$NetBSD: patch-af,v 1.2 2000/07/22 16:14:54 rh Exp $
|
||||
|
||||
--- RULES/mk-gmake.id.orig Thu Mar 9 22:36:18 2000
|
||||
+++ RULES/mk-gmake.id Thu Mar 9 22:36:52 2000
|
||||
|
|
|
@ -1,10 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2000/06/01 14:21:07 fvdl Exp $
|
||||
bin/cdrecord
|
||||
@comment $NetBSD: PLIST,v 1.8 2000/07/22 16:14:54 rh Exp $
|
||||
bin/cdda2wav
|
||||
bin/readcd
|
||||
bin/cdrecord
|
||||
bin/mkisofs
|
||||
bin/readcd
|
||||
man/man1/cdda2wav.1
|
||||
man/man1/cdrecord.1
|
||||
man/man8/mkisofs.8
|
||||
@exec [ -e /dev/scgx ] || ln -s /dev/cd0d /dev/scgx
|
||||
@unexec /bin/rm -f /dev/scgx
|
||||
|
|
Loading…
Reference in a new issue