Apply upstream fix for providing the same ABI for C++03 and C++11.
Bump revision. Belatedly fix b3.mk.
This commit is contained in:
parent
5698d8dc7e
commit
8c917f778e
6 changed files with 72 additions and 9 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.28 2017/02/11 22:27:00 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.29 2017/09/25 22:26:27 joerg Exp $
|
||||
|
||||
DISTNAME= podofo-0.9.5
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=podofo/}
|
||||
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.8 2013/07/05 21:12:45 joerg Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.9 2017/09/25 22:26:27 joerg Exp $
|
||||
|
||||
BUILDLINK_TREE+= podofo
|
||||
|
||||
.if !defined(PODOFO_BUILDLINK3_MK)
|
||||
PODOFO_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.podofo+= podofo>=0.9.2
|
||||
BUILDLINK_API_DEPENDS.podofo+= podofo>=0.9.5nb1
|
||||
BUILDLINK_PKGSRCDIR.podofo?= ../../print/podofo
|
||||
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.17 2017/02/11 22:27:00 adam Exp $
|
||||
$NetBSD: distinfo,v 1.18 2017/09/25 22:26:27 joerg Exp $
|
||||
|
||||
SHA1 (podofo-0.9.5.tar.gz) = 25c84a9e4815197e967bdb93fc2de8e1654a2812
|
||||
RMD160 (podofo-0.9.5.tar.gz) = a557330766b1795dd010937eb5c08ce7df671122
|
||||
|
@ -6,7 +6,9 @@ SHA512 (podofo-0.9.5.tar.gz) = d13b30bfebc89b809173cd2251eed1f15dfa90abb58371bfd
|
|||
Size (podofo-0.9.5.tar.gz) = 1160799 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = f6e51c220fcd1cca833cdf5e4d9c3e0da9116c1e
|
||||
SHA1 (patch-cmake_modules_FindFREETYPE.cmake) = 755d6d7ad73dea490479b90299728129bb1b0795
|
||||
SHA1 (patch-src_base_PdfCompilerCompat.h) = 5472e3fdda57f48ac5d6f24e916e94c51fd18af4
|
||||
SHA1 (patch-src_base_PdfCompilerCompat.h) = 965cc15853f9829fad0e018651a7640914108c67
|
||||
SHA1 (patch-src_base_PdfDefines.h) = 1526aacbe680adaa6f147aafb3303ec2f45991e7
|
||||
SHA1 (patch-src_base_PdfMemoryManagement.cpp) = 9303daf1e471106d9d22e42230db650dba5f1006
|
||||
SHA1 (patch-src_base_PdfVariant.h) = 8e9c206738716fd51a1d56f34e7aa35cc6718d48
|
||||
SHA1 (patch-src_doc_PdfImage.cpp) = 844250a772d40ba3ea2322ea623990b87b27c664
|
||||
SHA1 (patch-test_CMakeLists.txt) = 846871dac995ff80544ad9096574eddd776e324f
|
||||
|
|
|
@ -1,8 +1,12 @@
|
|||
$NetBSD: patch-src_base_PdfCompilerCompat.h,v 1.2 2015/11/05 19:46:53 adam Exp $
|
||||
$NetBSD: patch-src_base_PdfCompilerCompat.h,v 1.3 2017/09/25 22:26:27 joerg Exp $
|
||||
|
||||
--- src/base/PdfCompilerCompat.h.orig 2011-09-30 13:20:59.000000000 +0200
|
||||
+++ src/base/PdfCompilerCompat.h 2014-08-26 14:58:16.000000000 +0200
|
||||
@@ -72,6 +72,9 @@
|
||||
Ensure alloca exists, even in standard modes on NetBSD.
|
||||
|
||||
Merge r1825.
|
||||
|
||||
--- src/base/PdfCompilerCompat.h.orig 2017-01-11 20:32:50.000000000 +0000
|
||||
+++ src/base/PdfCompilerCompat.h
|
||||
@@ -74,6 +74,9 @@
|
||||
#if defined(_WIN32)
|
||||
#include <malloc.h>
|
||||
#endif
|
||||
|
@ -12,3 +16,20 @@ $NetBSD: patch-src_base_PdfCompilerCompat.h,v 1.2 2015/11/05 19:46:53 adam Exp $
|
|||
|
||||
// Disable usage of min() and max() macros
|
||||
#if defined(_WIN32) && !defined(__MINGW32__)
|
||||
@@ -198,16 +201,6 @@ namespace PoDoFo {
|
||||
|
||||
#endif // defined(_WIN32)
|
||||
|
||||
-// Visual C++ 2015 (_MSC_VER 1900) still uses __cplusplus = 199711 so, we need both tests
|
||||
-// this shrinks enum types from sizeof(int) to sizeof(char) which creates significant
|
||||
-// space savings on PdfObject / PdfVariant
|
||||
-#if (defined(_MSC_VER) && _MSC_VER < 1900) || (!defined(_MSC_VER) && __cplusplus < 201103)
|
||||
-#define PODOFO_ENUM_UINT8
|
||||
-#else
|
||||
-#define PODOFO_ENUM_UINT8 : uint8_t
|
||||
-#endif
|
||||
-
|
||||
-
|
||||
/**
|
||||
* \page PoDoFo PdfCompilerCompat Header
|
||||
*
|
||||
|
|
15
print/podofo/patches/patch-src_base_PdfDefines.h
Normal file
15
print/podofo/patches/patch-src_base_PdfDefines.h
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_base_PdfDefines.h,v 1.1 2017/09/25 22:26:27 joerg Exp $
|
||||
|
||||
Merge r1825.
|
||||
|
||||
--- src/base/PdfDefines.h.orig 2017-09-25 13:21:28.667585186 +0000
|
||||
+++ src/base/PdfDefines.h
|
||||
@@ -194,7 +194,7 @@ const EPdfWriteMode ePdfWriteMode_Defaul
|
||||
*
|
||||
* Remember to update PdfVariant::GetDataTypeString() when adding members here.
|
||||
*/
|
||||
-enum EPdfDataType PODOFO_ENUM_UINT8 {
|
||||
+enum EPdfDataType {
|
||||
ePdfDataType_Bool, /**< Boolean datatype: Accepts the values "true" and "false" */
|
||||
ePdfDataType_Number, /**< Number datatype for integer values */
|
||||
ePdfDataType_Real, /**< Real datatype for floating point numbers */
|
24
print/podofo/patches/patch-src_base_PdfVariant.h
Normal file
24
print/podofo/patches/patch-src_base_PdfVariant.h
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-src_base_PdfVariant.h,v 1.1 2017/09/25 22:26:27 joerg Exp $
|
||||
|
||||
Merge r1825.
|
||||
|
||||
--- src/base/PdfVariant.h.orig 2017-09-25 13:20:57.927586504 +0000
|
||||
+++ src/base/PdfVariant.h
|
||||
@@ -513,7 +513,7 @@ class PODOFO_API PdfVariant {
|
||||
* required to access the correct member of
|
||||
* the union UVariant.
|
||||
*/
|
||||
- EPdfDataType m_eDataType;
|
||||
+ pdf_int8 m_eDataType;
|
||||
|
||||
// No touchy. Only for use by PdfVariant's internal tracking of the delayed
|
||||
// loading state. Use DelayedLoadDone() to test this if you need to.
|
||||
@@ -574,7 +574,7 @@ EPdfDataType PdfVariant::GetDataType() c
|
||||
{
|
||||
DelayedLoad();
|
||||
|
||||
- return m_eDataType;
|
||||
+ return static_cast<EPdfDataType>(m_eDataType);
|
||||
}
|
||||
|
||||
// -----------------------------------------------------
|
Loading…
Reference in a new issue