Make this work on linux (and possibly solaris) and fix a few hardcoded

path bugs:
- pass OPSYS to Makefile.inc, don't hardcode NETBSD1
- command_directory, daemon_directory, share_directory, man_directory
  were hard-coded to /usr/pkg, bleh!
- and so was the ROOT_PATH.
This commit is contained in:
christos 1999-06-26 16:55:27 +00:00
parent 0524764173
commit 8cef8539d4
4 changed files with 20 additions and 14 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.7 1999/06/13 20:27:49 kleink Exp $
# $NetBSD: Makefile,v 1.8 1999/06/26 16:55:27 christos Exp $
DISTNAME= postfix-19990317-pl05
PKGNAME= postfix-19990317p05
@ -16,10 +16,16 @@ pre-patch:
pre-configure:
${CP} ${WRKSRC}/conf/main.cf ${WRKSRC}/conf/main.cf.dist
${CP} ${WRKSRC}/util/sys_defs.h ${WRKSRC}/util/sys_defs.h.dist
${SED} -e 's:__PREFIX:'${PREFIX}':g'< ${WRKSRC}/conf/main.cf.dist \
${CP} ${WRKSRC}/Makefile.inc ${WRKSRC}/Makefile.inc.dist
${SED} -e 's:__PREFIX:'${PREFIX}':g' \
< ${WRKSRC}/conf/main.cf.dist \
> ${WRKSRC}/conf/main.cf
${SED} -e 's:__PREFIX:'${PREFIX}':g'< ${WRKSRC}/util/sys_defs.h.dist \
${SED} -e 's:__PREFIX:'${PREFIX}':g' \
< ${WRKSRC}/util/sys_defs.h.dist \
> ${WRKSRC}/util/sys_defs.h
${SED} -e 's:@OPSYS@:'${CAPITAL_OPSYS}${OS_MAJOR_VERSION}':g' \
< ${WRKSRC}/Makefile.inc.dist \
> ${WRKSRC}/Makefile.inc
post-build:
${SED} -e 's#@@PREFIX@@#${PREFIX}#g' \

View file

@ -1,9 +1,9 @@
$NetBSD: patch-ab,v 1.1 1999/05/30 18:18:31 tron Exp $
$NetBSD: patch-ab,v 1.2 1999/06/26 16:55:28 christos Exp $
--- Makefile.inc.orig Sun May 30 18:49:12 1999
+++ Makefile.inc Sun May 30 18:49:12 1999
@@ -0,0 +1,32 @@
+# $NetBSD: patch-ab,v 1.1 1999/05/30 18:18:31 tron Exp $
+# $NetBSD: patch-ab,v 1.2 1999/06/26 16:55:28 christos Exp $
+
+WARNS?= 0
+
@ -19,7 +19,7 @@ $NetBSD: patch-ab,v 1.1 1999/05/30 18:18:31 tron Exp $
+UOBJDIR!=cd $(.CURDIR)/../util; \
+ printf "xxx: .MAKE\n\t@echo \$${.OBJDIR}\n" | ${MAKE} -s -f-
+
+CPPFLAGS+= -Wno-comment -DNETBSD1 -I${.CURDIR}/ \
+CPPFLAGS+= -Wno-comment -D@OPSYS@ -I${.CURDIR}/ \
+ -I${.CURDIR}/../master -I${.CURDIR}/../global -I${.CURDIR}/../util \
+ -I${.CURDIR}/../dns
+

View file

@ -1,9 +1,9 @@
$NetBSD: patch-af,v 1.1 1999/05/30 18:18:31 tron Exp $
$NetBSD: patch-af,v 1.2 1999/06/26 16:55:28 christos Exp $
--- conf/main.cf.orig Wed Mar 17 23:35:48 1999
+++ conf/main.cf Sun May 30 18:49:15 1999
@@ -1,3 +1,5 @@
+# $NetBSD: patch-af,v 1.1 1999/05/30 18:18:31 tron Exp $
+# $NetBSD: patch-af,v 1.2 1999/06/26 16:55:28 christos Exp $
+#
# Global Postfix configuration file. This file lists only a subset
# of all 100+ parameters. See the sample-xxx.cf files for a full list.
@ -19,7 +19,7 @@ $NetBSD: patch-af,v 1.1 1999/05/30 18:18:31 tron Exp $
# postXXX commands. The default value is $program_directory.
#
-#command_directory = /usr/sbin
+command_directory = /usr/pkg/sbin
+command_directory = __PREFIX/sbin
# The daemon_directory parameter specifies the location of all Postfix
# daemon programs (i.e. programs listed in the master.cf file). The
@ -27,12 +27,12 @@ $NetBSD: patch-af,v 1.1 1999/05/30 18:18:31 tron Exp $
# by root.
#
-#daemon_directory = /usr/libexec/postfix
+daemon_directory = /usr/pkg/libexec/postfix
+daemon_directory = __PREFIX/libexec/postfix
+
+# Shared files and etc directory
+etc_directory = /etc/postfix
+share_directory = /usr/pkg/share/postfix
+man_directory = /usr/pkg/man
+share_directory = __PREFIX/share/postfix
+man_directory = __PREFIX/man
# QUEUE AND PROCESS OWNERSHIP
#

View file

@ -1,4 +1,4 @@
$NetBSD: patch-bk,v 1.1 1999/05/30 18:18:33 tron Exp $
$NetBSD: patch-bk,v 1.2 1999/06/26 16:55:28 christos Exp $
--- util/sys_defs.h.orig Sat Mar 20 02:16:34 1999
+++ util/sys_defs.h Sun May 30 18:49:15 1999
@ -7,7 +7,7 @@ $NetBSD: patch-bk,v 1.1 1999/05/30 18:18:33 tron Exp $
#define ALIAS_DB_MAP "hash:/etc/aliases"
#define GETTIMEOFDAY(t) gettimeofday(t,(struct timezone *) 0)
-#define ROOT_PATH "/bin:/usr/bin:/sbin:/usr/sbin"
+#define ROOT_PATH "/bin:/usr/bin:/sbin:/usr/sbin:/usr/pkg/sbin:/usr/pkg/bin"
+#define ROOT_PATH "/bin:/usr/bin:/sbin:/usr/sbin:__PREFIX/sbin:__PREFIX/bin"
#define USE_STATFS
#define STATFS_IN_SYS_MOUNT_H
#endif