Update to version 0.9.9.1.
Changes between 0.9.8 and 0.9.9.1 ================================= * Updated protocol version to 1.2. Clients and servers with support for 1.1 are not compatible with the new protocol! * Added -no-listener option to FILE SEND command, Renamed FILE RECEIVE to FILE ACCEPT. * Added idle and signon fields to the ATTRIBUTE_SERVICE attribute to indicate the user's current idle and signon time of a service. * Added MAC field to the Private Message Payload to protect against chosen ciphertext attacks. * Added support for normal client to kill its own entries from the network. * Added ERR_UNSUPPORTED_PUBLIC_KEY and ERR_OPERATION_ALLOWED status types. * Defined the SILC_MESSAGE_FLAG_SIGNED. * Defined that all public keys sent in commands and notify payloads are actually Public Key Payloads not raw public key data. * Compute maximum padding for authentication packets to make passphrase approximation attacks impossible (padding must be at least 8 bytes now). * Added support for rekey before 2^32 sequence number wraps. * Added Encrypt-Then-MAC order to Channel Message Payload MAC generation. * Added Encrypt-Then-MAC order to SILC packet MAC generation. Deprecated the old Encrypt-And-MAC order. * Added expando $j which expands to current SILC Client version * SILC_UMODE_GONE changes are now propagated correctly to the client. * Print "nick now appears as newnick" and update nicklist when you change your nick to "nick". * Added support for setting FOUNDER mode on channel with specific public key which can be set with CMODE command. * Unified the Channel Message Payload and Private Message into one Message Payload. * UTF-8 decode topics also in JOIN command reply and TOPIC_SET notifys in client. * Added support to client sending new BAN and INVITE commands. Display INVITE and BAN lists as specified by SILC 1.2 * Merged with Irssi 0.8.6. * Added library versioning for shared libraries. * Do reverse lookups for server when /CONNECT-ing. * MARS support is now gone. * Fixed PING command sending in client library and handling in server. The server ID must be ID Payload, not raw ID data. * Fixed example in /HELP KEY * Fixed the client to correctly shutdown the client library to avoid memory leaks. * Fixed few double frees from client library.
This commit is contained in:
parent
ef3d336727
commit
8cf1d1da2c
5 changed files with 74 additions and 51 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.17 2002/11/21 15:40:14 salo Exp $
|
||||
# $NetBSD: Makefile,v 1.18 2002/12/04 17:26:48 salo Exp $
|
||||
|
||||
DISTNAME= silc-client-0.9.8
|
||||
DISTNAME= silc-client-0.9.9.1
|
||||
CATEGORIES= chat security
|
||||
MASTER_SITES= http://www.silcnet.org/download/client/sources/ \
|
||||
ftp://ftp.silcnet.org/silc/client/sources/ \
|
||||
|
@ -21,10 +21,17 @@ USE_GNU_ICONV= # defined
|
|||
USE_BUILDLINK2= # defined
|
||||
USE_LIBTOOL= # defined
|
||||
|
||||
BUILDLINK_DEPENDS.iconv= libiconv>=1.7
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
PKG_SYSCONFSUBDIR?= silc
|
||||
|
||||
MAKE_ENV+= examplesdir=${PREFIX}/share/examples/silc
|
||||
|
||||
CONF_FILES+= ${PREFIX}/share/examples/silc/silc.conf.default \
|
||||
${PKG_SYSCONFDIR}/silc.conf
|
||||
|
||||
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/silc
|
||||
CONFIGURE_ARGS+= --with-helpdir=${PREFIX}/share/silc/help
|
||||
CONFIGURE_ARGS+= --with-docdir=${PREFIX}/share/doc/silc
|
||||
|
@ -33,8 +40,6 @@ CONFIGURE_ARGS+= --with-simdir=${PREFIX}/lib/silc/modules
|
|||
CONFIGURE_ARGS+= --with-iconv=${BUILDLINK_DIR}
|
||||
CONFIGURE_ARGS+= --with-terminfo
|
||||
|
||||
BUILDLINK_DEPENDS.iconv= libiconv>=1.7
|
||||
|
||||
# Use native curses library.
|
||||
.if (${OPSYS} == "NetBSD") || (${OPSYS} == "SunOS")
|
||||
CONFIGURE_ARGS+= --with-vcurses
|
||||
|
@ -75,16 +80,17 @@ PLIST_SRC+= ${PKGDIR}/PLIST
|
|||
# Temporary hack which prevents installation of static libraries
|
||||
#
|
||||
post-build:
|
||||
for file in \
|
||||
for f in \
|
||||
${WRKSRC}/lib/libsilc.la \
|
||||
${WRKSRC}/lib/libsilcclient.la \
|
||||
${WRKSRC}/lib/.libs/libsilc.la \
|
||||
${WRKSRC}/lib/.libs/libsilcclient.la ; \
|
||||
do \
|
||||
${CP} $$file $$file.orig ; \
|
||||
${SED} "s|^old_library|#&|" $$file.orig > $$file ; \
|
||||
${CP} $$f $$f.orig ; \
|
||||
${SED} "s|^old_library|#&|" $$f.orig > $$f ; \
|
||||
done
|
||||
|
||||
.include "../../converters/libiconv/buildlink2.mk"
|
||||
.include "../../devel/glib/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.install.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,18 +1,18 @@
|
|||
@comment $NetBSD: PLIST,v 1.8 2002/11/21 15:40:14 salo Exp $
|
||||
@comment $NetBSD: PLIST,v 1.9 2002/12/04 17:26:48 salo Exp $
|
||||
bin/silc
|
||||
etc/silc/silc.conf
|
||||
lib/silc/libsilc-1.0.so
|
||||
lib/silc/libsilc-1.0.so.0
|
||||
lib/silc/libsilc-1.0.so.0.0
|
||||
lib/silc/libsilc.la
|
||||
lib/silc/libsilc.so
|
||||
lib/silc/libsilc.so.0
|
||||
lib/silc/libsilc.so.0.0
|
||||
lib/silc/libsilcclient-1.0.so
|
||||
lib/silc/libsilcclient-1.0.so.0
|
||||
lib/silc/libsilcclient-1.0.so.0.0
|
||||
lib/silc/libsilcclient.la
|
||||
lib/silc/libsilcclient.so
|
||||
lib/silc/libsilcclient.so.0
|
||||
lib/silc/libsilcclient.so.0.0
|
||||
lib/silc/modules/aes.sim.so
|
||||
lib/silc/modules/blowfish.sim.so
|
||||
lib/silc/modules/cast.sim.so
|
||||
lib/silc/modules/mars.sim.so
|
||||
lib/silc/modules/md5.sim.so
|
||||
lib/silc/modules/none.sim.so
|
||||
lib/silc/modules/rc5.sim.so
|
||||
|
@ -21,6 +21,7 @@ lib/silc/modules/rsa.sim.so
|
|||
lib/silc/modules/sha1.sim.so
|
||||
lib/silc/modules/twofish.sim.so
|
||||
man/man1/silc.1
|
||||
share/examples/silc/silc.conf.default
|
||||
share/doc/silc/CHANGES
|
||||
share/doc/silc/COPYING
|
||||
share/doc/silc/CREDITS
|
||||
|
@ -32,7 +33,7 @@ share/doc/silc/TODO
|
|||
share/doc/silc/formats.txt
|
||||
share/doc/silc/manual.txt
|
||||
share/doc/silc/signals.txt
|
||||
share/doc/silc/silc.conf.default
|
||||
share/doc/silc/special_vars.txt
|
||||
share/doc/silc/startup-HOWTO.html
|
||||
share/silc/help/action
|
||||
share/silc/help/admin
|
||||
|
@ -84,7 +85,6 @@ share/silc/help/motd
|
|||
share/silc/help/msg
|
||||
share/silc/help/names
|
||||
share/silc/help/nick
|
||||
share/silc/help/note
|
||||
share/silc/help/notice
|
||||
share/silc/help/oper
|
||||
share/silc/help/part
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.14 2002/11/21 15:40:14 salo Exp $
|
||||
$NetBSD: distinfo,v 1.15 2002/12/04 17:26:48 salo Exp $
|
||||
|
||||
SHA1 (silc-client-0.9.8.tar.bz2) = 4b3029436226d4826e82ab6ca897e043e3588dda
|
||||
Size (silc-client-0.9.8.tar.bz2) = 1566456 bytes
|
||||
SHA1 (patch-aa) = 5c7233288521af164cc2588e84127774cddb359e
|
||||
SHA1 (silc-client-0.9.9.1.tar.bz2) = a49debb3fca372776ab33ff17d6d44c72510af5c
|
||||
Size (silc-client-0.9.9.1.tar.bz2) = 1436578 bytes
|
||||
SHA1 (patch-aa) = bce1074fe6f9987d531a215327b4bc691fd555fb
|
||||
SHA1 (patch-ab) = 9c02f3ab2d6502075a71f4ac777704c9d0797370
|
||||
|
|
|
@ -1,42 +1,38 @@
|
|||
$NetBSD: patch-aa,v 1.8 2002/11/21 15:40:15 salo Exp $
|
||||
$NetBSD: patch-aa,v 1.9 2002/12/04 17:26:49 salo Exp $
|
||||
|
||||
--- Makefile.in.orig Wed Nov 6 16:40:28 2002
|
||||
+++ Makefile.in Wed Nov 13 01:14:19 2002
|
||||
@@ -697,10 +697,7 @@
|
||||
-mkdir -p $(modulesdir)
|
||||
-mkdir -p $(helpdir)
|
||||
--- Makefile.in.orig Fri Nov 29 08:50:33 2002
|
||||
+++ Makefile.in Wed Dec 4 16:01:39 2002
|
||||
@@ -706,6 +706,7 @@
|
||||
-mkdir -p $(docdir)
|
||||
- -mkdir -p $(logsdir)
|
||||
-mkdir -p $(manualdir)/man1
|
||||
- -mkdir -p $(manualdir)/man5
|
||||
- -mkdir -p $(manualdir)/man8
|
||||
|
||||
generate-server-key:
|
||||
-@if test '!' -f $(etcdir)/silcd.pub ; then \
|
||||
@@ -713,11 +710,8 @@
|
||||
install-dirs-client: install-dirs
|
||||
+ -mkdir -p $(examplesdir)
|
||||
-mkdir -p $(helpdir)
|
||||
-mkdir -p $(mandir)/man1
|
||||
|
||||
@@ -717,7 +718,6 @@
|
||||
doc-install:
|
||||
-$(INSTALL_DATA) $(srcdir)/doc/CodingStyle $(docdir)/
|
||||
-$(INSTALL_DATA) $(srcdir)/doc/FAQ $(docdir)/
|
||||
- -$(INSTALL_DATA) $(srcdir)/doc/example_* $(docdir)/
|
||||
- -$(INSTALL_DATA) $(srcdir)/doc/*.txt $(docdir)/
|
||||
+ -$(INSTALL_DATA) $(srcdir)/irssi/silc.conf $(docdir)/silc.conf.default
|
||||
-$(INSTALL_DATA) $(srcdir)/doc/silc.1 $(manualdir)/man1
|
||||
- -$(INSTALL_DATA) $(srcdir)/doc/silcd.8 $(manualdir)/man8;
|
||||
- -$(INSTALL_DATA) $(srcdir)/doc/silcd.conf.5 $(manualdir)/man5;
|
||||
-$(INSTALL_DATA) $(srcdir)/COPYING $(docdir)/
|
||||
-$(INSTALL_DATA) $(srcdir)/CHANGES $(docdir)/
|
||||
-$(INSTALL_DATA) $(srcdir)/CREDITS $(docdir)/
|
||||
@@ -737,13 +731,6 @@
|
||||
-$(INSTALL_DATA) $(srcdir)/doc/examples/silc* $(docdir)/examples/
|
||||
@@ -726,7 +726,7 @@
|
||||
-$(INSTALL_DATA) $(srcdir)/TODO $(docdir)/
|
||||
|
||||
etc-install:
|
||||
- -@if test '!' -f $(etcdir)/silcd.conf ; then \
|
||||
- $(INSTALL_DATA) $(srcdir)/doc/example_silcd.conf \
|
||||
- $(etcdir)/silcd.conf; \
|
||||
- $(INSTALL_DATA) $(srcdir)/doc/silcalgs.conf \
|
||||
- $(etcdir)/silcalgs.conf; \
|
||||
- chmod go= $(etcdir)/silcd.conf; \
|
||||
- fi
|
||||
-@if test '!' -d $(srcdir)/irssi ; then \
|
||||
if test '!' -f $(etcdir)/silc.conf ; then \
|
||||
$(INSTALL_DATA) $(srcdir)/irssi/silc.conf \
|
||||
doc-install-client: doc-install
|
||||
- $(INSTALL_DATA) $(srcdir)/irssi/silc.conf $(docdir)/example_silc.conf
|
||||
+ $(INSTALL_DATA) $(srcdir)/irssi/silc.conf $(examplesdir)/silc.conf.default
|
||||
-@if test -f $(srcdir)/doc/silc.1 ; then \
|
||||
$(INSTALL_DATA) $(srcdir)/doc/silc.1 $(mandir)/man1; \
|
||||
fi
|
||||
@@ -776,7 +776,7 @@
|
||||
$(sbindir)/silcd -C $(etcdir); \
|
||||
fi
|
||||
|
||||
-@SILC_DIST_CLIENT_TRUE@install-data-hook: install-dirs-client sim-install doc-install-client etc-install-client
|
||||
+@SILC_DIST_CLIENT_TRUE@install-data-hook: install-dirs-client sim-install doc-install-client
|
||||
@SILC_DIST_CLIENT_FALSE@@SILC_DIST_TOOLKIT_TRUE@install-data-hook: install-dirs-client install-dirs-server sim-install doc-install-client doc-install-server toolkit-install examples-install etc-install-client etc-install-server generate-server-key
|
||||
@SILC_DIST_CLIENT_FALSE@@SILC_DIST_TOOLKIT_FALSE@install-data-hook: install-dirs-server sim-install doc-install-server examples-install etc-install-server generate-server-key
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
|
|
20
chat/silc-client/patches/patch-ab
Normal file
20
chat/silc-client/patches/patch-ab
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-ab,v 1.6 2002/12/04 17:26:49 salo Exp $
|
||||
|
||||
--- irssi/Makefile.in.orig Fri Nov 29 08:50:58 2002
|
||||
+++ irssi/Makefile.in Wed Dec 4 16:20:05 2002
|
||||
@@ -332,15 +332,6 @@
|
||||
-rm -f libtool
|
||||
uninstall-info-am:
|
||||
confDATA_INSTALL = $(INSTALL_DATA)
|
||||
-install-confDATA: $(conf_DATA)
|
||||
- @$(NORMAL_INSTALL)
|
||||
- $(mkinstalldirs) $(DESTDIR)$(confdir)
|
||||
- @list='$(conf_DATA)'; for p in $$list; do \
|
||||
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
- f="`echo $$p | sed -e 's|^.*/||'`"; \
|
||||
- echo " $(confDATA_INSTALL) $$d$$p $(DESTDIR)$(confdir)/$$f"; \
|
||||
- $(confDATA_INSTALL) $$d$$p $(DESTDIR)$(confdir)/$$f; \
|
||||
- done
|
||||
|
||||
uninstall-confDATA:
|
||||
@$(NORMAL_UNINSTALL)
|
Loading…
Reference in a new issue