Bump PKGREVISON.
* Fix build with giflib 5.0.4.
This commit is contained in:
parent
465af6efdf
commit
8cf6375a1a
5 changed files with 81 additions and 19 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.17 2013/06/06 12:54:15 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.18 2013/07/05 13:33:40 ryoon Exp $
|
||||
|
||||
CONFLICTS+= emacs24-nox11-[0-9]*
|
||||
PKGREVISION= 3
|
||||
PKGREVISION= 4
|
||||
|
||||
.include "../../editors/emacs24/Makefile.common"
|
||||
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.10 2013/03/22 18:05:09 marino Exp $
|
||||
$NetBSD: distinfo,v 1.11 2013/07/05 13:33:40 ryoon Exp $
|
||||
|
||||
SHA1 (emacs-24.3.tar.gz) = 3c672a176df06e20d2661058ad49893f184b4956
|
||||
RMD160 (emacs-24.3.tar.gz) = b67e847861002bbb76ae6588ff659408763313cf
|
||||
Size (emacs-24.3.tar.gz) = 52543898 bytes
|
||||
SHA1 (patch-aa) = 9c1c68344f446b85eba7d3bdc244ffa7c1983b67
|
||||
SHA1 (patch-ab) = 1143637a0fdc6ebc9503691f6e90c630c98532d2
|
||||
SHA1 (patch-aa) = 992373f582bbd99733361bae99bf54587a89a10d
|
||||
SHA1 (patch-ab) = 3d6c52d2e9ae934d955ae5bea0ef346d9fa428b9
|
||||
SHA1 (patch-ad) = 2dcb0f4b43c599d0c4af83b5f7e1f2797f96bdac
|
||||
SHA1 (patch-ag) = 407d34e97356c2e8bee26f0fd90f116dd194afcb
|
||||
SHA1 (patch-lib-careadlinkat.h) = f236d182e609bf7111c70e83e10806a75a220c29
|
||||
SHA1 (patch-src_image.c) = cb9b00c5478587d2e54286312411605753e66f5c
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: patch-aa,v 1.7 2013/03/22 18:05:10 marino Exp $
|
||||
$NetBSD: patch-aa,v 1.8 2013/07/05 13:33:40 ryoon Exp $
|
||||
|
||||
Add DragonFly
|
||||
* Add DragonFly
|
||||
* Fix giflib 5.0 build.
|
||||
|
||||
--- configure.ac.orig 2013-03-05 08:24:59.000000000 +0000
|
||||
+++ configure.ac
|
||||
|
@ -78,7 +79,17 @@ Add DragonFly
|
|||
netbsd | openbsd )
|
||||
if test -f $CRT_DIR/crti.o; then
|
||||
|
||||
@@ -2834,7 +2869,7 @@ mail_lock=no
|
||||
@@ -2661,7 +2696,8 @@ if test "${HAVE_X11}" = "yes" && test "$
|
||||
AC_CHECK_HEADER(gif_lib.h,
|
||||
# EGifPutExtensionLast only exists from version libungif-4.1.0b1.
|
||||
# Earlier versions can crash Emacs.
|
||||
- [AC_CHECK_LIB(gif, EGifPutExtensionLast, HAVE_GIF=yes, HAVE_GIF=maybe)])
|
||||
+# EGifPutExtensionLast) has been deprecated in giflib 5.0.0 or later.
|
||||
+ [AC_CHECK_LIB(gif, EGifPutExtensionTrailer, HAVE_GIF=yes, HAVE_GIF=maybe)])
|
||||
|
||||
if test "$HAVE_GIF" = yes; then
|
||||
LIBGIF=-lgif
|
||||
@@ -2834,7 +2870,7 @@ mail_lock=no
|
||||
case "$opsys" in
|
||||
aix4-2) mail_lock="lockf" ;;
|
||||
|
||||
|
@ -87,7 +98,7 @@ Add DragonFly
|
|||
|
||||
## On GNU/Linux systems, both methods are used by various mail programs.
|
||||
## I assume most people are using newer mailers that have heard of flock.
|
||||
@@ -2988,6 +3023,11 @@ case "$opsys" in
|
||||
@@ -2988,6 +3024,11 @@ case "$opsys" in
|
||||
## option to use it.
|
||||
darwin) LIBS_TERMCAP="-lncurses" ;;
|
||||
|
||||
|
@ -99,7 +110,7 @@ Add DragonFly
|
|||
gnu*) test -z "$LIBS_TERMCAP" && LIBS_TERMCAP="-lncurses" ;;
|
||||
|
||||
freebsd)
|
||||
@@ -3439,7 +3479,7 @@ case $opsys in
|
||||
@@ -3439,7 +3480,7 @@ case $opsys in
|
||||
esac
|
||||
|
||||
case $opsys in
|
||||
|
@ -108,7 +119,7 @@ Add DragonFly
|
|||
AC_DEFINE(DONT_REOPEN_PTY, 1, [Define if process.c does not need to
|
||||
close a pty to make it a controlling terminal (it is already a
|
||||
controlling terminal of the subprocess, because we did ioctl TIOCSCTTY).])
|
||||
@@ -3545,7 +3585,7 @@ case $opsys in
|
||||
@@ -3545,7 +3586,7 @@ case $opsys in
|
||||
AC_DEFINE(FIRST_PTY_LETTER, ['p'])
|
||||
;;
|
||||
|
||||
|
@ -117,7 +128,7 @@ Add DragonFly
|
|||
dnl if HAVE_GRANTPT
|
||||
if test "x$ac_cv_func_grantpt" = xyes; then
|
||||
AC_DEFINE(UNIX98_PTYS, 1, [Define if the system has Unix98 PTYs.])
|
||||
@@ -3628,7 +3668,7 @@ AH_TEMPLATE(SIGNALS_VIA_CHARACTERS, [Mak
|
||||
@@ -3628,7 +3669,7 @@ AH_TEMPLATE(SIGNALS_VIA_CHARACTERS, [Mak
|
||||
case $opsys in
|
||||
dnl Perry Smith <pedz@ddivt1.austin.ibm.com> says this is correct for AIX.
|
||||
dnl thomas@mathematik.uni-bremen.de says this is needed for IRIX.
|
||||
|
@ -126,7 +137,7 @@ Add DragonFly
|
|||
AC_DEFINE(SIGNALS_VIA_CHARACTERS, 1)
|
||||
;;
|
||||
|
||||
@@ -3725,6 +3765,10 @@ else dnl !ema
|
||||
@@ -3725,6 +3766,10 @@ else dnl !ema
|
||||
AC_DEFINE(PENDING_OUTPUT_COUNT(FILE), [((FILE)->_p - (FILE)->_bf._base)])
|
||||
;;
|
||||
|
||||
|
@ -137,7 +148,7 @@ Add DragonFly
|
|||
unixware)
|
||||
AC_DEFINE(PENDING_OUTPUT_COUNT(FILE), [((FILE)->__ptr - (FILE)->__base)])
|
||||
;;
|
||||
@@ -3782,7 +3826,7 @@ AH_TEMPLATE(TAB3, [Undocumented.])
|
||||
@@ -3782,7 +3827,7 @@ AH_TEMPLATE(TAB3, [Undocumented.])
|
||||
case $opsys in
|
||||
darwin) AC_DEFINE(TAB3, OXTABS) ;;
|
||||
|
||||
|
@ -146,7 +157,7 @@ Add DragonFly
|
|||
AC_DEFINE(TABDLY, OXTABS, [Undocumented.])
|
||||
AC_DEFINE(TAB3, OXTABS)
|
||||
;;
|
||||
@@ -3859,7 +3903,7 @@ if test x$GCC = xyes; then
|
||||
@@ -3859,7 +3904,7 @@ if test x$GCC = xyes; then
|
||||
else
|
||||
case $opsys in
|
||||
dnl irix: Tested on Irix 6.5. SCM worked on earlier versions.
|
||||
|
@ -155,7 +166,7 @@ Add DragonFly
|
|||
AC_DEFINE(GC_SETJMP_WORKS, 1)
|
||||
;;
|
||||
esac
|
||||
@@ -3959,7 +4003,7 @@ case $opsys in
|
||||
@@ -3959,7 +4004,7 @@ case $opsys in
|
||||
AC_DEFINE(BSD_SYSTEM_AHB, 1, [Define if AH_BOTTOM should change BSD_SYSTEM.])
|
||||
;;
|
||||
|
||||
|
@ -164,7 +175,7 @@ Add DragonFly
|
|||
AC_DEFINE(BSD4_2, [])
|
||||
AC_PREPROC_IFELSE([AC_LANG_PROGRAM([[
|
||||
#ifndef BSD_SYSTEM
|
||||
@@ -4415,7 +4459,7 @@ LIB_GCC=
|
||||
@@ -4415,7 +4460,7 @@ LIB_GCC=
|
||||
if test "x$GCC" = "xyes" && test "x$ORDINARY_LINK" != "xyes"; then
|
||||
|
||||
case "$opsys" in
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: patch-ab,v 1.7 2013/03/22 18:05:10 marino Exp $
|
||||
$NetBSD: patch-ab,v 1.8 2013/07/05 13:33:40 ryoon Exp $
|
||||
|
||||
Add DragonFly
|
||||
* Add DragonFly
|
||||
* Fix giflib 5.0 build.
|
||||
|
||||
--- configure.orig 2013-03-08 08:13:36.000000000 +0000
|
||||
+++ configure
|
||||
|
@ -102,6 +103,31 @@ Add DragonFly
|
|||
netbsd | openbsd )
|
||||
if test -f $CRT_DIR/crti.o; then
|
||||
|
||||
@@ -12766,8 +12825,8 @@ if test "${HAVE_X11}" = "yes" && test "$
|
||||
if test "x$ac_cv_header_gif_lib_h" = xyes; then :
|
||||
# EGifPutExtensionLast only exists from version libungif-4.1.0b1.
|
||||
# Earlier versions can crash Emacs.
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for EGifPutExtensionLast in -lgif" >&5
|
||||
-$as_echo_n "checking for EGifPutExtensionLast in -lgif... " >&6; }
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for EGifPutExtensionTrailer in -lgif" >&5
|
||||
+$as_echo_n "checking for EGifPutExtensionTrailer in -lgif... " >&6; }
|
||||
if ${ac_cv_lib_gif_EGifPutExtensionLast+:} false; then :
|
||||
$as_echo_n "(cached) " >&6
|
||||
else
|
||||
@@ -12782,11 +12841,11 @@ cat confdefs.h - <<_ACEOF >conftest.$ac_
|
||||
#ifdef __cplusplus
|
||||
extern "C"
|
||||
#endif
|
||||
-char EGifPutExtensionLast ();
|
||||
+char EGifPutExtensionTrailer ();
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-return EGifPutExtensionLast ();
|
||||
+return EGifPutExtensionTrailer ();
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
@@ -13404,7 +13463,7 @@ mail_lock=no
|
||||
case "$opsys" in
|
||||
aix4-2) mail_lock="lockf" ;;
|
||||
|
|
24
editors/emacs24/patches/patch-src_image.c
Normal file
24
editors/emacs24/patches/patch-src_image.c
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-src_image.c,v 1.1 2013/07/05 13:33:40 ryoon Exp $
|
||||
|
||||
* Fix build with giflib 5.0.
|
||||
|
||||
--- src/image.c.orig 2013-01-01 20:37:17.000000000 +0000
|
||||
+++ src/image.c
|
||||
@@ -7192,7 +7192,7 @@ gif_load (struct frame *f, struct image
|
||||
}
|
||||
|
||||
/* Open the GIF file. */
|
||||
- gif = fn_DGifOpenFileName (SSDATA (file));
|
||||
+ gif = fn_DGifOpenFileName (SSDATA (file), NULL);
|
||||
if (gif == NULL)
|
||||
{
|
||||
image_error ("Cannot open `%s'", file, Qnil);
|
||||
@@ -7213,7 +7213,7 @@ gif_load (struct frame *f, struct image
|
||||
memsrc.len = SBYTES (specified_data);
|
||||
memsrc.index = 0;
|
||||
|
||||
- gif = fn_DGifOpen (&memsrc, gif_read_from_memory);
|
||||
+ gif = fn_DGifOpen (&memsrc, gif_read_from_memory, NULL);
|
||||
if (!gif)
|
||||
{
|
||||
image_error ("Cannot open memory source `%s'", img->spec, Qnil);
|
Loading…
Reference in a new issue