Fix build on NetBSD-current/i386 by papering over a build time assertion.

(Probably due to 64-bit time_t.)
cvs: ----------------------------------------------------------------------
This commit is contained in:
tnn 2009-06-17 08:34:07 +00:00
parent 42e9984f0b
commit 8d07a95da3
2 changed files with 16 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.44 2009/06/08 10:16:22 hasso Exp $
$NetBSD: distinfo,v 1.45 2009/06/17 08:34:07 tnn Exp $
SHA1 (lftp-3.7.14.tar.bz2) = b36819aa9624057f1c9067867579c2ac509c72e7
RMD160 (lftp-3.7.14.tar.bz2) = b6c7bfc5d33b607203afa6784c2db5ece6d2716b
@ -8,3 +8,4 @@ SHA1 (patch-ab) = 65c92b264873b45c69a0dfde2d2715dca0b6dc36
SHA1 (patch-ac) = 32e1fba23d4d6bd0b06bacbe503cb9b39d2bf825
SHA1 (patch-ad) = a8a335baf0c9a2a89c58c7395c879d2e8b0c4407
SHA1 (patch-ae) = 3ee418b94cc1afb7b2db5bc550fd966d346368a4
SHA1 (patch-af) = 69c414ab28cbdfb86e4981fb7eaa7985b8384838

14
net/lftp/patches/patch-af Normal file
View file

@ -0,0 +1,14 @@
$NetBSD: patch-af,v 1.1 2009/06/17 08:34:07 tnn Exp $
--- lib/getdate.y.orig 2009-05-15 08:24:00.000000000 +0200
+++ lib/getdate.y
@@ -113,7 +113,9 @@
wraps around, but there's no portable way to check for that at
compile-time. */
verify (TYPE_IS_INTEGER (time_t));
+/* This assertion fails on NetBSD-current/i386 due to 64-bit time_t
verify (LONG_MIN <= TYPE_MINIMUM (time_t) && TYPE_MAXIMUM (time_t) <= LONG_MAX);
+*/
/* An integer value, and the number of digits in its textual
representation. */