scientific application for data analysis and technical graphics
This commit is contained in:
parent
8180645199
commit
8d2f9690f3
8 changed files with 189 additions and 0 deletions
26
graphics/scigraphica/Makefile
Normal file
26
graphics/scigraphica/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/01/15 12:37:57 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= sg-0.6.1
|
||||
PKGNAME= scigraphica-0.6.1
|
||||
CATEGORIES= graphics math
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=scigraphica/}
|
||||
|
||||
MAINTAINER= drochner@netbsd.org
|
||||
HOMEPAGE= http://scigraphica.sourceforge.net/
|
||||
|
||||
DEPENDS+= gtk+-*:../../x11/gtk
|
||||
DEPENDS+= gtk+extra>=0.99.12:../../x11/gtk+extra
|
||||
DEPENDS+= imlib-*:../../graphics/imlib
|
||||
DEPENDS+= libxml-*:../../textproc/libxml
|
||||
DEPENDS+= python-*:../../lang/python
|
||||
DEPENDS+= py-Numeric-*:../../math/py-Numeric
|
||||
DEPENDS+= readline>=4.0:../../devel/readline
|
||||
|
||||
USE_X11= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= YES
|
||||
USE_LIBTOOL= yes
|
||||
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
graphics/scigraphica/files/md5
Normal file
3
graphics/scigraphica/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 2001/01/15 12:37:57 drochner Exp $
|
||||
|
||||
MD5 (sg-0.6.1.tar.gz) = af1dec0dc6d2b1ec935eec76cf1ef020
|
4
graphics/scigraphica/files/patch-sum
Normal file
4
graphics/scigraphica/files/patch-sum
Normal file
|
@ -0,0 +1,4 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 2001/01/15 12:37:57 drochner Exp $
|
||||
|
||||
MD5 (patch-aa) = c269b6d32d1f5593b6fcce6c1d98bbd2
|
||||
MD5 (patch-ab) = 54593b85de994cabd167346003dc7aaf
|
18
graphics/scigraphica/patches/patch-aa
Normal file
18
graphics/scigraphica/patches/patch-aa
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/01/15 12:37:57 drochner Exp $
|
||||
|
||||
--- configure.orig Tue Dec 5 17:05:56 2000
|
||||
+++ configure Wed Dec 13 14:23:33 2000
|
||||
@@ -3547,12 +3547,7 @@
|
||||
if test -f $PY_PREFIX/include/python$PY_VERSION/Python.h; then
|
||||
PY_LIBS="python$PY_VERSION"
|
||||
PY_LIB_LOC="-L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config"
|
||||
- array_loc=`find $PY_PREFIX/include/python$PY_VERSION/ -name arrayobject.h -printf %h`
|
||||
- if test -z $array_loc; then
|
||||
- if test -n $PYTHONPATH; then
|
||||
- array_loc=$PYTHONPATH
|
||||
- fi
|
||||
- fi
|
||||
+ array_loc=$PY_PREFIX/include/python$PY_VERSION/Numeric
|
||||
echo arrayobject.h location: $array_loc
|
||||
PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION"
|
||||
if test -n $array_loc; then
|
13
graphics/scigraphica/patches/patch-ab
Normal file
13
graphics/scigraphica/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2001/01/15 12:37:57 drochner Exp $
|
||||
|
||||
--- src/Makefile.in.orig Tue Dec 5 17:06:49 2000
|
||||
+++ src/Makefile.in Wed Dec 13 15:36:26 2000
|
||||
@@ -139,7 +139,7 @@
|
||||
|
||||
DEFS = @DEFS@ -I. -I$(srcdir) -I..
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
-LDFLAGS = @LDFLAGS@
|
||||
+LDFLAGS = @LDFLAGS@ -export-dynamic
|
||||
sga_OBJECTS = sg.o sg_arrange_dialog.o sg_axis_dialog.o sg_clipboard.o \
|
||||
sg_column_dialog.o sg_dataset.o sg_dataset_dialog.o sg_dialogs.o \
|
||||
sg_edit_function_dialog.o sg_ellipse_dialog.o sg_entry.o sg_file.o \
|
1
graphics/scigraphica/pkg/COMMENT
Normal file
1
graphics/scigraphica/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
data analysis and technical graphics
|
6
graphics/scigraphica/pkg/DESCR
Normal file
6
graphics/scigraphica/pkg/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
SciGraphica is a scientific application for data analysis and technical
|
||||
graphics. It pretends to be a clone of the popular commercial (and expensive)
|
||||
application "Microcal Origin". It fully supplies plotting features for 2D, 3D
|
||||
and polar charts. The aim is to obtain a fully-featured, cross-plattform,
|
||||
user-friendly, self-growing scientific application. It is free and open-source,
|
||||
released under the GPL license.
|
118
graphics/scigraphica/pkg/PLIST
Normal file
118
graphics/scigraphica/pkg/PLIST
Normal file
|
@ -0,0 +1,118 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/01/15 12:37:57 drochner Exp $
|
||||
bin/sga
|
||||
share/examples/3d.sg
|
||||
share/examples/multicolumn.sg
|
||||
share/examples/polar.sg
|
||||
share/examples/simpletest.sg
|
||||
share/examples/trigonometric.sg
|
||||
share/examples/vectors.sg
|
||||
share/examples/test.dat
|
||||
share/pixmaps/2d_small.xpm
|
||||
share/pixmaps/3d_small.xpm
|
||||
share/pixmaps/add_column.xpm
|
||||
share/pixmaps/arrange.xpm
|
||||
share/pixmaps/arrow.xpm
|
||||
share/pixmaps/arrow2.xpm
|
||||
share/pixmaps/arrow_down.xpm
|
||||
share/pixmaps/arrow_left.xpm
|
||||
share/pixmaps/arrow_right.xpm
|
||||
share/pixmaps/arrow_up.xpm
|
||||
share/pixmaps/autoscale.xpm
|
||||
share/pixmaps/bold.xpm
|
||||
share/pixmaps/bullet.xpm
|
||||
share/pixmaps/center.xpm
|
||||
share/pixmaps/color.xpm
|
||||
share/pixmaps/control.xpm
|
||||
share/pixmaps/copy.xpm
|
||||
share/pixmaps/cut.xpm
|
||||
share/pixmaps/dennied.xpm
|
||||
share/pixmaps/empty.xpm
|
||||
share/pixmaps/error.xpm
|
||||
share/pixmaps/fitpage.xpm
|
||||
share/pixmaps/folder.xpm
|
||||
share/pixmaps/font.xpm
|
||||
share/pixmaps/font_large.xpm
|
||||
share/pixmaps/function_small.xpm
|
||||
share/pixmaps/g_2dlayer.xpm
|
||||
share/pixmaps/g_3dcontour.xpm
|
||||
share/pixmaps/g_3dlayer.xpm
|
||||
share/pixmaps/g_bars.xpm
|
||||
share/pixmaps/g_boxes.xpm
|
||||
share/pixmaps/g_bubbles.xpm
|
||||
share/pixmaps/g_bubbles3d.xpm
|
||||
share/pixmaps/g_colors.xpm
|
||||
share/pixmaps/g_colors3d.xpm
|
||||
share/pixmaps/g_contour.xpm
|
||||
share/pixmaps/g_csurface.xpm
|
||||
share/pixmaps/g_density.xpm
|
||||
share/pixmaps/g_flux3d.xpm
|
||||
share/pixmaps/g_function.xpm
|
||||
share/pixmaps/g_hbars.xpm
|
||||
share/pixmaps/g_hbox.xpm
|
||||
share/pixmaps/g_impulses.xpm
|
||||
share/pixmaps/g_lines.xpm
|
||||
share/pixmaps/g_lpoints.xpm
|
||||
share/pixmaps/g_python.xpm
|
||||
share/pixmaps/g_scatter.xpm
|
||||
share/pixmaps/g_scatter3d.xpm
|
||||
share/pixmaps/g_surface.xpm
|
||||
share/pixmaps/g_vectors.xpm
|
||||
share/pixmaps/italic.xpm
|
||||
share/pixmaps/layer.xpm
|
||||
share/pixmaps/left.xpm
|
||||
share/pixmaps/logo.xpm
|
||||
share/pixmaps/new.xpm
|
||||
share/pixmaps/new_2d.xpm
|
||||
share/pixmaps/new_2d_small.xpm
|
||||
share/pixmaps/new_3d.xpm
|
||||
share/pixmaps/new_3d_small.xpm
|
||||
share/pixmaps/new_function.xpm
|
||||
share/pixmaps/new_plot.xpm
|
||||
share/pixmaps/new_polar.xpm
|
||||
share/pixmaps/new_polar_small.xpm
|
||||
share/pixmaps/new_sheet.xpm
|
||||
share/pixmaps/open.xpm
|
||||
share/pixmaps/paint.xpm
|
||||
share/pixmaps/paste.xpm
|
||||
share/pixmaps/plot_icon.xpm
|
||||
share/pixmaps/plot_icon2.xpm
|
||||
share/pixmaps/plot_small.xpm
|
||||
share/pixmaps/point.xpm
|
||||
share/pixmaps/pointers.xpm
|
||||
share/pixmaps/polar_small.xpm
|
||||
share/pixmaps/print.xpm
|
||||
share/pixmaps/reload.xpm
|
||||
share/pixmaps/reset.xpm
|
||||
share/pixmaps/right.xpm
|
||||
share/pixmaps/rotate_x.xpm
|
||||
share/pixmaps/rotate_y.xpm
|
||||
share/pixmaps/rotate_z.xpm
|
||||
share/pixmaps/save.xpm
|
||||
share/pixmaps/save_as.xpm
|
||||
share/pixmaps/sg.xpm
|
||||
share/pixmaps/sheet_icon.xpm
|
||||
share/pixmaps/sheet_icon2.xpm
|
||||
share/pixmaps/sheet_small.xpm
|
||||
share/pixmaps/sorry.xpm
|
||||
share/pixmaps/symbol_circle.xpm
|
||||
share/pixmaps/symbol_cross.xpm
|
||||
share/pixmaps/symbol_diamond.xpm
|
||||
share/pixmaps/symbol_dntriangle.xpm
|
||||
share/pixmaps/symbol_dot.xpm
|
||||
share/pixmaps/symbol_impulse.xpm
|
||||
share/pixmaps/symbol_ltriangle.xpm
|
||||
share/pixmaps/symbol_none.xpm
|
||||
share/pixmaps/symbol_plus.xpm
|
||||
share/pixmaps/symbol_rtriangle.xpm
|
||||
share/pixmaps/symbol_square.xpm
|
||||
share/pixmaps/symbol_star.xpm
|
||||
share/pixmaps/symbol_uptriangle.xpm
|
||||
share/pixmaps/target.xpm
|
||||
share/pixmaps/text.xpm
|
||||
share/pixmaps/tools.xpm
|
||||
share/pixmaps/warning.xpm
|
||||
share/pixmaps/zoom.xpm
|
||||
share/pixmaps/zoom_minus.xpm
|
||||
share/pixmaps/zoom_plus.xpm
|
||||
share/pixmaps/sg_icon.xpm
|
||||
share/gnome/apps/Applications/sg.desktop
|
Loading…
Reference in a new issue