Also add python23's cursesmodule fix (patch-aa) here. It's named patch-ba

here since patch-aa already exists.
This commit is contained in:
recht 2004-04-09 23:10:36 +00:00
parent bcb05d60c2
commit 8d32594619
2 changed files with 88 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.12 2004/03/22 06:33:58 minskim Exp $
$NetBSD: distinfo,v 1.13 2004/04/09 23:10:36 recht Exp $
SHA1 (Python-2.3.3.tgz) = 034d2e3ed011ea753d4fee7efab16e31029b1e5e
Size (Python-2.3.3.tgz) = 8491380 bytes
@ -10,3 +10,4 @@ SHA1 (patch-af) = 2989a1975c8ea435903eafc9add57cb7c4d7de14
SHA1 (patch-ah) = 4bc95e775a2b3f4f1997d0779c561db2e9e7b575
SHA1 (patch-al) = 2dfed1a40493b571e3477cfb56c2d0ed1b1deddf
SHA1 (patch-am) = 74e8d87ecd4cb17634e992a985393c72193b2892
SHA1 (patch-ba) = dd8f89952d7f40c9a979e362758775f093e047bc

View file

@ -0,0 +1,86 @@
$NetBSD: patch-ba,v 1.3 2004/04/09 23:10:36 recht Exp $
--- Modules/_cursesmodule.c.orig 2002-11-21 15:17:51.000000000 +0100
+++ Modules/_cursesmodule.c 2004-04-09 12:45:06.000000000 +0200
@@ -313,17 +313,9 @@
Window_OneArgNoReturnFunction(wattrset, attr_t, "l;attr")
Window_OneArgNoReturnFunction(clearok, int, "i;True(1) or False(0)")
Window_OneArgNoReturnFunction(idlok, int, "i;True(1) or False(0)")
-#if defined(__NetBSD__)
-Window_OneArgNoReturnVoidFunction(keypad, int, "i;True(1) or False(0)")
-#else
Window_OneArgNoReturnFunction(keypad, int, "i;True(1) or False(0)")
-#endif
Window_OneArgNoReturnFunction(leaveok, int, "i;True(1) or False(0)")
-#if defined(__NetBSD__)
-Window_OneArgNoReturnVoidFunction(nodelay, int, "i;True(1) or False(0)")
-#else
Window_OneArgNoReturnFunction(nodelay, int, "i;True(1) or False(0)")
-#endif
Window_OneArgNoReturnFunction(notimeout, int, "i;True(1) or False(0)")
Window_OneArgNoReturnFunction(scrollok, int, "i;True(1) or False(0)")
Window_OneArgNoReturnFunction(winsdelln, int, "i;nlines")
@@ -784,11 +776,7 @@
} else if (rtn<=255)
return Py_BuildValue("c", rtn);
else
-#if defined(__NetBSD__)
- return PyString_FromString(unctrl(rtn));
-#else
return PyString_FromString((char *)keyname(rtn));
-#endif
}
static PyObject *
@@ -1946,7 +1934,6 @@
return PyCursesCheckERR(intrflush(NULL,ch), "intrflush");
}
-#if !defined(__NetBSD__)
static PyObject *
PyCurses_KeyName(PyObject *self, PyObject *args)
{
@@ -1965,7 +1952,6 @@
return PyString_FromString((knp == NULL) ? "" : (char *)knp);
}
-#endif
static PyObject *
PyCurses_KillChar(PyObject *self)
@@ -2392,9 +2378,7 @@
{"initscr", (PyCFunction)PyCurses_InitScr, METH_NOARGS},
{"intrflush", (PyCFunction)PyCurses_IntrFlush, METH_VARARGS},
{"isendwin", (PyCFunction)PyCurses_isendwin, METH_NOARGS},
-#if !defined(__NetBSD__)
{"keyname", (PyCFunction)PyCurses_KeyName, METH_VARARGS},
-#endif
{"killchar", (PyCFunction)PyCurses_KillChar, METH_NOARGS},
{"longname", (PyCFunction)PyCurses_longname, METH_NOARGS},
{"meta", (PyCFunction)PyCurses_Meta, METH_VARARGS},
@@ -2490,9 +2474,7 @@
SetDictInt("A_DIM", A_DIM);
SetDictInt("A_BOLD", A_BOLD);
SetDictInt("A_ALTCHARSET", A_ALTCHARSET);
-#if !defined(__NetBSD__)
SetDictInt("A_INVIS", A_INVIS);
-#endif
SetDictInt("A_PROTECT", A_PROTECT);
SetDictInt("A_CHARTEXT", A_CHARTEXT);
SetDictInt("A_COLOR", A_COLOR);
@@ -2564,7 +2546,6 @@
int key;
char *key_n;
char *key_n2;
-#if !defined(__NetBSD__)
for (key=KEY_MIN;key < KEY_MAX; key++) {
key_n = (char *)keyname(key);
if (key_n == NULL || strcmp(key_n,"UNKNOWN KEY")==0)
@@ -2588,7 +2569,6 @@
if (key_n2 != key_n)
free(key_n2);
}
-#endif
SetDictInt("KEY_MIN", KEY_MIN);
SetDictInt("KEY_MAX", KEY_MAX);
}