Fix build problem caused by inconsistent function declaration which got

exposed by the recent update of the "libcdio" package.
This commit is contained in:
tron 2004-10-07 10:02:09 +00:00
parent 5345a62e3d
commit 8d68d3dbcb
2 changed files with 15 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.4 2004/04/19 17:58:25 drochner Exp $
$NetBSD: distinfo,v 1.5 2004/10/07 10:02:09 tron Exp $
SHA1 (vcdimager-0.7.20.tar.gz) = b75c9253bbd9f72f8b64b739e0c15bed5ac83bde
Size (vcdimager-0.7.20.tar.gz) = 954324 bytes
SHA1 (patch-aa) = 6cf7c87a391e25addb324c37a9f929813725c712
SHA1 (patch-ab) = 6304d85224534797f52e14d283d79cf1e2be2f3f

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.3 2004/10/07 10:02:09 tron Exp $
--- lib/image.c.orig 2003-11-10 12:57:49.000000000 +0100
+++ lib/image.c 2004-10-07 11:57:38.000000000 +0200
@@ -76,7 +76,7 @@
}
int
-vcd_image_sink_write (VcdImageSink *obj, void *buf, uint32_t lsn)
+vcd_image_sink_write (VcdImageSink *obj, void *buf, lsn_t lsn)
{
vcd_assert (obj != NULL);